summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--REFLECTION29
-rw-r--r--php-pecl-xdebug.spec12
2 files changed, 34 insertions, 7 deletions
diff --git a/REFLECTION b/REFLECTION
index 7f0ca06..9700cf3 100644
--- a/REFLECTION
+++ b/REFLECTION
@@ -1,4 +1,4 @@
-Extension [ <persistent> extension #184 xdebug version 2.2.7 ] {
+Extension [ <persistent> extension #188 xdebug version 2.3.0 ] {
- INI {
Entry [ xdebug.auto_trace <ALL> ]
@@ -7,6 +7,9 @@ Extension [ <persistent> extension #184 xdebug version 2.2.7 ] {
Entry [ xdebug.trace_enable_trigger <PERDIR,SYSTEM> ]
Current = '0'
}
+ Entry [ xdebug.trace_enable_trigger_value <PERDIR,SYSTEM> ]
+ Current = ''
+ }
Entry [ xdebug.trace_output_dir <ALL> ]
Current = '/tmp'
}
@@ -46,10 +49,22 @@ Extension [ <persistent> extension #184 xdebug version 2.2.7 ] {
Entry [ xdebug.file_link_format <ALL> ]
Current = ''
}
+ Entry [ xdebug.force_display_errors <SYSTEM> ]
+ Current = '0'
+ }
+ Entry [ xdebug.force_error_reporting <SYSTEM> ]
+ Current = '0'
+ }
+ Entry [ xdebug.halt_level <ALL> ]
+ Current = '0'
+ }
Entry [ xdebug.max_nesting_level <ALL> ]
Current = '1000'
}
- Entry [ xdebug.overload_var_dump <PERDIR,SYSTEM> ]
+ Entry [ xdebug.max_stack_frames <ALL> ]
+ Current = '-1'
+ }
+ Entry [ xdebug.overload_var_dump <ALL> ]
Current = '1'
}
Entry [ xdebug.show_exception_trace <ALL> ]
@@ -106,6 +121,9 @@ Extension [ <persistent> extension #184 xdebug version 2.2.7 ] {
Entry [ xdebug.profiler_enable_trigger <PERDIR,SYSTEM> ]
Current = '0'
}
+ Entry [ xdebug.profiler_enable_trigger_value <PERDIR,SYSTEM> ]
+ Current = ''
+ }
Entry [ xdebug.profiler_append <PERDIR,SYSTEM> ]
Current = '0'
}
@@ -159,12 +177,15 @@ Extension [ <persistent> extension #184 xdebug version 2.2.7 ] {
}
}
- - Constants [5] {
+ - Constants [8] {
Constant [ integer XDEBUG_TRACE_APPEND ] { 1 }
Constant [ integer XDEBUG_TRACE_COMPUTERIZED ] { 2 }
Constant [ integer XDEBUG_TRACE_HTML ] { 4 }
+ Constant [ integer XDEBUG_TRACE_NAKED_FILENAME ] { 8 }
Constant [ integer XDEBUG_CC_UNUSED ] { 1 }
Constant [ integer XDEBUG_CC_DEAD_CODE ] { 2 }
+ Constant [ integer XDEBUG_CC_BRANCH_CHECK ] { 4 }
+ Constant [ integer XDEBUG_STACK_NO_DESC ] { 1 }
}
- Functions {
@@ -230,6 +251,8 @@ Extension [ <persistent> extension #184 xdebug version 2.2.7 ] {
}
Function [ <internal:xdebug> function xdebug_get_code_coverage ] {
}
+ Function [ <internal:xdebug> function xdebug_code_coverage_started ] {
+ }
Function [ <internal:xdebug> function xdebug_get_function_count ] {
}
Function [ <internal:xdebug> function xdebug_dump_superglobals ] {
diff --git a/php-pecl-xdebug.spec b/php-pecl-xdebug.spec
index 78685b3..bbbe58a 100644
--- a/php-pecl-xdebug.spec
+++ b/php-pecl-xdebug.spec
@@ -29,8 +29,8 @@
Name: %{?scl_prefix}php-pecl-xdebug
Summary: PECL package for debugging PHP scripts
-Version: 2.2.7
-Release: 2%{?dist}%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}
+Version: 2.3.0
+Release: 1%{?dist}%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}
%if 0%{?gitver:1}
Source0: https://github.com/%{pecl_name}/%{pecl_name}/archive/%{commit}/%{pecl_name}-%{version}-%{gitver}.tar.gz
%else
@@ -44,8 +44,8 @@ Group: Development/Languages
URL: http://xdebug.org/
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
-BuildRequires: %{?scl_prefix}php-pear
-BuildRequires: %{?scl_prefix}php-devel
+BuildRequires: %{?scl_prefix}php-pear > 1.9.1
+BuildRequires: %{?scl_prefix}php-devel > 5.4
BuildRequires: libedit-devel
BuildRequires: libtool
@@ -259,6 +259,10 @@ rm -rf %{buildroot}
%changelog
+* Mon Feb 23 2015 Remi Collet <remi@fedoraproject.org> - 2.3.0-1
+- Update to 2.3.0
+- raise minimum php version to 5.4
+
* Fri Jan 23 2015 Remi Collet <remi@fedoraproject.org> - 2.2.7-2
- fix %%postun scriplet