summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--0001-zif_handler-exists-in-7.2.patch25
-rw-r--r--PHPINFO2
-rw-r--r--REFLECTION2
-rw-r--r--php-pecl-xdebug.spec18
4 files changed, 8 insertions, 39 deletions
diff --git a/0001-zif_handler-exists-in-7.2.patch b/0001-zif_handler-exists-in-7.2.patch
deleted file mode 100644
index 6a78d56..0000000
--- a/0001-zif_handler-exists-in-7.2.patch
+++ /dev/null
@@ -1,25 +0,0 @@
-From 464804a13e49ce22b499ae0243657b2e4e32a4e2 Mon Sep 17 00:00:00 2001
-From: Remi Collet <remi@remirepo.net>
-Date: Fri, 21 Sep 2018 09:33:19 +0200
-Subject: [PATCH] zif_handler exists in 7.2
-
----
- xdebug_compat.h | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
-diff --git a/xdebug_compat.h b/xdebug_compat.h
-index ac8741bb..938b7074 100644
---- a/xdebug_compat.h
-+++ b/xdebug_compat.h
-@@ -75,7 +75,7 @@ zend_bool xdebug_zend_hash_apply_protection_end(HashTable* ht);
- # define XDEBUG_ZEND_CONSTANT_MODULE_NUMBER(v) ((v)->module_number)
- # endif
-
--# if PHP_VERSION_ID < 70300
-+# if PHP_VERSION_ID < 70200
- typedef void (*zif_handler)(INTERNAL_FUNCTION_PARAMETERS);
- # endif
-
---
-2.14.4
-
diff --git a/PHPINFO b/PHPINFO
index 2719735..314c118 100644
--- a/PHPINFO
+++ b/PHPINFO
@@ -2,7 +2,7 @@
xdebug
xdebug support => enabled
-Version => 2.7.0beta1
+Version => 2.7.0rc1
IDE Key => remi
Supported protocols
diff --git a/REFLECTION b/REFLECTION
index bfa0e6d..03213b4 100644
--- a/REFLECTION
+++ b/REFLECTION
@@ -1,4 +1,4 @@
-Extension [ <persistent> extension #200 xdebug version 2.7.0beta1 ] {
+Extension [ <persistent> extension #201 xdebug version 2.7.0rc1 ] {
- INI {
Entry [ xdebug.auto_trace <ALL> ]
diff --git a/php-pecl-xdebug.spec b/php-pecl-xdebug.spec
index aad6295..f3608b4 100644
--- a/php-pecl-xdebug.spec
+++ b/php-pecl-xdebug.spec
@@ -19,12 +19,12 @@
%global pecl_name xdebug
%global with_zts 0%{!?_without_zts:%{?__ztsphp:1}}
-%global gh_commit a264af33ac6cea474bd155d3c2d346f6d9dc88ac
+%global gh_commit 8c1aa33d1c630d59a464e9dcefc0d63ba627d0c8
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
#global gh_date 20171202
%global with_tests 0%{!?_without_tests:1}
%global upstream_version 2.7.0
-%global upstream_prever beta1
+%global upstream_prever rc1
# XDebug should be loaded after opcache
%global ini_name 15-%{pecl_name}.ini
@@ -35,7 +35,7 @@ Version: %{upstream_version}%{?upstream_prever:~%{upstream_prever}}
%if 0%{?gh_date:1}
Release: 0.8.%{gh_date}.%{gh_short}%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
%else
-Release: 2%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
+Release: 1%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
%endif
# The Xdebug License, version 1.01
@@ -44,8 +44,6 @@ License: BSD
URL: https://xdebug.org/
Source0: https://github.com/%{pecl_name}/%{pecl_name}/archive/%{gh_commit}/%{pecl_name}-%{upstream_version}%{?upstream_prever}-%{gh_short}.tar.gz
-Patch0: 0001-zif_handler-exists-in-7.2.patch
-
BuildRequires: %{?dtsprefix}gcc
BuildRequires: %{?scl_prefix}php-devel > 7
BuildRequires: %{?scl_prefix}php-pear
@@ -140,8 +138,6 @@ mv NTS/package.xml .
%{?_licensedir:sed -e '/LICENSE/s/role="doc"/role="src"/' -i package.xml}
cd NTS
-%patch0 -p1
-
# Check extension version
ver=$(sed -n '/XDEBUG_VERSION/{s/.* "//;s/".*$//;p}' php_xdebug.h)
if test "$ver" != "%{upstream_version}%{?upstream_prever}%{?gh_date:-dev}"; then
@@ -250,11 +246,6 @@ done
%if %{with_tests}
cd NTS
-: Ignore test failing with recent version
-rm tests/bug01195-php71.phpt
-rm tests/bug01210-php71.phpt
-rm tests/bug01486-001.phpt
-
: Upstream test suite NTS extension
# bug00886 is marked as slow as it uses a lot of disk space
SKIP_SLOW_TESTS=1 \
@@ -304,6 +295,9 @@ fi
%changelog
+* Sat Feb 2 2019 Remi Collet <remi@remirepo.net> - 2.7.0~rc1-1
+- update to 2.7.0RC1
+
* Thu Jan 17 2019 Remi Collet <remi@remirepo.net> - 2.7.0~beta1-2
- fix SCL dependency