summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--REFLECTION2
-rw-r--r--php-pecl-xdebug.spec30
-rw-r--r--xdebug-upstream.patch89
3 files changed, 19 insertions, 102 deletions
diff --git a/REFLECTION b/REFLECTION
index 6132ea1..7f0ca06 100644
--- a/REFLECTION
+++ b/REFLECTION
@@ -1,4 +1,4 @@
-Extension [ <persistent> extension #185 xdebug version 2.2.6 ] {
+Extension [ <persistent> extension #184 xdebug version 2.2.7 ] {
- INI {
Entry [ xdebug.auto_trace <ALL> ]
diff --git a/php-pecl-xdebug.spec b/php-pecl-xdebug.spec
index 2da9ca4..44816ab 100644
--- a/php-pecl-xdebug.spec
+++ b/php-pecl-xdebug.spec
@@ -29,18 +29,14 @@
Name: %{?scl_prefix}php-pecl-xdebug
Summary: PECL package for debugging PHP scripts
-Version: 2.2.6
-Release: 3%{?dist}%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}.1
+Version: 2.2.7
+Release: 1%{?dist}%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}
%if 0%{?gitver:1}
Source0: https://github.com/%{pecl_name}/%{pecl_name}/archive/%{commit}/%{pecl_name}-%{version}-%{gitver}.tar.gz
%else
Source0: http://pecl.php.net/get/%{pecl_name}-%{version}%{?prever}.tgz
%endif
-# http://bugs.xdebug.org/view.php?id=1087
-# https://www.couchbase.com/issues/browse/PCBC-294
-Patch0: %{pecl_name}-upstream.patch
-
# The Xdebug License, version 1.01
# (Based on "The PHP License", version 3.0)
License: PHP
@@ -119,8 +115,6 @@ mv %{pecl_name}-%{version}%{?prever} NTS
%endif
cd NTS
-%patch0 -p1 -b .upstream
-
# Check extension version
ver=$(sed -n '/XDEBUG_VERSION/{s/.* "//;s/".*$//;p}' php_xdebug.h)
if test "$ver" != "%{version}%{?prever}"; then
@@ -228,13 +222,21 @@ done
%endif
-%post
-%{pecl_install} %{pecl_xmldir}/%{name}.xml >/dev/null || :
+# when pear installed alone, after us
+%triggerin -- %{?scl_prefix}php-pear
+if [ -x %{__pecl} ] ; then
+ %{pecl_install} %{pecl_xmldir}/%{name}.xml >/dev/null || :
+fi
+# posttrans as pear can be installed after us
+%posttrans
+if [ -x %{__pecl} ] ; then
+ %{pecl_install} %{pecl_xmldir}/%{name}.xml >/dev/null || :
+fi
%postun
-if [ $1 -eq 0 ] ; then
- %{pecl_uninstall} %{pecl_name} >/dev/null || :
+if [ $1 -eq 0 -a -x %{__pecl} ] ; then
+ %{pecl_uninstall} %{proj_name} >/dev/null || :
fi
@@ -259,6 +261,10 @@ rm -rf %{buildroot}
%changelog
+* Thu Jan 22 2015 Remi Collet <remi@fedoraproject.org> - 2.2.7-1
+- Update to 2.2.7
+- drop runtime dependency on pear, new scriptlets
+
* Wed Dec 24 2014 Remi Collet <remi@fedoraproject.org> - 2.2.6-3.1
- Fedora 21 SCL mass rebuild
diff --git a/xdebug-upstream.patch b/xdebug-upstream.patch
deleted file mode 100644
index f319af3..0000000
--- a/xdebug-upstream.patch
+++ /dev/null
@@ -1,89 +0,0 @@
-From a55460a63144ba32d3817c1e70a091a579c44478 Mon Sep 17 00:00:00 2001
-From: Derick Rethans <github@derickrethans.nl>
-Date: Sun, 23 Nov 2014 17:53:30 +0000
-Subject: [PATCH] Fixed bug #1087: zend_execute_script or zend_eval_string in
- RINIT segfaults.
-
----
- xdebug.c | 4 +++-
- 1 file changed, 3 insertions(+), 1 deletion(-)
-
-diff --git a/xdebug.c b/xdebug.c
-index 8bd4f61..1b3517c 100644
---- a/xdebug.c
-+++ b/xdebug.c
-@@ -1588,7 +1588,9 @@ void xdebug_execute_internal(zend_execute_data *current_execute_data, struct _ze
- }
- }
-
-- xdebug_llist_remove(XG(stack), XDEBUG_LLIST_TAIL(XG(stack)), xdebug_stack_element_dtor);
-+ if (XG(stack)) {
-+ xdebug_llist_remove(XG(stack), XDEBUG_LLIST_TAIL(XG(stack)), xdebug_stack_element_dtor);
-+ }
- XG(level)--;
- }
-
-From dcb38d5053e9df32506aeabc8eb09d8370e5641f Mon Sep 17 00:00:00 2001
-From: Derick Rethans <github@derickrethans.nl>
-Date: Sun, 23 Nov 2014 22:51:43 +0000
-Subject: [PATCH] Fixed segfaults with ZTS on PHP 5.6
-
-Find through Travis, it's already being useful!
----
- xdebug.c | 2 ++
- 1 file changed, 2 insertions(+)
-
-diff --git a/xdebug.c b/xdebug.c
-index 1b3517c..b8c9d5a 100644
---- a/xdebug.c
-+++ b/xdebug.c
-@@ -314,6 +314,8 @@ static void php_xdebug_init_globals (zend_xdebug_globals *xg TSRMLS_DC)
- xg->output_is_tty = OUTPUT_NOT_CHECKED;
- xg->stdout_mode = 0;
- xg->in_at = 0;
-+ xg->active_execute_data = NULL;
-+ xg->active_op_array = NULL;
-
- xdebug_llist_init(&xg->server, xdebug_superglobals_dump_dtor);
- xdebug_llist_init(&xg->get, xdebug_superglobals_dump_dtor);
-From 693cfae8345fd1554a15a933c5aaa26e5c70cb93 Mon Sep 17 00:00:00 2001
-From: Derick Rethans <github@derickrethans.nl>
-Date: Wed, 3 Dec 2014 12:36:10 +0000
-Subject: [PATCH] Running scripts in RINIT is really not a good idea guys!
-
----
- xdebug.c | 14 +++++++++++++-
- 1 file changed, 13 insertions(+), 1 deletion(-)
-
-diff --git a/xdebug.c b/xdebug.c
-index 3c1340c..8867507 100644
---- a/xdebug.c
-+++ b/xdebug.c
-@@ -316,6 +316,18 @@ static void php_xdebug_init_globals (zend_xdebug_globals *xg TSRMLS_DC)
- xg->in_at = 0;
- xg->active_execute_data = NULL;
- xg->active_op_array = NULL;
-+ xg->no_exec = 0;
-+ xg->context.program_name = NULL;
-+ xg->context.list.last_file = NULL;
-+ xg->context.list.last_line = 0;
-+ xg->context.do_break = 0;
-+ xg->context.do_step = 0;
-+ xg->context.do_next = 0;
-+ xg->context.do_finish = 0;
-+ xg->in_execution = 0;
-+ xg->remote_enabled = 0;
-+ xg->breakpoints_allowed = 0;
-+ xg->profiler_enabled = 0;
-
- xdebug_llist_init(&xg->server, xdebug_superglobals_dump_dtor);
- xdebug_llist_init(&xg->get, xdebug_superglobals_dump_dtor);
-@@ -1392,7 +1404,7 @@ void xdebug_execute_ex(zend_execute_data *execute_data TSRMLS_DC)
- #endif
- fse->This = EG(This);
-
-- if (XG(remote_enabled) || XG(collect_vars) || XG(show_local_vars)) {
-+ if (XG(stack) && (XG(remote_enabled) || XG(collect_vars) || XG(show_local_vars))) {
- /* Because include/require is treated as a stack level, we have to add used
- * variables in include/required files to all the stack levels above, until
- * we hit a function or the top level stack. This is so that the variables