summaryrefslogtreecommitdiffstats
path: root/php-pecl-xdebug.spec
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2016-03-04 08:23:25 +0100
committerRemi Collet <fedora@famillecollet.com>2016-03-04 08:23:25 +0100
commit30caa7b804f53b2169a457b870edaf4ad6686829 (patch)
tree63a9b9fba568fe17826b4891053db7f7b6a4f0a7 /php-pecl-xdebug.spec
parentaf01d8335e036eb333d6738fbdc7a04255974afb (diff)
php-pecl-xdebug: switch the dev spec
Diffstat (limited to 'php-pecl-xdebug.spec')
-rw-r--r--php-pecl-xdebug.spec66
1 files changed, 49 insertions, 17 deletions
diff --git a/php-pecl-xdebug.spec b/php-pecl-xdebug.spec
index 47bc134..b2ce223 100644
--- a/php-pecl-xdebug.spec
+++ b/php-pecl-xdebug.spec
@@ -18,10 +18,12 @@
%{!?__php: %global __php %{_bindir}/php}
%global pecl_name xdebug
-%global with_zts 0%{?__ztsphp:1}
-%global gh_commit 2d2bdbc7948aa72143df0c5fc0eb684078732bf9
+%global with_zts 0%{!?_without_zts:%{?__ztsphp:1}}
+%global gh_commit 148ed8b2a9a8e8d1e19cca82b364f3bfb23cdf92
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
+#global gh_date 20151118
%global with_tests 0%{?_with_tests:1}
+%global prever RC4
# XDebug should be loaded after opcache
%if "%{php_version}" < "5.6"
@@ -32,9 +34,9 @@
Name: %{?scl_prefix}php-pecl-xdebug
Summary: PECL package for debugging PHP scripts
-Version: 2.3.3
-Release: 1%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
-Source0: https://github.com/%{pecl_name}/%{pecl_name}/archive/%{gh_commit}/%{pecl_name}-%{version}-%{gh_short}.tar.gz
+Version: 2.4.0
+Release: 0.8.%{prever}%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
+Source0: https://github.com/%{pecl_name}/%{pecl_name}/archive/%{gh_commit}/%{pecl_name}-%{version}%{?prever}-%{gh_short}.tar.gz
# The Xdebug License, version 1.01
# (Based on "The PHP License", version 3.0)
@@ -59,6 +61,8 @@ Provides: %{?scl_prefix}php-%{pecl_name} = %{version}
Provides: %{?scl_prefix}php-%{pecl_name}%{?_isa} = %{version}
Provides: %{?scl_prefix}php-pecl(Xdebug) = %{version}
Provides: %{?scl_prefix}php-pecl(Xdebug)%{?_isa} = %{version}
+Provides: %{?scl_prefix}php-pecl-%{pecl_name} = %{version}-%{release}
+Provides: %{?scl_prefix}php-pecl-%{pecl_name}%{?_isa} = %{version}-%{release}
%if "%{?vendor}" == "Remi Collet" && 0%{!?scl:1}
# Other third party repo stuff
@@ -74,6 +78,10 @@ Obsoletes: php55w-pecl-%{pecl_name} <= %{version}
Obsoletes: php56u-pecl-%{pecl_name} <= %{version}
Obsoletes: php56w-pecl-%{pecl_name} <= %{version}
%endif
+%if "%{php_version}" > "7.0"
+Obsoletes: php70u-pecl-%{pecl_name} <= %{version}
+Obsoletes: php70w-pecl-%{pecl_name} <= %{version}
+%endif
%endif
%if 0%{?fedora} < 20 && 0%{?rhel} < 7
@@ -109,6 +117,8 @@ Package built for PHP %(%{__php} -r 'echo PHP_MAJOR_VERSION.".".PHP_MINOR_VERSIO
mv %{pecl_name}-%{gh_commit} NTS
mv NTS/package.xml .
+%{?_licensedir:sed -e '/LICENSE/s/role="doc"/role="src"/' -i package.xml}
+
cd NTS
# Check extension version
@@ -220,21 +230,21 @@ done
%if %{with_tests}
cd NTS
# ignore kwown failed tests
-rm tests/bug00623.phpt
-rm tests/bug00687.phpt
-rm tests/bug00778.phpt
-rm tests/bug00806.phpt
-rm tests/bug00840.phpt
-rm tests/bug00886.phpt
-rm tests/bug00913.phpt
-rm tests/bug01059.phpt
-rm tests/bug01104.phpt
-rm tests/dbgp-context-get.phpt
-rm tests/dbgp-property-get-constants.phpt
+#rm tests/bug00623.phpt
+#rm tests/bug00687.phpt
+#rm tests/bug00778.phpt
+#rm tests/bug00806.phpt
+#rm tests/bug00840.phpt
+#rm tests/bug00886.phpt
+#rm tests/bug00913.phpt
+#rm tests/bug01059.phpt
+#rm tests/bug01104.phpt
+#rm tests/dbgp-context-get.phpt
+#rm tests/dbgp-property-get-constants.phpt
: Upstream test suite NTS extension
TEST_PHP_EXECUTABLE=%{_bindir}/php \
-TEST_PHP_ARGS="-n -d extension=soap.so -d zend_extension=$PWD/modules/%{pecl_name}.so" \
+TEST_PHP_ARGS="-n -d extension=soap.so -d zend_extension=%{buildroot}%{php_extdir}/%{pecl_name}.so" \
NO_INTERACTION=1 \
REPORT_EXIT_STATUS=1 \
%{__php} -n run-tests.php --show-diff
@@ -282,6 +292,28 @@ rm -rf %{buildroot}
%changelog
+* Wed Jan 27 2016 Remi Collet <remi@fedoraproject.org> - 2.4.0-0.8.RC4
+- update to 2.4.0RC4
+
+* Sun Dec 13 2015 Remi Collet <remi@fedoraproject.org> - 2.4.0-0.7.RC3
+- update to 2.4.0RC3
+
+* Thu Dec 3 2015 Remi Collet <remi@fedoraproject.org> - 2.4.0-0.6.RC2
+- update to 2.4.0RC2
+
+* Wed Nov 25 2015 Remi Collet <remi@fedoraproject.org> - 2.4.0-0.5.RC1
+- update to 2.4.0RC1
+
+* Thu Nov 19 2015 Remi Collet <remi@fedoraproject.org> - 2.4.0-0.4.20151118git7e4523e
+- git snapshot, fix segfault with create_function
+
+* Mon Nov 9 2015 Remi Collet <remi@fedoraproject.org> - 2.4.0-0.2.beta1
+- add 1 upstream patch (segfault in code coverage)
+ http://bugs.xdebug.org/view.php?id=1195
+
+* Thu Nov 5 2015 Remi Collet <remi@fedoraproject.org> - 2.4.0-0.1.beta1
+- update to 2.4.0beta1
+
* Fri Jun 19 2015 Remi Collet <remi@fedoraproject.org> - 2.3.3-1
- update to 2.3.3
- drop all patches, merged upstream