summaryrefslogtreecommitdiffstats
path: root/php-pecl-xdebug-dev.spec
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2016-06-10 12:18:11 +0200
committerRemi Collet <fedora@famillecollet.com>2016-06-10 12:18:11 +0200
commit73254153bbc41ee7ba14e1cd8678c93d70d7badf (patch)
tree7dbf3c6c1453a4577b9a5163d90cb3e7becc93dc /php-pecl-xdebug-dev.spec
parentee4fd7117618fffccd490a564e7eea2aa796ffc0 (diff)
php-pecl-xdebug: 2.5.0-dev (for PHP 7.1)
Diffstat (limited to 'php-pecl-xdebug-dev.spec')
-rw-r--r--php-pecl-xdebug-dev.spec38
1 files changed, 32 insertions, 6 deletions
diff --git a/php-pecl-xdebug-dev.spec b/php-pecl-xdebug-dev.spec
index e0f8c68..e7f18ff 100644
--- a/php-pecl-xdebug-dev.spec
+++ b/php-pecl-xdebug-dev.spec
@@ -16,9 +16,9 @@
%global pecl_name xdebug
%global with_zts 0%{!?_without_zts:%{?__ztsphp:1}}
-%global gh_commit 821c1fd2e09e65a9d33414ce7ce234e2ea6fdf83
+%global gh_commit 78fa98b7e54180c8f4003c5ca3b01bfa67c2c561
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
-#global gh_date 20151118
+%global gh_date 20160529
%global with_tests 0%{?_with_tests:1}
#global prever RC4
@@ -31,15 +31,22 @@
Name: %{?scl_prefix}php-pecl-xdebug
Summary: PECL package for debugging PHP scripts
-Version: 2.4.0
+Version: 2.5.0
+%if 0%{?gh_date:1}
+Release: 0.1.%{gh_date}git%{gh_short}%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
+%else
Release: 1%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
-Source0: https://github.com/%{pecl_name}/%{pecl_name}/archive/%{gh_commit}/%{pecl_name}-%{version}%{?prever}-%{gh_short}.tar.gz
+%endif
# The Xdebug License, version 1.01
# (Based on "The PHP License", version 3.0)
License: BSD
Group: Development/Languages
URL: http://xdebug.org/
+Source0: https://github.com/%{pecl_name}/%{pecl_name}/archive/%{gh_commit}/%{pecl_name}-%{version}%{?prever}-%{gh_short}.tar.gz
+
+# Temp for 7.1.0alpha1, fixed upstream
+Patch0: %{pecl_name}-php71.patch
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
BuildRequires: %{?scl_prefix}php-pear > 1.9.1
@@ -79,6 +86,10 @@ Obsoletes: php56w-pecl-%{pecl_name} <= %{version}
Obsoletes: php70u-pecl-%{pecl_name} <= %{version}
Obsoletes: php70w-pecl-%{pecl_name} <= %{version}
%endif
+%if "%{php_version}" > "7.1"
+Obsoletes: php71u-pecl-%{pecl_name} <= %{version}
+Obsoletes: php71w-pecl-%{pecl_name} <= %{version}
+%endif
%endif
%if 0%{?fedora} < 20 && 0%{?rhel} < 7
@@ -112,16 +123,28 @@ Package built for PHP %(%{__php} -r 'echo PHP_MAJOR_VERSION.".".PHP_MINOR_VERSIO
%prep
%setup -qc
mv %{pecl_name}-%{gh_commit} NTS
+
+%if 0%{?gh_date:1}
+%{__php} -r '
+ $pkg = simplexml_load_file("NTS/package.xml");
+ $pkg->date = substr("%{gh_date}",0,4)."-".substr("%{gh_date}",4,2)."-".substr("%{gh_date}",6,2);
+ $pkg->version->release = "%{version}dev";
+ $pkg->stability->release = "devel";
+ $pkg->asXML("package.xml");
+'
+%else
mv NTS/package.xml .
+%endif
%{?_licensedir:sed -e '/LICENSE/s/role="doc"/role="src"/' -i package.xml}
cd NTS
+%patch0 -p0 -b .php71
# Check extension version
ver=$(sed -n '/XDEBUG_VERSION/{s/.* "//;s/".*$//;p}' php_xdebug.h)
-if test "$ver" != "%{version}%{?prever}"; then
- : Error: Upstream XDEBUG_VERSION version is ${ver}, expecting %{version}%{?prever}.
+if test "$ver" != "%{version}%{?prever}%{?gh_date:-dev}"; then
+ : Error: Upstream XDEBUG_VERSION version is ${ver}, expecting %{version}%{?prever}%{?gh_date:-dev}.
exit 1
fi
@@ -291,6 +314,9 @@ rm -rf %{buildroot}
%changelog
+* Fri Jun 10 2016 Remi Collet <remi@fedoraproject.org> - 2.5.0-0.1.20160529git78fa98b
+- update to 2.5.0-dev for PHP 7.1
+
* Fri Mar 4 2016 Remi Collet <remi@fedoraproject.org> - 2.4.0-1
- update to 2.4.0