summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2014-03-19 14:02:24 +0100
committerRemi Collet <fedora@famillecollet.com>2014-03-19 14:02:24 +0100
commit36dfbb165928649e0b23a8fd20bc9fc9fcc6fb34 (patch)
tree8ab29ac89ba98dd0e07a660b092ffc4ba0a2ad83
parent60d807eda4bbda41726a6788d959bb3dfeaf3150 (diff)
php-pecl-xdebug: allow SCL build
-rw-r--r--php-pecl-xdebug.spec28
1 files changed, 16 insertions, 12 deletions
diff --git a/php-pecl-xdebug.spec b/php-pecl-xdebug.spec
index aae79ed..fc1a516 100644
--- a/php-pecl-xdebug.spec
+++ b/php-pecl-xdebug.spec
@@ -9,6 +9,7 @@
# Please, preserve the changelog entries
#
+%{?scl: %scl_package php-pecl-xdebug}
%{!?php_inidir: %global php_inidir %{_sysconfdir}/php.d}
%{!?__pecl: %global __pecl %{_bindir}/pecl}
%{!?__php: %global __php %{_bindir}/php}
@@ -19,10 +20,10 @@
#global gitver %(c=%{commit}; echo ${c:0:7})
#global prever dev
-Name: php-pecl-xdebug
+Name: %{?scl_prefix}php-pecl-xdebug
Summary: PECL package for debugging PHP scripts
Version: 2.2.4
-Release: 1%{?dist}%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}
+Release: 2%{?dist}%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}
%if 0%{?gitver:1}
Source0: https://github.com/%{pecl_name}/%{pecl_name}/archive/%{commit}/%{pecl_name}-%{version}-%{gitver}.tar.gz
%else
@@ -36,33 +37,33 @@ Group: Development/Languages
URL: http://xdebug.org/
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
-BuildRequires: php-pear
-BuildRequires: php-devel
+BuildRequires: %{?scl_prefix}php-pear
+BuildRequires: %{?scl_prefix}php-devel
BuildRequires: libedit-devel
BuildRequires: libtool
Requires(post): %{__pecl}
Requires(postun): %{__pecl}
-Requires: php(zend-abi) = %{php_zend_api}
-Requires: php(api) = %{php_core_api}
+Requires: %{?scl_prefix}php(zend-abi) = %{php_zend_api}
+Requires: %{?scl_prefix}php(api) = %{php_core_api}
-Provides: php-%{pecl_name} = %{version}
-Provides: php-%{pecl_name}%{?_isa} = %{version}
-Provides: php-pecl(Xdebug) = %{version}
-Provides: php-pecl(Xdebug)%{?_isa} = %{version}
+Provides: %{?scl_prefix}php-%{pecl_name} = %{version}
+Provides: %{?scl_prefix}php-%{pecl_name}%{?_isa} = %{version}
+Provides: %{?scl_prefix}php-pecl(Xdebug) = %{version}
+Provides: %{?scl_prefix}php-pecl(Xdebug)%{?_isa} = %{version}
+%if "%{?vendor}" == "Remi Collet"
# Other third party repo stuff
Obsoletes: php53-pecl-%{pecl_name}
Obsoletes: php53u-pecl-%{pecl_name}
-%if "%{php_version}" > "5.4"
Obsoletes: php54-pecl-%{pecl_name}
-%endif
%if "%{php_version}" > "5.5"
Obsoletes: php55u-pecl-%{pecl_name}
%endif
%if "%{php_version}" > "5.6"
Obsoletes: php56u-pecl-%{pecl_name}
%endif
+%endif
%if 0%{?fedora} < 20 && 0%{?rhel} < 7
# Filter private shared
@@ -228,6 +229,9 @@ rm -rf %{buildroot}
%changelog
+* Wed Mar 19 2014 Remi Collet <rcollet@redhat.com> - 2.2.4-2
+- allow SCL build
+
* Sun Mar 02 2014 Remi Collet <remi@fedoraproject.org> - 2.2.4-1
- Update to 2.2.4 (stable)
- move documentation in pecl_docdir