summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2017-10-18 11:56:41 +0200
committerRemi Collet <remi@remirepo.net>2017-10-18 11:56:41 +0200
commite2dfbb331dab2af92a288b9f2b6845286ab0f557 (patch)
treed212bc1bb2307de04d9ce5470bca587b9e025716
parentfc417ed191eb1eef5bdfe53f301fba9bec4c61cb (diff)
refresh
-rw-r--r--php-pecl-xdebug.spec42
1 files changed, 24 insertions, 18 deletions
diff --git a/php-pecl-xdebug.spec b/php-pecl-xdebug.spec
index a3e632c..9755a0c 100644
--- a/php-pecl-xdebug.spec
+++ b/php-pecl-xdebug.spec
@@ -16,10 +16,10 @@
%global pecl_name xdebug
%global with_zts 0%{!?_without_zts:%{?__ztsphp:1}}
-%global gh_commit 9da805ce2a7ec32ff6e7db1ca43cca64811753a5
+%global gh_commit 89ea903e1279ced259207cdbdb9642af6ff86331
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
-%global gh_date 20170925
-%global with_tests 0%{?_with_tests:1}
+%global gh_date 20171017
+%global with_tests 0%{!?_without_tests:1}
#global prever rc1
# XDebug should be loaded after opcache
@@ -29,7 +29,7 @@ Name: %{?scl_prefix}php-pecl-xdebug
Summary: PECL package for debugging PHP scripts
Version: 2.6.0
%if 0%{?gh_date:1}
-Release: 0.5.%{gh_date}.%{gh_short}%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
+Release: 0.6.%{gh_date}.%{gh_short}%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
%else
Release: 2%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
%endif
@@ -209,6 +209,14 @@ done
%check
+# Shared needed extensions
+modules=""
+for mod in simplexml; do
+ if [ -f %{php_extdir}/${mod}.so ]; then
+ modules="$modules -d extension=${mod}.so"
+ fi
+done
+
# only check if build extension can be loaded
%{_bindir}/php \
--no-php-ini \
@@ -224,22 +232,16 @@ done
%if %{with_tests}
cd NTS
-# ignore kwown failed tests
-#rm tests/bug00623.phpt
-#rm tests/bug00687.phpt
-#rm tests/bug00778.phpt
-#rm tests/bug00806.phpt
-#rm tests/bug00840.phpt
-#rm tests/bug00886.phpt
-#rm tests/bug00913.phpt
-#rm tests/bug01059.phpt
-#rm tests/bug01104.phpt
-#rm tests/dbgp-context-get.phpt
-#rm tests/dbgp-property-get-constants.phpt
+%if "%{php_version}" > "7.2"
+# Know as failed upstream (travis)
+rm tests/bug01258-php7.phpt
+%endif
: Upstream test suite NTS extension
+# bug00886 is marked as slow as it uses a lot of disk space
+SKIP_SLOW_TESTS=1 \
TEST_PHP_EXECUTABLE=%{_bindir}/php \
-TEST_PHP_ARGS="-n -d extension=soap.so -d zend_extension=%{buildroot}%{php_extdir}/%{pecl_name}.so" \
+TEST_PHP_ARGS="-n $modules -d zend_extension=%{buildroot}%{php_extdir}/%{pecl_name}.so -d xdebug.auto_trace=0" \
NO_INTERACTION=1 \
REPORT_EXIT_STATUS=1 \
%{__php} -n run-tests.php --show-diff
@@ -284,8 +286,12 @@ fi
%changelog
+* Wed Oct 18 2017 Remi Collet <remi@remirepo.net> - 2.6.0-0.6.20171017.89ea903
+- refresh and fix test suite
+- enable test suite
+
* Mon Oct 2 2017 Remi Collet <remi@remirepo.net> - 2.6.0-0.5.20170925.9da805c
-rebuild
+- rebuild
* Tue Jul 18 2017 Remi Collet <remi@remirepo.net> - 2.6.0-0.4.20170601.d82879d
- rebuild for PHP 7.2.0beta1 new API