summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2018-01-29 10:59:30 +0100
committerRemi Collet <remi@remirepo.net>2018-01-29 10:59:30 +0100
commitb1e2d03a308c0f7fe40c52e019ccbf97d3be78c8 (patch)
tree639f36d364bdfbfc140875a353acbc6ec4be26a6
parentcbb9b8681acf70beead22cc6467ef20a9f2a2faf (diff)
Add upstream patch for bigendian
-rw-r--r--d9c0704548d2db0052ea8a97c53855b977c8a481.patch24
-rw-r--r--php-pecl-xdebug.spec12
2 files changed, 35 insertions, 1 deletions
diff --git a/d9c0704548d2db0052ea8a97c53855b977c8a481.patch b/d9c0704548d2db0052ea8a97c53855b977c8a481.patch
new file mode 100644
index 0000000..97687d5
--- /dev/null
+++ b/d9c0704548d2db0052ea8a97c53855b977c8a481.patch
@@ -0,0 +1,24 @@
+From d9c0704548d2db0052ea8a97c53855b977c8a481 Mon Sep 17 00:00:00 2001
+From: Derick Rethans <github@derickrethans.nl>
+Date: Sat, 27 Jan 2018 13:45:21 +0000
+Subject: [PATCH] Fixed issue #1522: Remote debugging test failures on s390
+ (Big Endian)
+
+---
+ xdebug_handler_dbgp.c | 3 ++-
+ 1 file changed, 2 insertions(+), 1 deletion(-)
+
+diff --git a/xdebug_handler_dbgp.c b/xdebug_handler_dbgp.c
+index e7f945e0..2daac9cc 100644
+--- a/xdebug_handler_dbgp.c
++++ b/xdebug_handler_dbgp.c
+@@ -2034,7 +2034,8 @@ static int xdebug_dbgp_parse_cmd(char *line, char **cmd, xdebug_dbgp_arg **ret_a
+ int len = ptr - value_begin;
+
+ args->value[opt_index] = xdebug_str_create(value_begin, len);
+- xdebug_stripcslashes(args->value[opt_index]->d, (int*) &(args->value[opt_index]->l));
++ xdebug_stripcslashes(args->value[opt_index]->d, &len);
++ args->value[opt_index]->l = len;
+
+ state = STATE_SKIP_CHAR;
+ } else {
diff --git a/php-pecl-xdebug.spec b/php-pecl-xdebug.spec
index fc296c0..b6c27d5 100644
--- a/php-pecl-xdebug.spec
+++ b/php-pecl-xdebug.spec
@@ -12,6 +12,9 @@
# Please, preserve the changelog entries
#
+# we don't want -z defs linker flag
+%undefine _strict_symbol_defs_build
+
%{?scl: %scl_package php-pecl-xdebug}
%global pecl_name xdebug
@@ -29,7 +32,7 @@ Name: %{?scl_prefix}php-pecl-xdebug
Summary: PECL package for debugging PHP scripts
Version: 2.6.0
%if 0%{?prever:1}
-Release: 0.11.%{prever}%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
+Release: 0.12.%{prever}%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
%else
%if 0%{?gh_date:1}
Release: 0.8.%{gh_date}.%{gh_short}%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
@@ -45,6 +48,8 @@ Group: Development/Languages
URL: http://xdebug.org/
Source0: https://github.com/%{pecl_name}/%{pecl_name}/archive/%{gh_commit}/%{pecl_name}-%{version}%{?prever}-%{gh_short}.tar.gz
+Patch0: https://github.com/xdebug/xdebug/commit/d9c0704548d2db0052ea8a97c53855b977c8a481.patch
+
BuildRequires: %{?scl_prefix}php-devel > 7
BuildRequires: %{?scl_prefix}php-pear
BuildRequires: %{?scl_prefix}php-simplexml
@@ -132,6 +137,8 @@ mv NTS/package.xml .
%{?_licensedir:sed -e '/LICENSE/s/role="doc"/role="src"/' -i package.xml}
cd NTS
+%patch0 -p1 -b .upstream
+
# Check extension version
ver=$(sed -n '/XDEBUG_VERSION/{s/.* "//;s/".*$//;p}' php_xdebug.h)
if test "$ver" != "%{version}%{?prever}%{?gh_date:-dev}"; then
@@ -286,6 +293,9 @@ fi
%changelog
+* Mon Jan 29 2018 Remi Collet <remi@remirepo.net> - 2.6.0-0.12.RC2
+- Add upstream patch for bigendian
+
* Tue Jan 23 2018 Remi Collet <remi@remirepo.net> - 2.6.0-0.11.RC2
- update to 2.6.0RC2