summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2017-02-26 18:09:34 +0100
committerRemi Collet <fedora@famillecollet.com>2017-02-26 18:09:34 +0100
commitc03ca437a65bbbee26f85700f854fea5686c2e1e (patch)
treee0cc703b1262abc0bd959eb24b3b152fd8ea9e72
parentd0ec0e20c610e0d1ae37a459d73cf4d24fd2eaa8 (diff)
php-pecl-xdebug: 2.5.1
-rw-r--r--REFLECTION133
-rw-r--r--php-pecl-xdebug.spec10
2 files changed, 140 insertions, 3 deletions
diff --git a/REFLECTION b/REFLECTION
index eb709b4..24ebb08 100644
--- a/REFLECTION
+++ b/REFLECTION
@@ -1,4 +1,4 @@
-Extension [ <persistent> extension #166 xdebug version 2.5.0 ] {
+Extension [ <persistent> extension #177 xdebug version 2.5.1 ] {
- INI {
Entry [ xdebug.auto_trace <ALL> ]
@@ -196,80 +196,211 @@ Extension [ <persistent> extension #166 xdebug version 2.5.0 ] {
- Functions {
Function [ <internal:xdebug> function xdebug_get_stack_depth ] {
+
+ - Parameters [0] {
+ }
}
Function [ <internal:xdebug> function xdebug_get_function_stack ] {
+
+ - Parameters [0] {
+ }
}
Function [ <internal:xdebug> function xdebug_get_formatted_function_stack ] {
+
+ - Parameters [0] {
+ }
}
Function [ <internal:xdebug> function xdebug_print_function_stack ] {
+
+ - Parameters [2] {
+ Parameter #0 [ <optional> $message ]
+ Parameter #1 [ <optional> $options ]
+ }
}
Function [ <internal:xdebug> function xdebug_get_declared_vars ] {
+
+ - Parameters [0] {
+ }
}
Function [ <internal:xdebug> function xdebug_call_class ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <optional> $depth ]
+ }
}
Function [ <internal:xdebug> function xdebug_call_function ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <optional> $depth ]
+ }
}
Function [ <internal:xdebug> function xdebug_call_file ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <optional> $depth ]
+ }
}
Function [ <internal:xdebug> function xdebug_call_line ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <optional> $depth ]
+ }
}
Function [ <internal:xdebug> function xdebug_var_dump ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $var ]
+ }
}
Function [ <internal:xdebug> function xdebug_debug_zval ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $var ]
+ }
}
Function [ <internal:xdebug> function xdebug_debug_zval_stdout ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $var ]
+ }
}
Function [ <internal:xdebug> function xdebug_enable ] {
+
+ - Parameters [0] {
+ }
}
Function [ <internal:xdebug> function xdebug_disable ] {
+
+ - Parameters [0] {
+ }
}
Function [ <internal:xdebug> function xdebug_is_enabled ] {
+
+ - Parameters [0] {
+ }
}
Function [ <internal:xdebug> function xdebug_break ] {
+
+ - Parameters [0] {
+ }
}
Function [ <internal:xdebug> function xdebug_start_trace ] {
+
+ - Parameters [2] {
+ Parameter #0 [ <optional> $fname ]
+ Parameter #1 [ <optional> $options ]
+ }
}
Function [ <internal:xdebug> function xdebug_stop_trace ] {
+
+ - Parameters [0] {
+ }
}
Function [ <internal:xdebug> function xdebug_get_tracefile_name ] {
+
+ - Parameters [0] {
+ }
}
Function [ <internal:xdebug> function xdebug_get_profiler_filename ] {
+
+ - Parameters [0] {
+ }
}
Function [ <internal:xdebug> function xdebug_dump_aggr_profiling_data ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <optional> $prefix ]
+ }
}
Function [ <internal:xdebug> function xdebug_clear_aggr_profiling_data ] {
+
+ - Parameters [0] {
+ }
}
Function [ <internal:xdebug> function xdebug_memory_usage ] {
+
+ - Parameters [0] {
+ }
}
Function [ <internal:xdebug> function xdebug_peak_memory_usage ] {
+
+ - Parameters [0] {
+ }
}
Function [ <internal:xdebug> function xdebug_time_index ] {
+
+ - Parameters [0] {
+ }
}
Function [ <internal:xdebug> function xdebug_start_error_collection ] {
+
+ - Parameters [0] {
+ }
}
Function [ <internal:xdebug> function xdebug_stop_error_collection ] {
+
+ - Parameters [0] {
+ }
}
Function [ <internal:xdebug> function xdebug_get_collected_errors ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <optional> $clear ]
+ }
}
Function [ <internal:xdebug> function xdebug_start_function_monitor ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $functions_to_monitor ]
+ }
}
Function [ <internal:xdebug> function xdebug_stop_function_monitor ] {
+
+ - Parameters [0] {
+ }
}
Function [ <internal:xdebug> function xdebug_get_monitored_functions ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <optional> $clear ]
+ }
}
Function [ <internal:xdebug> function xdebug_start_code_coverage ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <optional> $options ]
+ }
}
Function [ <internal:xdebug> function xdebug_stop_code_coverage ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <optional> $cleanup ]
+ }
}
Function [ <internal:xdebug> function xdebug_get_code_coverage ] {
+
+ - Parameters [0] {
+ }
}
Function [ <internal:xdebug> function xdebug_code_coverage_started ] {
+
+ - Parameters [0] {
+ }
}
Function [ <internal:xdebug> function xdebug_get_function_count ] {
+
+ - Parameters [0] {
+ }
}
Function [ <internal:xdebug> function xdebug_dump_superglobals ] {
+
+ - Parameters [0] {
+ }
}
Function [ <internal:xdebug> function xdebug_get_headers ] {
+
+ - Parameters [0] {
+ }
}
}
}
diff --git a/php-pecl-xdebug.spec b/php-pecl-xdebug.spec
index 805e8f1..186df99 100644
--- a/php-pecl-xdebug.spec
+++ b/php-pecl-xdebug.spec
@@ -16,7 +16,7 @@
%global pecl_name xdebug
%global with_zts 0%{!?_without_zts:%{?__ztsphp:1}}
-%global gh_commit 150336d1fa29e311636c682db0c1550117762947
+%global gh_commit 0fb207dfad8566ddbaa0412b9068e08df0f59b77
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
#global gh_date 20161004
%global with_tests 0%{?_with_tests:1}
@@ -31,7 +31,7 @@
Name: %{?scl_prefix}php-pecl-xdebug
Summary: PECL package for debugging PHP scripts
-Version: 2.5.0
+Version: 2.5.1
%if 0%{?gh_date:1}
Release: 0.5.%{gh_date}git%{gh_short}%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
%else
@@ -151,6 +151,8 @@ cp -pr NTS ZTS
%build
+%{?dtsenable}
+
cd NTS
%{_bindir}/phpize
%configure \
@@ -178,6 +180,7 @@ make %{?_smp_mflags}
%install
rm -rf %{buildroot}
+%{?dtsenable}
# install NTS extension
make -C NTS install INSTALL_ROOT=%{buildroot}
@@ -308,6 +311,9 @@ rm -rf %{buildroot}
%changelog
+* Sun Feb 26 2017 Remi Collet <remi@fedoraproject.org> - 2.5.1-1
+- Update to 2.5.1
+
* Mon Dec 5 2016 Remi Collet <remi@fedoraproject.org> - 2.5.0-1
- update to 2.5.0