summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2017-12-03 19:20:05 +0100
committerRemi Collet <remi@remirepo.net>2017-12-03 19:20:05 +0100
commit752d0ff75f6ca454855f12d5251e3c142d5e53f8 (patch)
tree7e05a3f755c577d0b52ee76a59079b48963cc131
parent04efbcf5723d77adab453a73a3e3f5ab5ed6a58d (diff)
v2.6.0alpha1
-rw-r--r--359.patch26
-rw-r--r--REFLECTION8
-rw-r--r--php-pecl-xdebug.spec13
3 files changed, 17 insertions, 30 deletions
diff --git a/359.patch b/359.patch
deleted file mode 100644
index fe48fd3..0000000
--- a/359.patch
+++ /dev/null
@@ -1,26 +0,0 @@
-From 1a7c4d9b50575e2738984bcaea1684d12535078d Mon Sep 17 00:00:00 2001
-From: Remi Collet <remi@remirepo.net>
-Date: Wed, 5 Jul 2017 06:17:17 +0200
-Subject: [PATCH] Used EG(active) instead of Removed EG(valid_symbol_table) -
- 7.2.0alpha3
-
----
- xdebug_stack.c | 4 ++++
- 1 file changed, 4 insertions(+)
-
-diff --git a/xdebug_stack.c b/xdebug_stack.c
-index 0e5b34ad..15bf5e82 100644
---- a/xdebug_stack.c
-+++ b/xdebug_stack.c
-@@ -800,7 +800,11 @@ void xdebug_error_cb(int type, const char *error_filename, const uint error_line
- break;
- }
-
-+#if PHP_VERSION_ID >= 70200
-+ if (PG(track_errors) && EG(active)) {
-+#else
- if (PG(track_errors) && EG(valid_symbol_table)) {
-+#endif
- zval tmp;
- ZVAL_STRINGL(&tmp, buffer, buffer_len);
-
diff --git a/REFLECTION b/REFLECTION
index 04299fd..7e1374d 100644
--- a/REFLECTION
+++ b/REFLECTION
@@ -1,4 +1,4 @@
-Extension [ <persistent> extension #97 xdebug version 2.6.0-dev ] {
+Extension [ <persistent> extension #190 xdebug version 2.6.0alpha1 ] {
- INI {
Entry [ xdebug.auto_trace <ALL> ]
@@ -49,6 +49,9 @@ Extension [ <persistent> extension #97 xdebug version 2.6.0-dev ] {
Entry [ xdebug.file_link_format <ALL> ]
Current = ''
}
+ Entry [ xdebug.filename_format <ALL> ]
+ Current = ''
+ }
Entry [ xdebug.force_display_errors <SYSTEM> ]
Current = '0'
}
@@ -166,6 +169,9 @@ Extension [ <persistent> extension #97 xdebug version 2.6.0-dev ] {
Entry [ xdebug.remote_addr_header <ALL> ]
Current = ''
}
+ Entry [ xdebug.remote_timeout <ALL> ]
+ Current = '200'
+ }
Entry [ xdebug.var_display_max_children <ALL> ]
Current = '128'
}
diff --git a/php-pecl-xdebug.spec b/php-pecl-xdebug.spec
index 19c5564..c92f141 100644
--- a/php-pecl-xdebug.spec
+++ b/php-pecl-xdebug.spec
@@ -16,11 +16,11 @@
%global pecl_name xdebug
%global with_zts 0%{!?_without_zts:%{?__ztsphp:1}}
-%global gh_commit f7a08bc252b2c9999d8cb84633e3c91364234c9b
+%global gh_commit bb90b66e8461b86aa25a9545cd99d476e0283b32
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
-%global gh_date 20171112
+#global gh_date 20171202
%global with_tests 0%{!?_without_tests:1}
-#global prever rc1
+%global prever alpha1
# XDebug should be loaded after opcache
%global ini_name 15-%{pecl_name}.ini
@@ -28,11 +28,15 @@
Name: %{?scl_prefix}php-pecl-xdebug
Summary: PECL package for debugging PHP scripts
Version: 2.6.0
+%if 0%{?prever:1}
+Release: 0.9.%{prever}%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
+%else
%if 0%{?gh_date:1}
Release: 0.8.%{gh_date}.%{gh_short}%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
%else
Release: 2%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
%endif
+%endif
# The Xdebug License, version 1.01
# (Based on "The PHP License", version 3.0)
@@ -282,6 +286,9 @@ fi
%changelog
+* Sun Dec 3 2017 Remi Collet <remi@remirepo.net> - 2.6.0-0.9.alpha1
+- update to 2.6.0alpha1
+
* Mon Nov 13 2017 Remi Collet <remi@remirepo.net> - 2.6.0-0.8.20171112.f7a08bc
- refresh