summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2017-12-29 07:12:53 +0100
committerRemi Collet <remi@remirepo.net>2017-12-29 07:12:53 +0100
commit7515edd2c99b9eef8d4ad176d03c74223c93d514 (patch)
tree94def70d0f482524a838f2e34dcd6c0bb7de2f90
parent752d0ff75f6ca454855f12d5251e3c142d5e53f8 (diff)
v2.6.0beta1
-rw-r--r--REFLECTION19
-rw-r--r--php-pecl-xdebug.spec9
2 files changed, 23 insertions, 5 deletions
diff --git a/REFLECTION b/REFLECTION
index 7e1374d..8955ad0 100644
--- a/REFLECTION
+++ b/REFLECTION
@@ -1,4 +1,4 @@
-Extension [ <persistent> extension #190 xdebug version 2.6.0alpha1 ] {
+Extension [ <persistent> extension #191 xdebug version 2.6.0beta1 ] {
- INI {
Entry [ xdebug.auto_trace <ALL> ]
@@ -189,7 +189,7 @@ Extension [ <persistent> extension #190 xdebug version 2.6.0alpha1 ] {
}
}
- - Constants [8] {
+ - Constants [15] {
Constant [ integer XDEBUG_TRACE_APPEND ] { 1 }
Constant [ integer XDEBUG_TRACE_COMPUTERIZED ] { 2 }
Constant [ integer XDEBUG_TRACE_HTML ] { 4 }
@@ -198,6 +198,13 @@ Extension [ <persistent> extension #190 xdebug version 2.6.0alpha1 ] {
Constant [ integer XDEBUG_CC_DEAD_CODE ] { 2 }
Constant [ integer XDEBUG_CC_BRANCH_CHECK ] { 4 }
Constant [ integer XDEBUG_STACK_NO_DESC ] { 1 }
+ Constant [ integer XDEBUG_FILTER_TRACING ] { 256 }
+ Constant [ integer XDEBUG_FILTER_CODE_COVERAGE ] { 512 }
+ Constant [ integer XDEBUG_FILTER_NONE ] { 0 }
+ Constant [ integer XDEBUG_PATH_WHITELIST ] { 1 }
+ Constant [ integer XDEBUG_PATH_BLACKLIST ] { 2 }
+ Constant [ integer XDEBUG_NAMESPACE_WHITELIST ] { 17 }
+ Constant [ integer XDEBUG_NAMESPACE_BLACKLIST ] { 18 }
}
- Functions {
@@ -413,6 +420,14 @@ Extension [ <persistent> extension #190 xdebug version 2.6.0alpha1 ] {
- Parameters [0] {
}
}
+ Function [ <internal:xdebug> function xdebug_set_filter ] {
+
+ - Parameters [3] {
+ Parameter #0 [ <required> $filter_group ]
+ Parameter #1 [ <required> $filter_type ]
+ Parameter #2 [ <required> $array_of_filters ]
+ }
+ }
}
}
diff --git a/php-pecl-xdebug.spec b/php-pecl-xdebug.spec
index c92f141..292d11b 100644
--- a/php-pecl-xdebug.spec
+++ b/php-pecl-xdebug.spec
@@ -16,11 +16,11 @@
%global pecl_name xdebug
%global with_zts 0%{!?_without_zts:%{?__ztsphp:1}}
-%global gh_commit bb90b66e8461b86aa25a9545cd99d476e0283b32
+%global gh_commit f7db5b771a63d338e4af0c5b123d4084d2fd49cd
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
#global gh_date 20171202
%global with_tests 0%{!?_without_tests:1}
-%global prever alpha1
+%global prever beta1
# XDebug should be loaded after opcache
%global ini_name 15-%{pecl_name}.ini
@@ -29,7 +29,7 @@ Name: %{?scl_prefix}php-pecl-xdebug
Summary: PECL package for debugging PHP scripts
Version: 2.6.0
%if 0%{?prever:1}
-Release: 0.9.%{prever}%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
+Release: 0.10.%{prever}%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
%else
%if 0%{?gh_date:1}
Release: 0.8.%{gh_date}.%{gh_short}%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
@@ -286,6 +286,9 @@ fi
%changelog
+* Fri Dec 29 2017 Remi Collet <remi@remirepo.net> - 2.6.0-0.10.beta1
+- update to 2.6.0beta1
+
* Sun Dec 3 2017 Remi Collet <remi@remirepo.net> - 2.6.0-0.9.alpha1
- update to 2.6.0alpha1