summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2015-04-22 10:09:25 +0200
committerRemi Collet <fedora@famillecollet.com>2015-04-22 10:09:25 +0200
commit10d4f4df1c2608a6d9366d65f5ddd77578ee1dad (patch)
tree0ad2a9ffea47316fb1bb8bdf11b07046492d96e5
parent93cfd4711db90e43473a6d358167dbf36663f35c (diff)
php-pecl-xdebug: add patch for virtual_file_ex in 5.6 #1214111
-rw-r--r--php-pecl-xdebug.spec11
-rw-r--r--xdebug-pr172.patch37
2 files changed, 47 insertions, 1 deletions
diff --git a/php-pecl-xdebug.spec b/php-pecl-xdebug.spec
index 81530d0..2ac72cf 100644
--- a/php-pecl-xdebug.spec
+++ b/php-pecl-xdebug.spec
@@ -30,13 +30,17 @@
Name: %{?scl_prefix}php-pecl-xdebug
Summary: PECL package for debugging PHP scripts
Version: 2.3.2
-Release: 1%{?dist}%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}
+Release: 2%{?dist}%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}
%if 0%{?gitver:1}
Source0: https://github.com/%{pecl_name}/%{pecl_name}/archive/%{commit}/%{pecl_name}-%{version}-%{gitver}.tar.gz
%else
Source0: http://pecl.php.net/get/%{pecl_name}-%{version}%{?prever}.tgz
%endif
+# https://github.com/xdebug/xdebug/pull/172
+# https://bugzilla.redhat.com/1214111
+Patch0: %{pecl_name}-pr172.patch
+
# The Xdebug License, version 1.01
# (Based on "The PHP License", version 3.0)
License: PHP
@@ -113,6 +117,8 @@ mv %{pecl_name}-%{version}%{?prever} NTS
%endif
cd NTS
+%patch0 -p1 -b .pr172
+
# Check extension version
ver=$(sed -n '/XDEBUG_VERSION/{s/.* "//;s/".*$//;p}' php_xdebug.h)
if test "$ver" != "%{version}%{?prever}"; then
@@ -259,6 +265,9 @@ rm -rf %{buildroot}
%changelog
+* Wed Apr 22 2015 Remi Collet <remi@fedoraproject.org> - 2.3.2-2
+- add patch for virtual_file_ex in 5.6 #1214111
+
* Sun Mar 22 2015 Remi Collet <remi@fedoraproject.org> - 2.3.2-1
- Update to 2.3.2
diff --git a/xdebug-pr172.patch b/xdebug-pr172.patch
new file mode 100644
index 0000000..e262339
--- /dev/null
+++ b/xdebug-pr172.patch
@@ -0,0 +1,37 @@
+From 419834a441cc65bb4e7220e1128356dc99d86211 Mon Sep 17 00:00:00 2001
+From: Remi Collet <fedora@famillecollet.com>
+Date: Wed, 22 Apr 2015 08:49:51 +0200
+Subject: [PATCH] fix usage of virtual_file_ex
+
+---
+ usefulstuff.c | 8 ++++++++
+ 1 file changed, 8 insertions(+)
+
+diff --git a/usefulstuff.c b/usefulstuff.c
+index 83725c7..3bc4d1a 100644
+--- a/usefulstuff.c
++++ b/usefulstuff.c
+@@ -344,7 +344,11 @@ char *xdebug_path_to_url(const char *fileurl TSRMLS_DC)
+ cwd[0] = '\0';
+ }
+
++#if PHP_VERSION_ID < 50600
+ new_state.cwd = strdup(cwd);
++#else
++ new_state.cwd = estrdup(cwd);
++#endif
+ new_state.cwd_length = strlen(cwd);
+
+ if (!virtual_file_ex(&new_state, fileurl, NULL, 1 TSRMLS_CC)) {
+@@ -352,7 +356,11 @@ char *xdebug_path_to_url(const char *fileurl TSRMLS_DC)
+ tmp = xdebug_sprintf("file://%s",s);
+ efree(s);
+ }
++#if PHP_VERSION_ID < 50600
+ free(new_state.cwd);
++#else
++ efree(new_state.cwd);
++#endif
+
+ } else if (fileurl[1] == '/' || fileurl[1] == '\\') {
+ /* convert UNC paths (eg. \\server\sharepath) */