summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2015-11-05 19:47:12 +0100
committerRemi Collet <fedora@famillecollet.com>2015-11-05 19:47:12 +0100
commit04329ec1cb81ce982891074235d83053a15ef576 (patch)
tree22f18bcfe1a92739e878215ef9605268e29cb9a7
parentab16b07ac79825b548ac6fefe65c13f1b51b4dd5 (diff)
php-pecl-xdebug: 2.4.0beta1 (php 5 and 7)
-rw-r--r--217.patch37
-rw-r--r--221.patch22
-rw-r--r--REFLECTION14
-rw-r--r--php-pecl-xdebug-php7.spec53
-rw-r--r--php-pecl-xdebug.spec6
5 files changed, 109 insertions, 23 deletions
diff --git a/217.patch b/217.patch
new file mode 100644
index 0000000..cda53d2
--- /dev/null
+++ b/217.patch
@@ -0,0 +1,37 @@
+From 05efe9a3e6574d7692fbd49f3116f5db320e71a9 Mon Sep 17 00:00:00 2001
+From: Remi Collet <fedora@famillecollet.com>
+Date: Thu, 5 Nov 2015 15:52:52 +0100
+Subject: [PATCH] fix -Wmaybe-uninitialized
+
+---
+ usefulstuff.c | 2 +-
+ xdebug_stack.c | 3 ---
+ 2 files changed, 1 insertion(+), 4 deletions(-)
+
+diff --git a/usefulstuff.c b/usefulstuff.c
+index 60e8f19..1ed45c8 100644
+--- a/usefulstuff.c
++++ b/usefulstuff.c
+@@ -619,7 +619,7 @@ int xdebug_format_output_filename(char **filename, char *format, char *script_na
+ case 'R': { /* $_SERVER['REQUEST_URI'] */
+ char *char_ptr, *strval;
+ #if PHP_VERSION_ID >= 70000
+- zval *data;
++ zval *data = NULL;
+
+ if (Z_TYPE(PG(http_globals)[TRACK_VARS_SERVER]) == IS_ARRAY) {
+ switch (*format) {
+diff --git a/xdebug_stack.c b/xdebug_stack.c
+index a13b2a4..9ecf4ec 100644
+--- a/xdebug_stack.c
++++ b/xdebug_stack.c
+@@ -1505,9 +1505,6 @@ function_stack_entry *xdebug_add_stack_frame(zend_execute_data *zdata, zend_op_a
+ aggr_key_len = strlen(aggr_key);
+ #if PHP_VERSION_ID >= 70000
+ aggr_key_str = zend_string_init(aggr_key, aggr_key_len, 0);
+-#endif
+-
+-#if PHP_VERSION_ID >= 70000
+ if ((tmp->aggr_entry = zend_hash_find_ptr(&XG(aggr_calls), aggr_key_str)) == NULL) {
+ #else
+ if (zend_hash_find(&XG(aggr_calls), aggr_key, aggr_key_len+1, (void**)&tmp->aggr_entry) == FAILURE) {
diff --git a/221.patch b/221.patch
new file mode 100644
index 0000000..9244f65
--- /dev/null
+++ b/221.patch
@@ -0,0 +1,22 @@
+From 7d540886765540e593c2dc89d63e41504697f1b2 Mon Sep 17 00:00:00 2001
+From: Remi Collet <fedora@famillecollet.com>
+Date: Thu, 5 Nov 2015 19:13:33 +0100
+Subject: [PATCH] fix build on i686
+
+---
+ xdebug_code_coverage.c | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/xdebug_code_coverage.c b/xdebug_code_coverage.c
+index 6c52f81..8745b04 100644
+--- a/xdebug_code_coverage.c
++++ b/xdebug_code_coverage.c
+@@ -554,7 +554,7 @@ static zend_brk_cont_element* xdebug_find_brk_cont(zend_uint nest_levels, int ar
+
+ static int xdebug_find_jump(zend_op_array *opa, unsigned int position, long *jmp1, long *jmp2)
+ {
+-#if PHP_VERSION_ID < 70000
++#if defined(ZEND_USE_ABS_JMP_ADDR) || PHP_VERSION_ID < 70000
+ zend_op *base_address = &(opa->opcodes[0]);
+ #endif
+
diff --git a/REFLECTION b/REFLECTION
index 2d71f09..5dea39a 100644
--- a/REFLECTION
+++ b/REFLECTION
@@ -1,4 +1,4 @@
-Extension [ <persistent> extension #199 xdebug version 2.3.3 ] {
+Extension [ <persistent> extension #206 xdebug version 2.4.0beta1 ] {
- INI {
Entry [ xdebug.auto_trace <ALL> ]
@@ -67,6 +67,9 @@ Extension [ <persistent> extension #199 xdebug version 2.3.3 ] {
Entry [ xdebug.overload_var_dump <ALL> ]
Current = '1'
}
+ Entry [ xdebug.show_error_trace <ALL> ]
+ Current = '1'
+ }
Entry [ xdebug.show_exception_trace <ALL> ]
Current = '0'
}
@@ -160,6 +163,9 @@ Extension [ <persistent> extension #199 xdebug version 2.3.3 ] {
Entry [ xdebug.remote_cookie_expire_time <ALL> ]
Current = '3600'
}
+ Entry [ xdebug.remote_addr_header <ALL> ]
+ Current = ''
+ }
Entry [ xdebug.var_display_max_children <ALL> ]
Current = '128'
}
@@ -245,6 +251,12 @@ Extension [ <persistent> extension #199 xdebug version 2.3.3 ] {
}
Function [ <internal:xdebug> function xdebug_get_collected_errors ] {
}
+ Function [ <internal:xdebug> function xdebug_start_function_monitor ] {
+ }
+ Function [ <internal:xdebug> function xdebug_stop_function_monitor ] {
+ }
+ Function [ <internal:xdebug> function xdebug_get_monitored_functions ] {
+ }
Function [ <internal:xdebug> function xdebug_start_code_coverage ] {
}
Function [ <internal:xdebug> function xdebug_stop_code_coverage ] {
diff --git a/php-pecl-xdebug-php7.spec b/php-pecl-xdebug-php7.spec
index 4f86cbb..8b7b115 100644
--- a/php-pecl-xdebug-php7.spec
+++ b/php-pecl-xdebug-php7.spec
@@ -18,10 +18,11 @@
%{!?__php: %global __php %{_bindir}/php}
%global pecl_name xdebug
-%global with_zts 0%{?__ztsphp:1}
-%global gh_commit 2d2bdbc7948aa72143df0c5fc0eb684078732bf9
+%global with_zts 0%{!?_without_zts:%{?__ztsphp:1}}
+%global gh_commit 982cee15eef0e1b65fb62be2470e6f2015917a65
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
-%global with_tests %{?_with_tests:1}%{!?_with_tests:0}
+%global with_tests 0%{?_with_tests:1}
+%global prever beta1
# XDebug should be loaded after opcache
%if "%{php_version}" < "5.6"
@@ -32,9 +33,14 @@
Name: %{?scl_prefix}php-pecl-xdebug
Summary: PECL package for debugging PHP scripts
-Version: 2.3.3
-Release: 1%{?dist}%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}
-Source0: https://github.com/%{pecl_name}/%{pecl_name}/archive/%{gh_commit}/%{pecl_name}-%{version}-%{gh_short}.tar.gz
+Version: 2.4.0
+Release: 0.1.%{prever}%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
+Source0: https://github.com/%{pecl_name}/%{pecl_name}/archive/%{gh_commit}/%{pecl_name}-%{version}%{?prever}-%{gh_short}.tar.gz
+
+# https://github.com/xdebug/xdebug/pull/217
+Patch1: 217.patch
+# https://github.com/xdebug/xdebug/pull/221
+Patch2: 221.patch
# The Xdebug License, version 1.01
# (Based on "The PHP License", version 3.0)
@@ -74,6 +80,10 @@ Obsoletes: php55w-pecl-%{pecl_name} <= %{version}
Obsoletes: php56u-pecl-%{pecl_name} <= %{version}
Obsoletes: php56w-pecl-%{pecl_name} <= %{version}
%endif
+%if "%{php_version}" > "7.0"
+Obsoletes: php70u-pecl-%{pecl_name} <= %{version}
+Obsoletes: php70w-pecl-%{pecl_name} <= %{version}
+%endif
%endif
%if 0%{?fedora} < 20 && 0%{?rhel} < 7
@@ -101,7 +111,7 @@ Xdebug also provides:
* code coverage analysis
* capabilities to debug your scripts interactively with a debug client
-Package built for PHP %(%{__php} -r 'echo PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')%{?scl: as Software Collection}.
+Package built for PHP %(%{__php} -r 'echo PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')%{?scl: as Software Collection (%{scl} by %{?scl_vendor}%{!?scl_vendor:rh})}.
%prep
@@ -110,6 +120,8 @@ mv %{pecl_name}-%{gh_commit} NTS
mv NTS/package.xml .
cd NTS
+%patch1 -p1 -b .pr217
+%patch2 -p1 -b .pr221
# Check extension version
ver=$(sed -n '/XDEBUG_VERSION/{s/.* "//;s/".*$//;p}' php_xdebug.h)
@@ -220,21 +232,21 @@ done
%if %{with_tests}
cd NTS
# ignore kwown failed tests
-rm tests/bug00623.phpt
-rm tests/bug00687.phpt
-rm tests/bug00778.phpt
-rm tests/bug00806.phpt
-rm tests/bug00840.phpt
-rm tests/bug00886.phpt
-rm tests/bug00913.phpt
-rm tests/bug01059.phpt
-rm tests/bug01104.phpt
-rm tests/dbgp-context-get.phpt
-rm tests/dbgp-property-get-constants.phpt
+#rm tests/bug00623.phpt
+#rm tests/bug00687.phpt
+#rm tests/bug00778.phpt
+#rm tests/bug00806.phpt
+#rm tests/bug00840.phpt
+#rm tests/bug00886.phpt
+#rm tests/bug00913.phpt
+#rm tests/bug01059.phpt
+#rm tests/bug01104.phpt
+#rm tests/dbgp-context-get.phpt
+#rm tests/dbgp-property-get-constants.phpt
: Upstream test suite NTS extension
TEST_PHP_EXECUTABLE=%{_bindir}/php \
-TEST_PHP_ARGS="-n -d extension=soap.so -d zend_extension=$PWD/modules/%{pecl_name}.so" \
+TEST_PHP_ARGS="-n -d extension=soap.so -d zend_extension=%{buildroot}%{php_extdir}/%{pecl_name}.so" \
NO_INTERACTION=1 \
REPORT_EXIT_STATUS=1 \
%{__php} -n run-tests.php --show-diff
@@ -282,6 +294,9 @@ rm -rf %{buildroot}
%changelog
+* Thu Nov 5 2015 Remi Collet <remi@fedoraproject.org> - 2.4.0-0.1.beta1
+- update to 2.4.0beta1
+
* Fri Jun 19 2015 Remi Collet <remi@fedoraproject.org> - 2.3.3-1
- update to 2.3.3
- drop all patches, merged upstream
diff --git a/php-pecl-xdebug.spec b/php-pecl-xdebug.spec
index 4f86cbb..76fa46d 100644
--- a/php-pecl-xdebug.spec
+++ b/php-pecl-xdebug.spec
@@ -21,7 +21,7 @@
%global with_zts 0%{?__ztsphp:1}
%global gh_commit 2d2bdbc7948aa72143df0c5fc0eb684078732bf9
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
-%global with_tests %{?_with_tests:1}%{!?_with_tests:0}
+%global with_tests 0%{?_with_tests:1}
# XDebug should be loaded after opcache
%if "%{php_version}" < "5.6"
@@ -33,7 +33,7 @@
Name: %{?scl_prefix}php-pecl-xdebug
Summary: PECL package for debugging PHP scripts
Version: 2.3.3
-Release: 1%{?dist}%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}
+Release: 1%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
Source0: https://github.com/%{pecl_name}/%{pecl_name}/archive/%{gh_commit}/%{pecl_name}-%{version}-%{gh_short}.tar.gz
# The Xdebug License, version 1.01
@@ -101,7 +101,7 @@ Xdebug also provides:
* code coverage analysis
* capabilities to debug your scripts interactively with a debug client
-Package built for PHP %(%{__php} -r 'echo PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')%{?scl: as Software Collection}.
+Package built for PHP %(%{__php} -r 'echo PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')%{?scl: as Software Collection (%{scl} by %{?scl_vendor}%{!?scl_vendor:rh})}.
%prep