summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2016-08-02 12:23:12 +0200
committerRemi Collet <fedora@famillecollet.com>2016-08-02 12:23:12 +0200
commitf3dd45f8b48740eec3d11cbd721fc723ca2e284e (patch)
treee97c4dfcaefe6d91dcd6728abb347f8d0db0d864
parent20e4a0e114ff7dc2c1a2f1b60b48adc91ed49a46 (diff)
php-pecl-xdebug: 2.5.0-dev, refresh
-rw-r--r--REFLECTION-DEV4
-rw-r--r--php-pecl-xdebug-dev.spec13
-rw-r--r--xdebug-php71.patch14
3 files changed, 8 insertions, 23 deletions
diff --git a/REFLECTION-DEV b/REFLECTION-DEV
index 2971ea0..27d68a4 100644
--- a/REFLECTION-DEV
+++ b/REFLECTION-DEV
@@ -1,4 +1,4 @@
-Extension [ <persistent> extension #146 xdebug version 2.4.0 ] {
+Extension [ <persistent> extension #15 xdebug version 2.5.0-dev ] {
- INI {
Entry [ xdebug.auto_trace <ALL> ]
@@ -65,7 +65,7 @@ Extension [ <persistent> extension #146 xdebug version 2.4.0 ] {
Current = '-1'
}
Entry [ xdebug.overload_var_dump <ALL> ]
- Current = '1'
+ Current = '2'
}
Entry [ xdebug.show_error_trace <ALL> ]
Current = '0'
diff --git a/php-pecl-xdebug-dev.spec b/php-pecl-xdebug-dev.spec
index 2953efa..3ab264a 100644
--- a/php-pecl-xdebug-dev.spec
+++ b/php-pecl-xdebug-dev.spec
@@ -16,9 +16,9 @@
%global pecl_name xdebug
%global with_zts 0%{!?_without_zts:%{?__ztsphp:1}}
-%global gh_commit bcb45acb6c828ccf9e217a1f58db92658c6650cb
+%global gh_commit 9fe2994df1439546373440b72fb7623f357c680c
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
-%global gh_date 20160705
+%global gh_date 20160731
%global with_tests 0%{?_with_tests:1}
#global prever RC4
@@ -33,7 +33,7 @@ Name: %{?scl_prefix}php-pecl-xdebug
Summary: PECL package for debugging PHP scripts
Version: 2.5.0
%if 0%{?gh_date:1}
-Release: 0.2.%{gh_date}git%{gh_short}%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
+Release: 0.3.%{gh_date}git%{gh_short}%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
%else
Release: 1%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
%endif
@@ -45,9 +45,6 @@ Group: Development/Languages
URL: http://xdebug.org/
Source0: https://github.com/%{pecl_name}/%{pecl_name}/archive/%{gh_commit}/%{pecl_name}-%{version}%{?prever}-%{gh_short}.tar.gz
-# Temp for 7.1.0alpha1, fixed upstream
-Patch0: %{pecl_name}-php71.patch
-
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
BuildRequires: %{?scl_prefix}php-pear > 1.9.1
BuildRequires: %{?scl_prefix}php-devel > 5.4
@@ -139,7 +136,6 @@ mv NTS/package.xml .
%{?_licensedir:sed -e '/LICENSE/s/role="doc"/role="src"/' -i package.xml}
cd NTS
-%patch0 -p0 -b .php71
# Check extension version
ver=$(sed -n '/XDEBUG_VERSION/{s/.* "//;s/".*$//;p}' php_xdebug.h)
@@ -314,6 +310,9 @@ rm -rf %{buildroot}
%changelog
+* Tue Aug 2 2016 Remi Collet <remi@fedoraproject.org> - 2.5.0-0.3.20160731git9fe2994
+- new snapshot of 2.5.0-dev
+
* Fri Jul 29 2016 Remi Collet <remi@fedoraproject.org> - 2.5.0-0.2.20160705git62b3733
- new snapshot of 2.5.0-dev
diff --git a/xdebug-php71.patch b/xdebug-php71.patch
deleted file mode 100644
index 8ff103e..0000000
--- a/xdebug-php71.patch
+++ /dev/null
@@ -1,14 +0,0 @@
-diff -up ./php_xdebug.h.old ./php_xdebug.h
---- ./php_xdebug.h.old 2016-06-10 12:09:53.021694392 +0200
-+++ ./php_xdebug.h 2016-06-10 12:09:56.355710983 +0200
-@@ -29,6 +29,10 @@
-
- #include "php.h"
-
-+#ifndef LOG_NOTICE
-+#define LOG_NOTICE 5
-+#endif
-+
- #include "xdebug_compat.h"
- #include "xdebug_handlers.h"
- #include "xdebug_hash.h"