summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2017-05-01 10:15:20 +0200
committerRemi Collet <remi@remirepo.net>2017-05-01 10:15:20 +0200
commit328d35f38185daa126f8ef5a9197cf9d53e25b8a (patch)
treea5606ca1183f37d375ff090942a5a7ea7fcfbde7
parent99f106b36f29bcc0c9d952a863679430f1b3fd40 (diff)
add upstream patch for https://bugs.xdebug.org/view.php?id=1424
-rw-r--r--2d9cebd20b8e2eeac8c0116876b5ba76bd4d24ee.patch25
-rw-r--r--php-pecl-xdebug.spec8
2 files changed, 32 insertions, 1 deletions
diff --git a/2d9cebd20b8e2eeac8c0116876b5ba76bd4d24ee.patch b/2d9cebd20b8e2eeac8c0116876b5ba76bd4d24ee.patch
new file mode 100644
index 0000000..13fe7ad
--- /dev/null
+++ b/2d9cebd20b8e2eeac8c0116876b5ba76bd4d24ee.patch
@@ -0,0 +1,25 @@
+From 2d9cebd20b8e2eeac8c0116876b5ba76bd4d24ee Mon Sep 17 00:00:00 2001
+From: "Frode E. Moe" <fluff.github@git.noloop.net>
+Date: Thu, 20 Apr 2017 17:34:10 -0400
+Subject: [PATCH] Fix set_time_limit hanging on PHP 5.6 when pcntl_exec does
+ not exist
+
+---
+ xdebug.c | 4 +++-
+ 1 file changed, 3 insertions(+), 1 deletion(-)
+
+diff --git a/xdebug.c b/xdebug.c
+index 54932db..c4e8768 100644
+--- a/xdebug.c
++++ b/xdebug.c
+@@ -1292,7 +1292,9 @@ PHP_RINIT_FUNCTION(xdebug)
+ #if PHP_VERSION_ID >= 70000
+ orig = zend_hash_str_find_ptr(EG(function_table), "pcntl_exec", sizeof("pcntl_exec") - 1);
+ #else
+- zend_hash_find(EG(function_table), "pcntl_exec", sizeof("pcntl_exec"), (void **)&orig);
++ if (zend_hash_find(EG(function_table), "pcntl_exec", sizeof("pcntl_exec"), (void **)&orig) == FAILURE) {
++ orig = NULL;
++ }
+ #endif
+ if (orig) {
+ XG(orig_pcntl_exec_func) = orig->internal_function.handler;
diff --git a/php-pecl-xdebug.spec b/php-pecl-xdebug.spec
index 8eb8b64..a4f263e 100644
--- a/php-pecl-xdebug.spec
+++ b/php-pecl-xdebug.spec
@@ -35,7 +35,7 @@ Version: 2.5.3
%if 0%{?gh_date:1}
Release: 0.5.%{gh_date}git%{gh_short}%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
%else
-Release: 1%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
+Release: 2%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
%endif
# The Xdebug License, version 1.01
@@ -45,6 +45,8 @@ Group: Development/Languages
URL: http://xdebug.org/
Source0: https://github.com/%{pecl_name}/%{pecl_name}/archive/%{gh_commit}/%{pecl_name}-%{version}%{?prever}-%{gh_short}.tar.gz
+Patch0: 2d9cebd20b8e2eeac8c0116876b5ba76bd4d24ee.patch
+
BuildRequires: %{?scl_prefix}php-pear > 1.9.1
BuildRequires: %{?scl_prefix}php-devel > 5.5
BuildRequires: libedit-devel
@@ -133,6 +135,7 @@ mv NTS/package.xml .
%{?_licensedir:sed -e '/LICENSE/s/role="doc"/role="src"/' -i package.xml}
cd NTS
+%patch0 -p1 -b .upstream
# Check extension version
ver=$(sed -n '/XDEBUG_VERSION/{s/.* "//;s/".*$//;p}' php_xdebug.h)
@@ -291,6 +294,9 @@ fi
%changelog
+* Mon May 1 2017 Remi Collet <remi@remirepo.net> - 2.5.3-2
+- add upstream patch for https://bugs.xdebug.org/view.php?id=1424
+
* Fri Apr 21 2017 Remi Collet <remi@remirepo.net> - 2.5.3-1
- update to 2.5.3