summaryrefslogtreecommitdiffstats
path: root/php-pecl-vld.spec
diff options
context:
space:
mode:
Diffstat (limited to 'php-pecl-vld.spec')
-rw-r--r--php-pecl-vld.spec92
1 files changed, 38 insertions, 54 deletions
diff --git a/php-pecl-vld.spec b/php-pecl-vld.spec
index e3a1cd3..3a2ed6c 100644
--- a/php-pecl-vld.spec
+++ b/php-pecl-vld.spec
@@ -1,74 +1,54 @@
# remirepo spec file for php-pecl-vld
#
-# Copyright (c) 2013-2021 Remi Collet
-# License: CC-BY-SA
+# Copyright (c) 2013-2023 Remi Collet
+# License: CC-BY-SA-4.0
# http://creativecommons.org/licenses/by-sa/4.0/
#
# Please, preserve the changelog entries
#
-%if 0%{?scl:1}
-%global sub_prefix %{scl_prefix}
-%scl_package php-pecl-vld
-%endif
+
+%{?scl:%scl_package php-pecl-vld}
%global gh_commit 8146d47ed5883c0b7cb9c5ce980892ce286cd916
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner derickr
%global gh_project vld
#global gh_date 20180814
-%global pecl_name vld
-%global with_zts 0%{!?_without_zts:%{?__ztsphp:1}}
-%if "%{php_version}" < "5.6"
-%global ini_name %{pecl_name}.ini
+%global pecl_name vld
+%global with_zts 0%{!?_without_zts:%{?__ztsphp:1}}
+%global ini_name 40-%{pecl_name}.ini
+%if 0%{?gh_date:1}
+%global sources %{gh_project}-%{gh_commit}
%else
-%global ini_name 40-%{pecl_name}.ini
+%global sources %{pecl_name}-%{version}
%endif
+%global _configure ../%{sources}/configure
Summary: Dump the internal representation of PHP scripts
-Name: %{?sub_prefix}php-pecl-%{pecl_name}
-Version: 0.17.2
+Name: %{?scl_prefix}php-pecl-%{pecl_name}
+Version: 0.18.0
%if 0%{?gh_date:1}
Release: 0.16.%{gh_date}.%{gh_short}%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
Source0: https://github.com/%{gh_owner}/%{gh_project}/archive/%{gh_commit}/%{pecl_name}-%{version}-%{gh_short}.tar.gz
%else
-Release: 1%{?dist}%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}
-Source0: https://pecl.php.net/get/%{pecl_name}-%{version}.tgz
+Release: 2%{?dist}%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}
+Source0: https://pecl.php.net/get/%{sources}.tgz
%endif
-License: PHP
+License: PHP-3.01
URL: https://pecl.php.net/package/%{pecl_name}
-Patch0: 0001-constify.patch
-
-BuildRequires: %{?dtsprefix}gcc
BuildRequires: make
+BuildRequires: %{?dtsprefix}gcc
BuildRequires: %{?scl_prefix}php-devel >= 7.0
BuildRequires: %{?scl_prefix}php-pear
Requires: %{?scl_prefix}php(zend-abi) = %{php_zend_api}
Requires: %{?scl_prefix}php(api) = %{php_core_api}
-%{?_sclreq:Requires: %{?scl_prefix}runtime%{?_sclreq}%{?_isa}}
Provides: %{?scl_prefix}php-%{pecl_name} = %{version}
Provides: %{?scl_prefix}php-%{pecl_name}%{?_isa} = %{version}
Provides: %{?scl_prefix}php-pecl(%{pecl_name}) = %{version}
Provides: %{?scl_prefix}php-pecl(%{pecl_name})%{?_isa} = %{version}
-%if "%{?scl_prefix}" != "%{?sub_prefix}"
-Provides: %{?scl_prefix}php-pecl-%{pecl_name} = %{version}-%{release}
-Provides: %{?scl_prefix}php-pecl-%{pecl_name}%{?_isa} = %{version}-%{release}
-%endif
-
-%if "%{?packager}" == "Remi Collet" && 0%{!?scl:1} && 0%{?rhel}
-# Other third party repo stuff
-%if "%{php_version}" > "7.4"
-Obsoletes: php74-pecl-%{pecl_name} <= %{version}
-%endif
-%if "%{php_version}" > "8.0"
-Obsoletes: php80-pecl-%{pecl_name} <= %{version}
-%endif
-%if "%{php_version}" > "8.1"
-Obsoletes: php81-pecl-%{pecl_name} <= %{version}
-%endif
-%endif
%description
@@ -81,7 +61,6 @@ Package built for PHP %(%{__php} -r 'echo PHP_MAJOR_VERSION.".".PHP_MINOR_VERSIO
%prep
%setup -q -c
%if 0%{?gh_date:1}
-mv %{gh_project}-%{gh_commit} NTS
%{__php} -r '
$pkg = simplexml_load_file("NTS/package.xml");
$pkg->date = substr("%{gh_date}",0,4)."-".substr("%{gh_date}",4,2)."-".substr("%{gh_date}",6,2);
@@ -89,17 +68,13 @@ mv %{gh_project}-%{gh_commit} NTS
$pkg->stability->release = "devel";
$pkg->asXML("package.xml");
'
-%else
-mv %{pecl_name}-%{version} NTS
%endif
%{?_licensedir:sed -e '/LICENSE/s/role="doc"/role="src"/' -i package.xml}
+pushd %{sources}
: Fix version
-sed -e 's/"0.16.0"/"%{version}"/' -i NTS/vld.c
-
-pushd NTS
-%patch0 -p1
+sed -e 's/"0.16.0"/"%{version}"/' -i vld.c
: Check version
if ! grep -q '"%{version}%{?gh_date:-dev}"' vld.c; then
@@ -108,10 +83,9 @@ if ! grep -q '"%{version}%{?gh_date:-dev}"' vld.c; then
fi
popd
-
+mkdir NTS
%if %{with_zts}
-# Duplicate source tree for NTS / ZTS build
-cp -pr NTS ZTS
+mkdir ZTS
%endif
# Create configuration file
@@ -135,17 +109,18 @@ EOF
%build
%{?dtsenable}
-cd NTS
-%{_bindir}/phpize
+cd %{sources}
+%{__phpize}
+
+cd ../NTS
%configure \
- --with-php-config=%{_bindir}/php-config
+ --with-php-config=%{__phpconfig}
make %{?_smp_mflags}
%if %{with_zts}
cd ../ZTS
-%{_bindir}/zts-phpize
%configure \
- --with-php-config=%{_bindir}/zts-php-config
+ --with-php-config=%{__ztsphpconfig}
make %{?_smp_mflags}
%endif
@@ -168,7 +143,7 @@ install -D -m 644 %{ini_name} %{buildroot}%{php_ztsinidir}/%{ini_name}
%endif
# Documentation
-cd NTS
+cd %{sources}
for i in $(grep 'role="doc"' ../package.xml | sed -e 's/^.*name="//;s/".*$//')
do install -Dpm 644 $i %{buildroot}%{pecl_docdir}/%{pecl_name}/$i
done
@@ -210,7 +185,7 @@ fi
%files
-%{?_licensedir:%license NTS/LICENSE}
+%{?_licensedir:%license %{sources}/LICENSE}
%doc %{pecl_docdir}/%{pecl_name}
%{pecl_xmldir}/%{name}.xml
@@ -224,6 +199,15 @@ fi
%changelog
+* Mon Sep 4 2023 Remi Collet <remi@remirepo.net> - 0.18.0-2
+- build out of sources tree
+
+* Fri Sep 16 2022 Remi Collet <remi@remirepo.net> - 0.18.0-1
+- update to 0.18.0
+
+* Thu Sep 15 2022 Remi Collet <remi@remirepo.net> - 0.17.2-2
+- add upstream for PHP 8.2
+
* Tue Nov 30 2021 Remi Collet <remi@remirepo.net> - 0.17.2-1
- update to 0.17.2
- add patch for build warnings from