summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2014-03-24 18:01:01 +0100
committerRemi Collet <fedora@famillecollet.com>2014-03-24 18:01:01 +0100
commit8963ce622c99da138cba6f347172d3ecff9d3954 (patch)
tree97a194e24f0d464bd66d5668266783f6b02d6300
parent88e91de963667213ada20b69a2151fcfa79aadff (diff)
php-pecl-vld: allow SCL bulid
-rw-r--r--php-pecl-vld.spec26
1 files changed, 15 insertions, 11 deletions
diff --git a/php-pecl-vld.spec b/php-pecl-vld.spec
index 959d950..e54da76 100644
--- a/php-pecl-vld.spec
+++ b/php-pecl-vld.spec
@@ -6,6 +6,7 @@
#
# Please, preserve the changelog entries
#
+%{?scl: %scl_package php-pecl-vld}
%{!?php_inidir: %global php_inidir %{_sysconfdir}/php.d}
%{!?__pecl: %global __pecl %{_bindir}/pecl}
%{!?__php: %global __php %{_bindir}/php}
@@ -14,9 +15,9 @@
%global with_zts 0%{?__ztsphp:1}
Summary: Dump the internal representation of PHP scripts
-Name: php-pecl-%{pecl_name}
+Name: %{?scl_prefix}php-pecl-%{pecl_name}
Version: 0.12.0
-Release: 2%{?dist}%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}
+Release: 3%{?dist}%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}
License: PHP
Group: Development/Languages
URL: http://pecl.php.net/package/%{pecl_name}
@@ -30,18 +31,18 @@ Source1: https://raw.github.com/derickr/vld/master/LICENSE
Patch0: %{pecl_name}-git.patch
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
-BuildRequires: php-devel
-BuildRequires: php-pear
+BuildRequires: %{?scl_prefix}php-devel
+BuildRequires: %{?scl_prefix}php-pear
Requires(post): %{__pecl}
Requires(postun): %{__pecl}
-Requires: php(zend-abi) = %{php_zend_api}
-Requires: php(api) = %{php_core_api}
+Requires: %{?scl_prefix}php(zend-abi) = %{php_zend_api}
+Requires: %{?scl_prefix}php(api) = %{php_core_api}
-Provides: php-%{pecl_name} = %{version}
-Provides: php-%{pecl_name}%{?_isa} = %{version}
-Provides: php-pecl(%{pecl_name}) = %{version}
-Provides: php-pecl(%{pecl_name})%{?_isa} = %{version}
+Provides: %{?scl_prefix}php-%{pecl_name} = %{version}
+Provides: %{?scl_prefix}php-%{pecl_name}%{?_isa} = %{version}
+Provides: %{?scl_prefix}php-pecl(%{pecl_name}) = %{version}
+Provides: %{?scl_prefix}php-pecl(%{pecl_name})%{?_isa} = %{version}
%if "%{?vendor}" == "Remi Collet"
# Other third party repo stuff
@@ -152,7 +153,7 @@ fi
%check
# Minimal load test for NTS extension
-php --no-php-ini \
+%{__php} --no-php-ini \
--define extension=NTS/modules/%{pecl_name}.so \
--modules | grep %{pecl_name}
@@ -182,6 +183,9 @@ rm -rf %{buildroot}
%changelog
+* Mon Mar 24 2014 Remi Collet <remi@fedoraproject.org> - 0.12.0-3
+- allow SCL build
+
* Sun Mar 16 2014 Remi Collet <remi@fedoraproject.org> - 0.12.0-2
- install doc in pecl_docdir
- add missing License file (from github repo)