summaryrefslogtreecommitdiffstats
path: root/php-pecl-vips.spec
diff options
context:
space:
mode:
Diffstat (limited to 'php-pecl-vips.spec')
-rw-r--r--php-pecl-vips.spec13
1 files changed, 10 insertions, 3 deletions
diff --git a/php-pecl-vips.spec b/php-pecl-vips.spec
index 40ca561..66e7aa1 100644
--- a/php-pecl-vips.spec
+++ b/php-pecl-vips.spec
@@ -22,12 +22,16 @@
Summary: PHP extension for interfacing with libvips
Name: %{?sub_prefix}php-pecl-%{pecl_name}
Version: 1.0.12
-Release: 5%{?dist}%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}
+Release: 6%{?dist}%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}
License: PHP
Group: Development/Languages
URL: https://pecl.php.net/package/%{pecl_name}
Source0: https://pecl.php.net/get/%{pecl_name}-%{version}%{?prever}.tgz
+# https://github.com/libvips/php-vips-ext/issues/43
+# https://github.com/libvips/php-vips-ext/pull/44
+Patch0: %{pecl_name}-pr44.patch
+
BuildRequires: %{?dtsprefix}gcc
BuildRequires: make
BuildRequires: %{?scl_prefix}php-devel >= 7.0
@@ -85,6 +89,8 @@ sed -e 's/role="test"/role="src"/' \
-i package.xml
cd NTS
+%patch0 -p1
+
# Sanity check, really often broken
extver=$(sed -n '/define PHP_VIPS_VERSION/{s/.* "//;s/".*$//;p}' php_vips.h)
if test "x${extver}" != "x%{version}%{?prever}"; then
@@ -108,8 +114,6 @@ EOF
%build
%{?dtsenable}
-export LDFLAGS="%{?__global_ldflags} -Wl,-z,nodelete"
-
cd NTS
%{_bindir}/phpize
%configure \
@@ -225,6 +229,9 @@ REPORT_EXIT_STATUS=1 \
%changelog
+* Wed Sep 8 2021 Remi Collet <remi@remirepo.net> - 1.0.12-6
+- test build for upstream patch
+
* Mon Sep 6 2021 Remi Collet <remi@remirepo.net> - 1.0.12-5
- rebuild with workaround for https://github.com/libvips/php-vips-ext/issues/43