summaryrefslogtreecommitdiffstats
path: root/php-pecl-vips.spec
diff options
context:
space:
mode:
Diffstat (limited to 'php-pecl-vips.spec')
-rw-r--r--php-pecl-vips.spec9
1 files changed, 8 insertions, 1 deletions
diff --git a/php-pecl-vips.spec b/php-pecl-vips.spec
index 9444932..fdbde4a 100644
--- a/php-pecl-vips.spec
+++ b/php-pecl-vips.spec
@@ -16,10 +16,13 @@
%global ini_name 40-%{pecl_name}.ini
#global prever RC9
+# Ensure runtime version > buildtime version, for possible new symbols
+%global vipsbuildver %(pkg-config --silence-errors --modversion vips 2>/dev/null || echo 65536)
+
Summary: PHP extension for interfacing with libvips
Name: %{?sub_prefix}php-pecl-%{pecl_name}
Version: 1.0.5
-Release: 1%{?dist}%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}
+Release: 2%{?dist}%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}
License: PHP
Group: Development/Languages
URL: http://pecl.php.net/package/%{pecl_name}
@@ -28,6 +31,7 @@ Source0: http://pecl.php.net/get/%{pecl_name}-%{version}%{?prever}.tgz
BuildRequires: %{?scl_prefix}php-devel > 7
BuildRequires: %{?scl_prefix}php-pear
BuildRequires: pkgconfig(vips) >= 8.2
+Requires: vips%{?_isa} >= %{vipsbuildver}
Requires: %{?scl_prefix}php(zend-abi) = %{php_zend_api}
Requires: %{?scl_prefix}php(api) = %{php_core_api}
@@ -210,6 +214,9 @@ REPORT_EXIT_STATUS=1 \
%changelog
+* Mon Apr 10 2017 Remi Collet <remi@remirepo.net> - 1.0.5-2
+- rebuild with libvips 8.5.2
+
* Sun Apr 9 2017 Remi Collet <remi@remirepo.net> - 1.0.5-1
- Update to 1.0.5