summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--php-pecl-uuid.spec35
1 files changed, 15 insertions, 20 deletions
diff --git a/php-pecl-uuid.spec b/php-pecl-uuid.spec
index 93bb346..6c68e9f 100644
--- a/php-pecl-uuid.spec
+++ b/php-pecl-uuid.spec
@@ -3,19 +3,23 @@
#
# Fedora spec file for php-pecl-uuid
#
-# Copyright (c) 2012-2017 Remi Collet
+# Copyright (c) 2012-2018 Remi Collet
# License: CC-BY-SA
# http://creativecommons.org/licenses/by-sa/4.0/
#
# Please, preserve the changelog entries
#
+
+# we don't want -z defs linker flag
+%undefine _strict_symbol_defs_build
+
%if 0%{?scl:1}
%global sub_prefix %{scl_prefix}
%scl_package php-pecl-uuid
%endif
%global pecl_name uuid
-%global with_zts 0%{?__ztsphp:1}
+%global with_zts 0%{!?_without_zts:%{?__ztsphp:1}}
%if "%{php_version}" < "5.6"
%global ini_name %{pecl_name}.ini
%else
@@ -26,13 +30,12 @@
Summary: Universally Unique Identifier extension for PHP
Name: %{?sub_prefix}php-pecl-uuid
Version: 1.0.4
-Release: 11%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
+Release: 12%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
License: LGPLv2+
-Group: Development/Languages
URL: http://pecl.php.net/package/uuid
Source: http://pecl.php.net/get/%{pecl_name}-%{version}%{?prever}.tgz
-BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
+BuildRequires: %{?dtsprefix}gcc
BuildRequires: %{?scl_prefix}php-devel
BuildRequires: %{?scl_prefix}php-pear
BuildRequires: libuuid-devel
@@ -53,14 +56,6 @@ Provides: %{?scl_prefix}php-pecl-%{pecl_name}%{?_isa} = %{version}-%{relea
%if "%{?vendor}" == "Remi Collet" && 0%{!?scl:1} && 0%{?rhel}
# Other third party repo stuff
-Obsoletes: php53-pecl-%{pecl_name} <= %{version}
-Obsoletes: php53u-pecl-%{pecl_name} <= %{version}
-Obsoletes: php54-pecl-%{pecl_name} <= %{version}
-Obsoletes: php54w-pecl-%{pecl_name} <= %{version}
-%if "%{php_version}" > "5.5"
-Obsoletes: php55u-pecl-%{pecl_name} <= %{version}
-Obsoletes: php55w-pecl-%{pecl_name} <= %{version}
-%endif
%if "%{php_version}" > "5.6"
Obsoletes: php56u-pecl-%{pecl_name} <= %{version}
Obsoletes: php56w-pecl-%{pecl_name} <= %{version}
@@ -124,6 +119,7 @@ EOF
%build
+%{?dtsenable}
export PHP_RPATH=no
cd NTS
@@ -146,7 +142,8 @@ make %{?_smp_mflags}
%install
-rm -rf %{buildroot}
+%{?dtsenable}
+
# Install the NTS stuff
make -C NTS install INSTALL_ROOT=%{buildroot}
install -D -m 644 %{ini_name} %{buildroot}%{php_inidir}/%{ini_name}
@@ -187,7 +184,7 @@ REPORT_EXIT_STATUS=1 \
%endif
-%if 0%{?fedora} < 24
+%if 0%{?fedora} < 24 && 0%{?rhel} < 8
# when pear installed alone, after us
%triggerin -- %{?scl_prefix}php-pear
if [ -x %{__pecl} ] ; then
@@ -207,12 +204,7 @@ fi
%endif
-%clean
-rm -rf %{buildroot}
-
-
%files
-%defattr(-,root,root,-)
%{?_licensedir:%license NTS/LICENSE}
%doc %{pecl_docdir}/%{pecl_name}
%{pecl_xmldir}/%{name}.xml
@@ -227,6 +219,9 @@ rm -rf %{buildroot}
%changelog
+* Fri Jun 22 2018 Remi Collet <remi@remirepo.net> - 1.0.4-12
+- cleanup and rebuild
+
* Tue Jul 18 2017 Remi Collet <remi@remirepo.net> - 1.0.4-11
- rebuild for PHP 7.2.0beta1 new API