summaryrefslogtreecommitdiffstats
path: root/php-pecl-uopz.spec
diff options
context:
space:
mode:
Diffstat (limited to 'php-pecl-uopz.spec')
-rw-r--r--php-pecl-uopz.spec41
1 files changed, 19 insertions, 22 deletions
diff --git a/php-pecl-uopz.spec b/php-pecl-uopz.spec
index dd4ed11..0112275 100644
--- a/php-pecl-uopz.spec
+++ b/php-pecl-uopz.spec
@@ -1,13 +1,12 @@
# remirepo spec file for php-pecl-uopz
#
-# Copyright (c) 2014-2021 Remi Collet
+# Copyright (c) 2014-2022 Remi Collet
# License: CC-BY-SA
# http://creativecommons.org/licenses/by-sa/4.0/
#
# Please, preserve the changelog entries
#
%if 0%{?scl:1}
-%global sub_prefix %{scl_prefix}
%scl_package php-pecl-uopz
%endif
@@ -22,9 +21,9 @@
#global gh_project uopz
Summary: User Operations for Zend
-Name: %{?sub_prefix}php-pecl-%{pecl_name}
+Name: %{?scl_prefix}php-pecl-%{pecl_name}
Version: 7.1.1
-Release: 1%{?dist}%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}
+Release: 2%{?dist}%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}
License: PHP
URL: https://pecl.php.net/package/%{pecl_name}
%if 0%{?gh_commit:1}
@@ -37,6 +36,9 @@ BuildRequires: make
BuildRequires: %{?dtsprefix}gcc
BuildRequires: %{?scl_prefix}php-devel >= 8.0
BuildRequires: %{?scl_prefix}php-pear
+#BuildRequires: php-debugsource
+#BuildRequires: php-cli-debuginfo
+#BuildRequires: gdb
Requires: %{?scl_prefix}php(zend-abi) = %{php_zend_api}
Requires: %{?scl_prefix}php(api) = %{php_core_api}
@@ -46,22 +48,8 @@ Provides: %{?scl_prefix}php-%{pecl_name} = %{version}
Provides: %{?scl_prefix}php-%{pecl_name}%{?_isa} = %{version}
Provides: %{?scl_prefix}php-pecl(%{pecl_name}) = %{version}
Provides: %{?scl_prefix}php-pecl(%{pecl_name})%{?_isa} = %{version}
-%if "%{?scl_prefix}" != "%{?sub_prefix}"
-Provides: %{?scl_prefix}php-pecl-%{pecl_name} = %{version}-%{release}
-Provides: %{?scl_prefix}php-pecl-%{pecl_name}%{?_isa} = %{version}-%{release}
-%endif
Conflicts: %{?scl_prefix}php-pecl-xdebug < 2.9.4
-%if "%{?packager}" == "Remi Collet" && 0%{!?scl:1} && 0%{?rhel}
-# Other third party repo stuff
-Obsoletes: php73-pecl-%{pecl_name} <= %{version}
-Obsoletes: php74-pecl-%{pecl_name} <= %{version}
-Obsoletes: php80-pecl-%{pecl_name} <= %{version}
-%if "%{php_version}" > "8.1"
-Obsoletes: php81-pecl-%{pecl_name} <= %{version}
-%endif
-%endif
-
%description
The uopz extension is focused on providing utilities to aid with unit
@@ -199,18 +187,22 @@ fi
%check
+# https://github.com/krakjoe/uopz/issues/160
+#rm ?TS/tests/012.phpt
+
cd NTS
: Minimal load test for NTS extension
%{__php} --no-php-ini \
--define extension=%{buildroot}%{php_extdir}/%{pecl_name}.so \
--modules | grep %{pecl_name}
+%if %{with tests}
: Upstream test suite for NTS extension
TEST_PHP_EXECUTABLE=%{__php} \
TEST_PHP_ARGS="-n -d extension=%{buildroot}%{php_extdir}/%{pecl_name}.so" \
-NO_INTERACTION=1 \
REPORT_EXIT_STATUS=1 \
-%{__php} -n run-tests.php
+%{__php} -n run-tests.php -q --show-diff
+%endif
%if %{with_zts}
cd ../ZTS
@@ -219,12 +211,13 @@ cd ../ZTS
--define extension=%{buildroot}%{php_ztsextdir}/%{pecl_name}.so \
--modules | grep %{pecl_name}
+%if %{with tests}
: Upstream test suite for ZTS extension
TEST_PHP_EXECUTABLE=%{_bindir}/zts-php \
TEST_PHP_ARGS="-n -d extension=%{buildroot}%{php_ztsextdir}/%{pecl_name}.so" \
-NO_INTERACTION=1 \
REPORT_EXIT_STATUS=1 \
-%{_bindir}/zts-php -n run-tests.php
+%{_bindir}/zts-php -n run-tests.php -q --show-diff
+%endif
%endif
@@ -243,6 +236,10 @@ REPORT_EXIT_STATUS=1 \
%changelog
+* Fri Feb 11 2022 Remi Collet <remi@remirepo.net> - 7.1.1-2
+- skip 1 test failing with 8.1 reported as
+ https://github.com/krakjoe/uopz/issues/160
+
* Tue Oct 19 2021 Remi Collet <remi@remirepo.net> - 7.1.1-1
- update to 7.1.1