summaryrefslogtreecommitdiffstats
path: root/php-pecl-translit.spec
diff options
context:
space:
mode:
Diffstat (limited to 'php-pecl-translit.spec')
-rw-r--r--php-pecl-translit.spec54
1 files changed, 22 insertions, 32 deletions
diff --git a/php-pecl-translit.spec b/php-pecl-translit.spec
index 90107c4..206dca9 100644
--- a/php-pecl-translit.spec
+++ b/php-pecl-translit.spec
@@ -1,6 +1,6 @@
# remirepo spec file for php-pecl-translit
#
-# Copyright (c) 2015-2018 Remi Collet
+# Copyright (c) 2015-2019 Remi Collet
# License: CC-BY-SA
# http://creativecommons.org/licenses/by-sa/4.0/
#
@@ -14,31 +14,26 @@
%global pecl_name translit
%global with_zts 0%{!?_without_zts:%{?__ztsphp:1}}
# see https://github.com/derickr/pecl-translit/releases
-%global gh_commit 09efe930d4e73ca6f82e1195c2c0092f0dce96e5
+%global gh_commit f2e23d91068047a3d08a8e8d999aca13013ff9cc
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner derickr
%global gh_project pecl-translit
%global with_tests 0%{!?_without_tests:1}
-%if "%{php_version}" < "5.6"
-# After json
-%global ini_name %{pecl_name}.ini
-%else
# After 20-iconv
%global ini_name 40-%{pecl_name}.ini
-%endif
Summary: Transliterates non-latin character sets to latin
Name: %{?sub_prefix}php-pecl-%{pecl_name}
-Version: 0.6.2
-Release: 8%{?dist}%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}
+Version: 0.6.3
+Release: 1%{?dist}%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}
License: BSD
URL: http://pecl.php.net/package/%{pecl_name}
# Pull sources from github to get tests
Source0: https://github.com/%{gh_owner}/%{gh_project}/archive/%{gh_commit}/%{gh_project}-%{version}%{?prever}-%{gh_short}.tar.gz
-BuildRequires: %{?dtsprefix}gcc
-BuildRequires: %{?scl_prefix}php-devel
+BuildRequires: %{?dtsprefix}gcc
+BuildRequires: %{?scl_prefix}php-devel > 5.6
BuildRequires: %{?scl_prefix}php-pear
%if %{with_tests}
BuildRequires: %{?scl_prefix}php-iconv
@@ -59,22 +54,6 @@ Provides: %{?scl_prefix}php-pecl-%{pecl_name}%{?_isa} = %{version}-%{releas
%if "%{?vendor}" == "Remi Collet" && 0%{!?scl:1} && 0%{?rhel}
# Other third party repo stuff
-Obsoletes: php53-pecl-%{pecl_name} <= %{version}
-Obsoletes: php53u-pecl-%{pecl_name} <= %{version}
-Obsoletes: php54-pecl-%{pecl_name} <= %{version}
-Obsoletes: php54w-pecl-%{pecl_name} <= %{version}
-%if "%{php_version}" > "5.5"
-Obsoletes: php55u-pecl-%{pecl_name} <= %{version}
-Obsoletes: php55w-pecl-%{pecl_name} <= %{version}
-%endif
-%if "%{php_version}" > "5.6"
-Obsoletes: php56u-pecl-%{pecl_name} <= %{version}
-Obsoletes: php56w-pecl-%{pecl_name} <= %{version}
-%endif
-%if "%{php_version}" > "7.0"
-Obsoletes: php70u-pecl-%{pecl_name} <= %{version}
-Obsoletes: php70w-pecl-%{pecl_name} <= %{version}
-%endif
%if "%{php_version}" > "7.1"
Obsoletes: php71u-pecl-%{pecl_name} <= %{version}
Obsoletes: php71w-pecl-%{pecl_name} <= %{version}
@@ -84,9 +63,13 @@ Obsoletes: php72u-pecl-%{pecl_name} <= %{version}
Obsoletes: php72w-pecl-%{pecl_name} <= %{version}
%endif
%if "%{php_version}" > "7.3"
-Obsoletes: php73u-pecl-%{pecl_name} <= %{version}
+Obsoletes: php73-pecl-%{pecl_name} <= %{version}
Obsoletes: php73w-pecl-%{pecl_name} <= %{version}
%endif
+%if "%{php_version}" > "7.4"
+Obsoletes: php74-pecl-%{pecl_name} <= %{version}
+Obsoletes: php74w-pecl-%{pecl_name} <= %{version}
+%endif
%endif
%if 0%{?fedora} < 20 && 0%{?rhel} < 7
@@ -216,23 +199,26 @@ fi
%endif
%if %{with_tests}
+%if "%{php_version}" > "7.4"
+TOPT="-q %{?_smp_mflags} --show-diff"
+%else
+TOPT="-q --show-diff"
+%endif
: Upstream test suite NTS extension
cd NTS
TEST_PHP_EXECUTABLE=%{_bindir}/php \
TEST_PHP_ARGS="-n $DEPMOD -d extension=%{buildroot}%{php_extdir}/%{pecl_name}.so" \
-NO_INTERACTION=1 \
REPORT_EXIT_STATUS=1 \
-%{_bindir}/php -n run-tests.php --show-diff
+%{_bindir}/php -n run-tests.php $TOPT
%if %{with_zts}
: Upstream test suite NTS extension
cd ../ZTS
TEST_PHP_EXECUTABLE=%{__ztsphp} \
TEST_PHP_ARGS="-n $DEPMOD -d extension=%{buildroot}%{php_ztsextdir}/%{pecl_name}.so" \
-NO_INTERACTION=1 \
REPORT_EXIT_STATUS=1 \
-%{__ztsphp} -n run-tests.php --show-diff
+%{__ztsphp} -n run-tests.php $TOPT
%endif
%endif
@@ -253,6 +239,10 @@ REPORT_EXIT_STATUS=1 \
%changelog
+* Wed May 29 2019 Remi Collet <remi@remirepo.net> - 0.6.3-1
+- update to 0.6.3
+- raise dependency on PHP 5.6
+
* Thu Aug 16 2018 Remi Collet <remi@remirepo.net> - 0.6.2-8
- rebuild for 7.3.0beta2 new ABI