summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2017-07-07 09:17:09 +0200
committerRemi Collet <remi@remirepo.net>2017-07-07 09:17:09 +0200
commit6b21ee3b3cfa6d38fa661a30d372a1824217c8c1 (patch)
tree1a2611b8feb493a0cfd16a06e7753e6639a63627
parent41b8d0c8aec8ebbf43471f57683e3e6394f5b221 (diff)
cleaup for fedora review
-rw-r--r--php-pecl-timecop.spec73
1 files changed, 18 insertions, 55 deletions
diff --git a/php-pecl-timecop.spec b/php-pecl-timecop.spec
index 28a7e03..6bf088d 100644
--- a/php-pecl-timecop.spec
+++ b/php-pecl-timecop.spec
@@ -1,3 +1,6 @@
+# Fedora spec file for php-pecl-timecop
+# without SCL compatibility from:
+#
# remirepo spec file for php-pecl-timecop
#
# Copyright (c) 2017 Remi Collet
@@ -6,11 +9,6 @@
#
# Please, preserve the changelog entries
#
-%if 0%{?scl:1}
-%global sub_prefix %{scl_prefix}
-%scl_package php-pecl-timecop
-%endif
-
%global pecl_name timecop
%global with_zts 0%{!?_without_zts:%{?__ztsphp:1}}
%global with_tests %{?_without_tests:0}%{!?_without_tests:1}
@@ -21,9 +19,9 @@
%endif
Summary: Time travel and freezing extension
-Name: %{?sub_prefix}php-pecl-timecop
+Name: php-pecl-timecop
Version: 1.2.7
-Release: 1%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
+Release: 1%{?dist}
License: MIT
Group: Development/Languages
URL: http://pecl.php.net/package/%{pecl_name}
@@ -31,56 +29,22 @@ Source0: http://pecl.php.net/get/%{pecl_name}-%{version}.tgz
# https://github.com/hnw/php-timecop/pull/22
Source1: https://raw.githubusercontent.com/hnw/php-timecop/master/tests-skipcheck.inc.php
-BuildRequires: %{?scl_prefix}php-devel
-BuildRequires: %{?scl_prefix}php-pear
-
-Requires: %{?scl_prefix}php(zend-abi) = %{php_zend_api}
-Requires: %{?scl_prefix}php(api) = %{php_core_api}
-%{?_sclreq:Requires: %{?scl_prefix}runtime%{?_sclreq}%{?_isa}}
-
-Obsoletes: %{?scl_prefix}php-%{pecl_name} < 1.2.7
-Provides: %{?scl_prefix}php-%{pecl_name} = %{version}
-Provides: %{?scl_prefix}php-%{pecl_name}%{?_isa} = %{version}
-Provides: %{?scl_prefix}php-pecl(%{pecl_name}) = %{version}
-Provides: %{?scl_prefix}php-pecl(%{pecl_name})%{?_isa} = %{version}
-%if "%{?scl_prefix}" != "%{?sub_prefix}"
-Provides: %{?scl_prefix}php-pecl-%{pecl_name} = %{version}-%{release}
-Provides: %{?scl_prefix}php-pecl-%{pecl_name}%{?_isa} = %{version}-%{release}
-%endif
+BuildRequires: php-devel
+BuildRequires: php-pear
-%if "%{?vendor}" == "Remi Collet" && 0%{!?scl:1} && 0%{?rhel}
-# Other third party repo stuff
-%if "%{php_version}" > "5.6"
-Obsoletes: php56u-pecl-%{pecl_name} <= %{version}
-Obsoletes: php56w-pecl-%{pecl_name} <= %{version}
-%endif
-%if "%{php_version}" > "7.0"
-Obsoletes: php70u-pecl-%{pecl_name} <= %{version}
-Obsoletes: php70w-pecl-%{pecl_name} <= %{version}
-%endif
-%if "%{php_version}" > "7.1"
-Obsoletes: php71u-pecl-%{pecl_name} <= %{version}
-Obsoletes: php71w-pecl-%{pecl_name} <= %{version}
-%endif
-%if "%{php_version}" > "7.2"
-Obsoletes: php72u-pecl-%{pecl_name} <= %{version}
-Obsoletes: php72w-pecl-%{pecl_name} <= %{version}
-%endif
-%endif
+Requires: php(zend-abi) = %{php_zend_api}
+Requires: php(api) = %{php_core_api}
-%if 0%{?fedora} < 20 && 0%{?rhel} < 7
-# Filter shared private
-%{?filter_provides_in: %filter_provides_in %{_libdir}/.*\.so$}
-%{?filter_setup}
-%endif
+Provides: php-%{pecl_name} = %{version}
+Provides: php-%{pecl_name}%{?_isa} = %{version}
+Provides: php-pecl(%{pecl_name}) = %{version}
+Provides: php-pecl(%{pecl_name})%{?_isa} = %{version}
%description
A PHP extension providing "time travel" and "time freezing" capabilities,
inspired by ruby timecop gem.
-Package built for PHP %(%{__php} -r 'echo PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')%{?scl: as Software Collection (%{scl} by %{?scl_vendor}%{!?scl_vendor:rh})}.
-
%prep
%setup -qc
@@ -117,13 +81,11 @@ extension = %{pecl_name}.so
; Configuration
;timecop.func_override = 1
-:timecop.sync_request_time = 1
+;timecop.sync_request_time = 1
EOF
%build
-%{?dtsenable}
-
cd NTS
%{_bindir}/phpize
%configure \
@@ -144,8 +106,6 @@ make %{?_smp_mflags}
%install
-%{?dtsenable}
-
# Install the NTS stuff
make -C NTS install INSTALL_ROOT=%{buildroot}
install -D -m 644 %{ini_name} %{buildroot}%{php_inidir}/%{ini_name}
@@ -205,7 +165,7 @@ REPORT_EXIT_STATUS=1 \
%if 0%{?fedora} < 24
# when pear installed alone, after us
-%triggerin -- %{?scl_prefix}php-pear
+%triggerin -- php-pear
if [ -x %{__pecl} ] ; then
%{pecl_install} %{pecl_xmldir}/%{name}.xml >/dev/null || :
fi
@@ -239,6 +199,9 @@ fi
%changelog
* Fri Jul 7 2017 Remi Collet <remi@remirepo.net> - 1.2.7-1
+- cleanup for Fedora review
+
+* Fri Jul 7 2017 Remi Collet <remi@remirepo.net> - 1.2.7-1
- rename to php-pecl-timecop
- use sources from pecl
- update to 1.2.7