summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2022-02-14 07:10:42 +0100
committerRemi Collet <remi@php.net>2022-02-14 07:10:42 +0100
commit46be7341a915cff496e186a342c212aa257b0ad6 (patch)
treee7117a090071376a3dd2cfb10aa7cf301161c9d2
parentc9f9fd9fe0125caedf1bf7a7f462326777094da5 (diff)
update to 0.14.0
-rw-r--r--PHPINFO2
-rw-r--r--REFLECTION234
-rw-r--r--php-pecl-teds.spec5
3 files changed, 235 insertions, 6 deletions
diff --git a/PHPINFO b/PHPINFO
index 0a00202..75a8946 100644
--- a/PHPINFO
+++ b/PHPINFO
@@ -2,4 +2,4 @@
teds
teds support => enabled
-teds version => 0.12.0
+teds version => 0.14.0
diff --git a/REFLECTION b/REFLECTION
index 33dcd80..92d9cad 100644
--- a/REFLECTION
+++ b/REFLECTION
@@ -1,4 +1,4 @@
-Extension [ <persistent> extension #99 teds version 0.12.0 ] {
+Extension [ <persistent> extension #99 teds version 0.14.0 ] {
- Functions {
Function [ <internal:teds> function Teds\any ] {
@@ -99,7 +99,7 @@ Extension [ <persistent> extension #99 teds version 0.12.0 ] {
}
}
- - Classes [18] {
+ - Classes [19] {
Interface [ <internal:teds> interface Teds\Values extends Traversable, Countable ] {
- Constants [0] {
@@ -355,6 +355,216 @@ Extension [ <persistent> extension #99 teds version 0.12.0 ] {
}
}
+ Class [ <internal:teds> <iterateable> final class Teds\BitSet implements IteratorAggregate, Traversable, Teds\ListInterface, Teds\Values, Countable, ArrayAccess, Teds\Collection, JsonSerializable ] {
+
+ - Constants [0] {
+ }
+
+ - Static properties [0] {
+ }
+
+ - Static methods [1] {
+ Method [ <internal:teds> static public method __set_state ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> array $array ]
+ }
+ - Return [ Teds\BitSet ]
+ }
+ }
+
+ - Properties [0] {
+ }
+
+ - Methods [24] {
+ Method [ <internal:teds, ctor> public method __construct ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <optional> iterable $iterator = [] ]
+ }
+ }
+
+ Method [ <internal:teds, prototype IteratorAggregate> public method getIterator ] {
+
+ - Parameters [0] {
+ }
+ - Return [ InternalIterator ]
+ }
+
+ Method [ <internal:teds, prototype Countable> public method count ] {
+
+ - Parameters [0] {
+ }
+ - Return [ int ]
+ }
+
+ Method [ <internal:teds, prototype Teds\Values> public method isEmpty ] {
+
+ - Parameters [0] {
+ }
+ - Return [ bool ]
+ }
+
+ Method [ <internal:teds> public method capacity ] {
+
+ - Parameters [0] {
+ }
+ - Return [ int ]
+ }
+
+ Method [ <internal:teds> public method __serialize ] {
+
+ - Parameters [0] {
+ }
+ - Return [ array ]
+ }
+
+ Method [ <internal:teds> public method __unserialize ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> array $data ]
+ }
+ - Return [ void ]
+ }
+
+ Method [ <internal:teds, prototype Teds\ListInterface> public method push ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <optional> mixed ...$values ]
+ }
+ - Return [ void ]
+ }
+
+ Method [ <internal:teds> public method pushBits ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <optional> bool ...$values ]
+ }
+ - Return [ void ]
+ }
+
+ Method [ <internal:teds, prototype Teds\ListInterface> public method pop ] {
+
+ - Parameters [0] {
+ }
+ - Return [ bool ]
+ }
+
+ Method [ <internal:teds, prototype Teds\Collection> public method toArray ] {
+
+ - Parameters [0] {
+ }
+ - Return [ array ]
+ }
+
+ Method [ <internal:teds, prototype Teds\Values> public method values ] {
+
+ - Parameters [0] {
+ }
+ - Return [ array ]
+ }
+
+ Method [ <internal:teds, prototype Teds\ListInterface> public method get ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> int $offset ]
+ }
+ - Return [ bool ]
+ }
+
+ Method [ <internal:teds, prototype Teds\ListInterface> public method set ] {
+
+ - Parameters [2] {
+ Parameter #0 [ <required> int $offset ]
+ Parameter #1 [ <required> mixed $value ]
+ }
+ - Return [ void ]
+ }
+
+ Method [ <internal:teds> public method setBit ] {
+
+ - Parameters [2] {
+ Parameter #0 [ <required> int $offset ]
+ Parameter #1 [ <required> bool $value ]
+ }
+ - Return [ void ]
+ }
+
+ Method [ <internal:teds, prototype ArrayAccess> public method offsetGet ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> mixed $offset ]
+ }
+ - Return [ mixed ]
+ }
+
+ Method [ <internal:teds, prototype ArrayAccess> public method offsetExists ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> mixed $offset ]
+ }
+ - Return [ bool ]
+ }
+
+ Method [ <internal:teds, prototype Teds\Collection> public method containsKey ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> mixed $offset ]
+ }
+ - Return [ bool ]
+ }
+
+ Method [ <internal:teds, prototype ArrayAccess> public method offsetSet ] {
+
+ - Parameters [2] {
+ Parameter #0 [ <required> mixed $offset ]
+ Parameter #1 [ <required> mixed $value ]
+ }
+ - Return [ void ]
+ }
+
+ Method [ <internal:teds, prototype ArrayAccess> public method offsetUnset ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> mixed $offset ]
+ }
+ - Return [ void ]
+ }
+
+ Method [ <internal:teds> public method indexOf ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> bool $value ]
+ }
+ - Return [ ?int ]
+ }
+
+ Method [ <internal:teds, prototype Teds\Values> public method contains ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> mixed $value ]
+ }
+ - Return [ bool ]
+ }
+
+ Method [ <internal:teds, prototype JsonSerializable> public method jsonSerialize ] {
+
+ - Parameters [0] {
+ }
+ - Return [ array ]
+ }
+
+ Method [ <internal:teds> public method setSize ] {
+
+ - Parameters [2] {
+ Parameter #0 [ <required> int $size ]
+ Parameter #1 [ <optional> bool $default = false ]
+ }
+ - Return [ void ]
+ }
+ }
+ }
+
Class [ <internal:teds> <iterateable> final class Teds\Deque implements IteratorAggregate, Traversable, Teds\ListInterface, Teds\Values, Countable, ArrayAccess, Teds\Collection, JsonSerializable ] {
- Constants [0] {
@@ -1924,7 +2134,7 @@ Extension [ <persistent> extension #99 teds version 0.12.0 ] {
- Properties [0] {
}
- - Methods [15] {
+ - Methods [16] {
Method [ <internal:teds, ctor> public method __construct ] {
- Parameters [1] {
@@ -2017,6 +2227,14 @@ Extension [ <persistent> extension #99 teds version 0.12.0 ] {
- Return [ array ]
}
+ Method [ <internal:teds> public method contains ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> mixed $value ]
+ }
+ - Return [ bool ]
+ }
+
Method [ <internal:teds> public method __serialize ] {
- Parameters [0] {
@@ -2055,7 +2273,7 @@ Extension [ <persistent> extension #99 teds version 0.12.0 ] {
- Properties [0] {
}
- - Methods [15] {
+ - Methods [16] {
Method [ <internal:teds, ctor> public method __construct ] {
- Parameters [1] {
@@ -2148,6 +2366,14 @@ Extension [ <persistent> extension #99 teds version 0.12.0 ] {
- Return [ array ]
}
+ Method [ <internal:teds> public method contains ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> mixed $value ]
+ }
+ - Return [ bool ]
+ }
+
Method [ <internal:teds> public method __serialize ] {
- Parameters [0] {
diff --git a/php-pecl-teds.spec b/php-pecl-teds.spec
index 1c97555..7ccfec7 100644
--- a/php-pecl-teds.spec
+++ b/php-pecl-teds.spec
@@ -19,7 +19,7 @@
%global pecl_name teds
%global ini_name 40-%{pecl_name}.ini
-%global upstream_version 0.12.0
+%global upstream_version 0.14.0
#global upstream_prever a1
Summary: Tentative Extra Data Structures
@@ -194,6 +194,9 @@ fi
%changelog
+* Mon Feb 14 2022 Remi Collet <remi@remirepo.net> - 0.14.0-1
+- update to 0.14.0
+
* Thu Feb 10 2022 Remi Collet <remi@remirepo.net> - 0.12.0-1
- update to 0.12.0