summaryrefslogtreecommitdiffstats
path: root/php-pecl-swoole4.spec
diff options
context:
space:
mode:
Diffstat (limited to 'php-pecl-swoole4.spec')
-rw-r--r--php-pecl-swoole4.spec15
1 files changed, 12 insertions, 3 deletions
diff --git a/php-pecl-swoole4.spec b/php-pecl-swoole4.spec
index 9cf2dbe..921ff08 100644
--- a/php-pecl-swoole4.spec
+++ b/php-pecl-swoole4.spec
@@ -17,7 +17,7 @@
%global with_zts 0%{!?_without_zts:%{?__ztsphp:1}}
%global pecl_name swoole
-# After 20-sockets
+# After 20-sockets, 20-json and 20-mysqlnd
%global ini_name 40-%{pecl_name}.ini
%global with_nghttpd2 1
@@ -27,7 +27,7 @@
%global with_brotli 0
%endif
-%global upstream_version 4.5.5
+%global upstream_version 4.5.6
#global upstream_prever RC2
@@ -49,10 +49,11 @@ BuildRequires: %{?dtsprefix}gcc-c++
%endif
BuildRequires: %{?scl_prefix}php-devel > 7.1
BuildRequires: %{?scl_prefix}php-pear
+BuildRequires: %{?scl_prefix}php-json
BuildRequires: %{?scl_prefix}php-sockets
BuildRequires: %{?scl_prefix}php-mysqlnd
BuildRequires: pcre-devel
-BuildRequires: openssl-devel
+BuildRequires: openssl-devel >= 1.0.2
BuildRequires: zlib-devel
%if %{with_brotli}
BuildRequires: brotli-devel
@@ -60,6 +61,7 @@ BuildRequires: brotli-devel
Requires: %{?scl_prefix}php(zend-abi) = %{php_zend_api}
Requires: %{?scl_prefix}php(api) = %{php_core_api}
+Requires: %{?scl_prefix}php-json%{?_isa}
Requires: %{?scl_prefix}php-sockets%{?_isa}
Requires: %{?scl_prefix}php-mysqlnd%{?_isa}
%{?_sclreq:Requires: %{?scl_prefix}runtime%{?_sclreq}%{?_isa}}
@@ -206,6 +208,7 @@ peclbuild() {
--enable-openssl \
--enable-http2 \
--enable-mysqlnd \
+ --enable-swoole-json \
--with-libdir=%{_lib} \
--with-php-config=$1
@@ -281,6 +284,7 @@ fi
%check
OPT="--no-php-ini"
+[ -f %{php_extdir}/json.so ] && OPT="$OPT -d extension=json.so"
[ -f %{php_extdir}/sockets.so ] && OPT="$OPT -d extension=sockets.so"
[ -f %{php_extdir}/mysqlnd.so ] && OPT="$OPT -d extension=mysqlnd.so"
@@ -331,6 +335,11 @@ cd ../ZTS
%changelog
+* Fri Oct 30 2020 Remi Collet <remi@remirepo.net> - 4.5.6-1
+- update to 4.5.6
+- raise dependency on openssl 1.0.2 (drop EL-6 support)
+- add dependency on json extension
+
* Thu Oct 15 2020 Remi Collet <remi@remirepo.net> - 4.5.5-1
- update to 4.5.5
- drop patches merged upstream