summaryrefslogtreecommitdiffstats
path: root/php-pecl-swoole4.spec
diff options
context:
space:
mode:
Diffstat (limited to 'php-pecl-swoole4.spec')
-rw-r--r--php-pecl-swoole4.spec20
1 files changed, 6 insertions, 14 deletions
diff --git a/php-pecl-swoole4.spec b/php-pecl-swoole4.spec
index 6afe5b5..9cf2dbe 100644
--- a/php-pecl-swoole4.spec
+++ b/php-pecl-swoole4.spec
@@ -27,26 +27,20 @@
%global with_brotli 0
%endif
-%global upstream_version 4.5.4
+%global upstream_version 4.5.5
#global upstream_prever RC2
Summary: PHP's asynchronous concurrent distributed networking framework
Name: %{?sub_prefix}php-pecl-%{pecl_name}4
Version: %{upstream_version}%{?upstream_prever:~%{upstream_prever}}
-Release: 3%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
+Release: 1%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
# Extension is ASL 2.0
# Hiredis is BSD
License: ASL 2.0 and BSD
URL: https://pecl.php.net/package/%{pecl_name}
Source0: https://pecl.php.net/get/%{pecl_name}-%{upstream_version}%{?upstream_prever}.tgz
-Patch0: https://github.com/swoole/swoole-src/commit/bebc3a0890156b9067b19f9c56766d132647fd58.patch
-Patch1: https://github.com/swoole/swoole-src/commit/7d4eaed41ae94237ed9e4ae72ac166b6e7617047.patch
-Patch2: https://github.com/swoole/swoole-src/commit/0a1ab3d5b1cfde8b905192bec0535bc61b92871a.patch
-Patch3: https://patch-diff.githubusercontent.com/raw/swoole/swoole-src/pull/3686.patch
-Patch4: https://patch-diff.githubusercontent.com/raw/swoole/swoole-src/pull/3713.patch
-
%if 0%{?rhel} == 6
BuildRequires: devtoolset-6-toolchain
%else
@@ -169,12 +163,6 @@ sed \
cd NTS
-%patch0 -p1 -b .up0
-%patch1 -p1 -b .up1
-%patch2 -p1 -b .up2
-%patch3 -p1 -b .pr3686
-%patch4 -p1 -b .pr3713
-
# Sanity check, really often broken
extver=$(sed -n '/#define SWOOLE_VERSION /{s/.* "//;s/".*$//;p}' include/swoole_version.h)
if test "x${extver}" != "x%{upstream_version}%{?upstream_prever}"; then
@@ -343,6 +331,10 @@ cd ../ZTS
%changelog
+* Thu Oct 15 2020 Remi Collet <remi@remirepo.net> - 4.5.5-1
+- update to 4.5.5
+- drop patches merged upstream
+
* Wed Sep 30 2020 Remi Collet <remi@remirepo.net> - 4.5.4-3
- rebuild for PHP 8.0.0RC1
- add patch from https://github.com/swoole/swoole-src/pull/3713