summaryrefslogtreecommitdiffstats
path: root/php-pecl-swoole4.spec
diff options
context:
space:
mode:
Diffstat (limited to 'php-pecl-swoole4.spec')
-rw-r--r--php-pecl-swoole4.spec25
1 files changed, 19 insertions, 6 deletions
diff --git a/php-pecl-swoole4.spec b/php-pecl-swoole4.spec
index 18061a6..2160d67 100644
--- a/php-pecl-swoole4.spec
+++ b/php-pecl-swoole4.spec
@@ -18,16 +18,17 @@
%global with_zts 0%{!?_without_zts:%{?__ztsphp:1}}
%global pecl_name swoole
# After 20-sockets, 20-json and 20-mysqlnd
-%global ini_name 40-%{pecl_name}.ini
+%global ini_name 40-%{pecl_name}.ini
-%global with_nghttpd2 1
+%bcond_without cares
+%bcond_without nghttpd2
%if 0%{?fedora} >= 25 || 0%{?rhel} >= 8
-%global with_brotli 1
+%bcond_without brotli
%else
-%global with_brotli 0
+%bcond_with brotli
%endif
-%global upstream_version 4.6.7
+%global upstream_version 4.7.0
#global upstream_prever RC2
@@ -54,7 +55,10 @@ BuildRequires: pcre-devel
BuildRequires: openssl-devel >= 1.0.2
BuildRequires: zlib-devel
BuildRequires: libcurl-devel
-%if %{with_brotli}
+%if %{with cares}
+BuildRequires: c-ares-devel
+%endif
+%if %{with brotli}
BuildRequires: brotli-devel
%endif
@@ -100,6 +104,9 @@ Obsoletes: php74-pecl-%{pecl_name} <= %{version}
%if "%{php_version}" > "8.0"
Obsoletes: php80-pecl-%{pecl_name} <= %{version}
%endif
+%if "%{php_version}" > "8.1"
+Obsoletes: php81-pecl-%{pecl_name} <= %{version}
+%endif
%endif
@@ -197,6 +204,9 @@ peclbuild() {
--enable-mysqlnd \
--enable-swoole-json \
--enable-swoole-curl \
+%if %{with cares}
+ --enable-cares \
+%endif
--with-libdir=%{_lib} \
--with-php-config=$1
@@ -320,6 +330,9 @@ cd ../ZTS
%changelog
+* Mon Jul 19 2021 Remi Collet <remi@remirepo.net> - 4.7.0-1
+- update to 4.7.0
+
* Sun May 16 2021 Remi Collet <remi@remirepo.net> - 4.6.7-1
- update to 4.6.7