summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--5fee743356e035e47d260299b80b99d1b020908c.patch38
-rw-r--r--PHPINFO4
-rw-r--r--REFLECTION72
-rw-r--r--php-pecl-swoole4.spec11
4 files changed, 72 insertions, 53 deletions
diff --git a/5fee743356e035e47d260299b80b99d1b020908c.patch b/5fee743356e035e47d260299b80b99d1b020908c.patch
deleted file mode 100644
index f28cb08..0000000
--- a/5fee743356e035e47d260299b80b99d1b020908c.patch
+++ /dev/null
@@ -1,38 +0,0 @@
-From 5fee743356e035e47d260299b80b99d1b020908c Mon Sep 17 00:00:00 2001
-From: twosee <twose@qq.com>
-Date: Sun, 10 Mar 2019 12:18:48 +0800
-Subject: [PATCH] Fix #2411 (Build issue on 32-bit).
-
----
- include/context.h | 2 +-
- src/coroutine/base.cc | 4 ++--
- 2 files changed, 3 insertions(+), 3 deletions(-)
-
-diff --git a/include/context.h b/include/context.h
-index 636c35509..2de69c416 100644
---- a/include/context.h
-+++ b/include/context.h
-@@ -81,7 +81,7 @@ class Context
- bool SwapIn();
- bool SwapOut();
- static void context_func(void* arg);
--#ifdef SW_LOG_TRACE_OPEN
-+#if !defined(SW_NO_USE_ASM_CONTEXT) && defined(SW_LOG_TRACE_OPEN)
- ssize_t get_stack_usage();
- #endif
- public:
-diff --git a/src/coroutine/base.cc b/src/coroutine/base.cc
-index a08294af4..a7dafcaad 100644
---- a/src/coroutine/base.cc
-+++ b/src/coroutine/base.cc
-@@ -82,8 +82,8 @@ void Coroutine::close()
- {
- on_close(task);
- }
--#ifdef SW_LOG_TRACE_OPEN
-- swTraceLog(SW_TRACE_CONTEXT, "coroutine#%ld stack memroy use less than %ld bytes.", get_cid(), ctx.get_stack_usage());
-+#ifndef SW_NO_USE_ASM_CONTEXT
-+ swTraceLog(SW_TRACE_CONTEXT, "coroutine#%ld stack memory use less than %ld bytes.", get_cid(), ctx.get_stack_usage());
- #endif
- current = origin;
- coroutines.erase(cid);
diff --git a/PHPINFO b/PHPINFO
index 77fb439..be8766d 100644
--- a/PHPINFO
+++ b/PHPINFO
@@ -3,8 +3,8 @@ swoole
Swoole => enabled
Author => Swoole Team <team@swoole.com>
-Version => 4.3.0
-Built => Mar 7 2019 10:01:54
+Version => 4.3.1
+Built => Mar 13 2019 08:30:50
coroutine => enabled
trace_log => enabled
epoll => enabled
diff --git a/REFLECTION b/REFLECTION
index 278d8e1..c72e6ca 100644
--- a/REFLECTION
+++ b/REFLECTION
@@ -1,4 +1,4 @@
-Extension [ <persistent> extension #153 swoole version 4.3.0 ] {
+Extension [ <persistent> extension #153 swoole version 4.3.1 ] {
- INI {
Entry [ swoole.enable_coroutine <ALL> ]
@@ -16,11 +16,11 @@ Extension [ <persistent> extension #153 swoole version 4.3.0 ] {
}
- Constants [256] {
- Constant [ string SWOOLE_VERSION ] { 4.3.0 }
- Constant [ integer SWOOLE_VERSION_ID ] { 40300 }
+ Constant [ string SWOOLE_VERSION ] { 4.3.1 }
+ Constant [ integer SWOOLE_VERSION_ID ] { 40301 }
Constant [ integer SWOOLE_MAJOR_VERSION ] { 4 }
Constant [ integer SWOOLE_MINOR_VERSION ] { 3 }
- Constant [ integer SWOOLE_RELEASE_VERSION ] { 0 }
+ Constant [ integer SWOOLE_RELEASE_VERSION ] { 1 }
Constant [ string SWOOLE_EXTRA_VERSION ] { }
Constant [ boolean SWOOLE_DEBUG ] { }
Constant [ integer SWOOLE_BASE ] { 1 }
@@ -198,7 +198,7 @@ Extension [ <persistent> extension #153 swoole version 4.3.0 ] {
Constant [ integer SWOOLE_HTTP_CLIENT_ESTATUS_REQUEST_TIMEOUT ] { -2 }
Constant [ integer SWOOLE_HTTP_CLIENT_ESTATUS_SERVER_RESET ] { -3 }
Constant [ integer SWOOLE_DEFAULT_MAX_CORO_NUM ] { 3000 }
- Constant [ integer SWOOLE_MAX_CORO_NUM_LIMIT ] { 9223372036854775807 }
+ Constant [ integer SWOOLE_CORO_MAX_NUM_LIMIT ] { 9223372036854775807 }
Constant [ integer SWOOLE_CORO_INIT ] { 0 }
Constant [ integer SWOOLE_CORO_WAITING ] { 1 }
Constant [ integer SWOOLE_CORO_RUNNING ] { 2 }
@@ -500,7 +500,7 @@ Extension [ <persistent> extension #153 swoole version 4.3.0 ] {
}
}
- - Classes [42] {
+ - Classes [43] {
Class [ <internal:swoole> class Swoole\Timer ] {
- Constants [0] {
@@ -1440,9 +1440,10 @@ Extension [ <persistent> extension #153 swoole version 4.3.0 ] {
- Static methods [0] {
}
- - Properties [2] {
+ - Properties [3] {
Property [ <default> public $fd ]
Property [ <default> public $errCode ]
+ Property [ <default> public $errMsg ]
}
- Methods [16] {
@@ -3610,6 +3611,63 @@ Extension [ <persistent> extension #153 swoole version 4.3.0 ] {
}
}
+ Class [ <internal:swoole> class Swoole\Coroutine\Http\Client\Exception extends Swoole\Exception implements Throwable ] {
+
+ - Constants [0] {
+ }
+
+ - Static properties [0] {
+ }
+
+ - Static methods [0] {
+ }
+
+ - Properties [4] {
+ Property [ <default> protected $message ]
+ Property [ <default> protected $code ]
+ Property [ <default> protected $file ]
+ Property [ <default> protected $line ]
+ }
+
+ - Methods [10] {
+ Method [ <internal:Core, inherits Exception, ctor> public method __construct ] {
+
+ - Parameters [3] {
+ Parameter #0 [ <optional> $message ]
+ Parameter #1 [ <optional> $code ]
+ Parameter #2 [ <optional> $previous ]
+ }
+ }
+
+ Method [ <internal:Core, inherits Exception> public method __wakeup ] {
+ }
+
+ Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getMessage ] {
+ }
+
+ Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getCode ] {
+ }
+
+ Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getFile ] {
+ }
+
+ Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getLine ] {
+ }
+
+ Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getTrace ] {
+ }
+
+ Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getPrevious ] {
+ }
+
+ Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getTraceAsString ] {
+ }
+
+ Method [ <internal:Core, inherits Exception, prototype Throwable> public method __toString ] {
+ }
+ }
+ }
+
Class [ <internal:swoole> class Swoole\Coroutine ] {
- Constants [0] {
diff --git a/php-pecl-swoole4.spec b/php-pecl-swoole4.spec
index 665e168..55b81d1 100644
--- a/php-pecl-swoole4.spec
+++ b/php-pecl-swoole4.spec
@@ -35,16 +35,14 @@
Summary: PHP's asynchronous concurrent distributed networking framework
Name: %{?sub_prefix}php-pecl-%{pecl_name}4
-Version: 4.3.0
-Release: 2%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
+Version: 4.3.1
+Release: 1%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
# Extension is ASL 2.0
# Hiredis is BSD
License: ASL 2.0 and BSD
URL: http://pecl.php.net/package/%{pecl_name}
Source0: http://pecl.php.net/get/%{pecl_name}-%{version}.tgz
-Patch0: https://github.com/swoole/swoole-src/commit/5fee743356e035e47d260299b80b99d1b020908c.patch
-
%if 0%{?rhel} == 6
BuildRequires: devtoolset-6-toolchain
%else
@@ -169,8 +167,6 @@ sed \
cd NTS
-%patch0 -p1
-
# Sanity check, really often broken
extver=$(sed -n '/#define SWOOLE_VERSION /{s/.* "//;s/".*$//;p}' include/swoole.h)
if test "x${extver}" != "x%{version}%{?prever:-%{prever}}"; then
@@ -339,6 +335,9 @@ cd ../ZTS
%changelog
+* Wed Mar 13 2019 Remi Collet <remi@remirepo.net> - 4.3.1-1
+- update to 4.3.1
+
* Mon Mar 11 2019 Remi Collet <remi@remirepo.net> - 4.3.0-2
- test build for upstream patch