summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--5fee743356e035e47d260299b80b99d1b020908c.patch38
-rw-r--r--php-pecl-swoole4.spec11
2 files changed, 46 insertions, 3 deletions
diff --git a/5fee743356e035e47d260299b80b99d1b020908c.patch b/5fee743356e035e47d260299b80b99d1b020908c.patch
new file mode 100644
index 0000000..f28cb08
--- /dev/null
+++ b/5fee743356e035e47d260299b80b99d1b020908c.patch
@@ -0,0 +1,38 @@
+From 5fee743356e035e47d260299b80b99d1b020908c Mon Sep 17 00:00:00 2001
+From: twosee <twose@qq.com>
+Date: Sun, 10 Mar 2019 12:18:48 +0800
+Subject: [PATCH] Fix #2411 (Build issue on 32-bit).
+
+---
+ include/context.h | 2 +-
+ src/coroutine/base.cc | 4 ++--
+ 2 files changed, 3 insertions(+), 3 deletions(-)
+
+diff --git a/include/context.h b/include/context.h
+index 636c35509..2de69c416 100644
+--- a/include/context.h
++++ b/include/context.h
+@@ -81,7 +81,7 @@ class Context
+ bool SwapIn();
+ bool SwapOut();
+ static void context_func(void* arg);
+-#ifdef SW_LOG_TRACE_OPEN
++#if !defined(SW_NO_USE_ASM_CONTEXT) && defined(SW_LOG_TRACE_OPEN)
+ ssize_t get_stack_usage();
+ #endif
+ public:
+diff --git a/src/coroutine/base.cc b/src/coroutine/base.cc
+index a08294af4..a7dafcaad 100644
+--- a/src/coroutine/base.cc
++++ b/src/coroutine/base.cc
+@@ -82,8 +82,8 @@ void Coroutine::close()
+ {
+ on_close(task);
+ }
+-#ifdef SW_LOG_TRACE_OPEN
+- swTraceLog(SW_TRACE_CONTEXT, "coroutine#%ld stack memroy use less than %ld bytes.", get_cid(), ctx.get_stack_usage());
++#ifndef SW_NO_USE_ASM_CONTEXT
++ swTraceLog(SW_TRACE_CONTEXT, "coroutine#%ld stack memory use less than %ld bytes.", get_cid(), ctx.get_stack_usage());
+ #endif
+ current = origin;
+ coroutines.erase(cid);
diff --git a/php-pecl-swoole4.spec b/php-pecl-swoole4.spec
index 9e60ea1..665e168 100644
--- a/php-pecl-swoole4.spec
+++ b/php-pecl-swoole4.spec
@@ -36,13 +36,15 @@
Summary: PHP's asynchronous concurrent distributed networking framework
Name: %{?sub_prefix}php-pecl-%{pecl_name}4
Version: 4.3.0
-Release: 1%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
+Release: 2%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
# Extension is ASL 2.0
# Hiredis is BSD
License: ASL 2.0 and BSD
URL: http://pecl.php.net/package/%{pecl_name}
Source0: http://pecl.php.net/get/%{pecl_name}-%{version}.tgz
+Patch0: https://github.com/swoole/swoole-src/commit/5fee743356e035e47d260299b80b99d1b020908c.patch
+
%if 0%{?rhel} == 6
BuildRequires: devtoolset-6-toolchain
%else
@@ -167,6 +169,8 @@ sed \
cd NTS
+%patch0 -p1
+
# Sanity check, really often broken
extver=$(sed -n '/#define SWOOLE_VERSION /{s/.* "//;s/".*$//;p}' include/swoole.h)
if test "x${extver}" != "x%{version}%{?prever:-%{prever}}"; then
@@ -205,9 +209,7 @@ peclbuild() {
%configure \
--enable-swoole \
--enable-sockets \
-%if %{__isa_bits} == 64
--enable-trace-log \
-%endif
--enable-openssl \
--enable-http2 \
%if %{with_pgsql}
@@ -337,6 +339,9 @@ cd ../ZTS
%changelog
+* Mon Mar 11 2019 Remi Collet <remi@remirepo.net> - 4.3.0-2
+- test build for upstream patch
+
* Thu Mar 7 2019 Remi Collet <remi@remirepo.net> - 4.3.0-1
- update to 4.3.0
- drop dependencies on libnghttp2 and c-ares