summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--PHPINFO4
-rw-r--r--REFLECTION44
-rw-r--r--php-pecl-swoole4.spec6
3 files changed, 45 insertions, 9 deletions
diff --git a/PHPINFO b/PHPINFO
index e04de66..9669bd9 100644
--- a/PHPINFO
+++ b/PHPINFO
@@ -3,8 +3,8 @@ swoole
Swoole => enabled
Author => Swoole Team <team@swoole.com>
-Version => 4.4.2
-Built => Jul 26 2019 09:41:58
+Version => 4.4.3
+Built => Aug 3 2019 07:51:51
coroutine => enabled
trace_log => enabled
epoll => enabled
diff --git a/REFLECTION b/REFLECTION
index 4e3c9e7..dbc7ebc 100644
--- a/REFLECTION
+++ b/REFLECTION
@@ -1,4 +1,4 @@
-Extension [ <persistent> extension #153 swoole version 4.4.2 ] {
+Extension [ <persistent> extension #153 swoole version 4.4.3 ] {
- INI {
Entry [ swoole.enable_coroutine <ALL> ]
@@ -22,11 +22,11 @@ Extension [ <persistent> extension #153 swoole version 4.4.2 ] {
}
- Constants [311] {
- Constant [ string SWOOLE_VERSION ] { 4.4.2 }
- Constant [ integer SWOOLE_VERSION_ID ] { 40402 }
+ Constant [ string SWOOLE_VERSION ] { 4.4.3 }
+ Constant [ integer SWOOLE_VERSION_ID ] { 40403 }
Constant [ integer SWOOLE_MAJOR_VERSION ] { 4 }
Constant [ integer SWOOLE_MINOR_VERSION ] { 4 }
- Constant [ integer SWOOLE_RELEASE_VERSION ] { 2 }
+ Constant [ integer SWOOLE_RELEASE_VERSION ] { 3 }
Constant [ string SWOOLE_EXTRA_VERSION ] { }
Constant [ boolean SWOOLE_DEBUG ] { }
Constant [ integer SWOOLE_BASE ] { 1 }
@@ -3756,7 +3756,7 @@ Extension [ <persistent> extension #153 swoole version 4.4.2 ] {
Property [ <default> public $errMsg ]
}
- - Methods [161] {
+ - Methods [165] {
Method [ <internal:swoole, ctor> public method __construct ] {
- Parameters [1] {
@@ -4478,6 +4478,40 @@ Extension [ <persistent> extension #153 swoole version 4.4.2 ] {
}
}
+ Method [ <internal:swoole> public method zPopMin ] {
+
+ - Parameters [2] {
+ Parameter #0 [ <required> $key ]
+ Parameter #1 [ <required> $count ]
+ }
+ }
+
+ Method [ <internal:swoole> public method zPopMax ] {
+
+ - Parameters [2] {
+ Parameter #0 [ <required> $key ]
+ Parameter #1 [ <required> $count ]
+ }
+ }
+
+ Method [ <internal:swoole> public method bzPopMin ] {
+
+ - Parameters [3] {
+ Parameter #0 [ <required> $key ]
+ Parameter #1 [ <required> $timeout_or_key ]
+ Parameter #2 [ <optional> $extra_args ]
+ }
+ }
+
+ Method [ <internal:swoole> public method bzPopMax ] {
+
+ - Parameters [3] {
+ Parameter #0 [ <required> $key ]
+ Parameter #1 [ <required> $timeout_or_key ]
+ Parameter #2 [ <optional> $extra_args ]
+ }
+ }
+
Method [ <internal:swoole> public method zDeleteRangeByScore ] {
- Parameters [3] {
diff --git a/php-pecl-swoole4.spec b/php-pecl-swoole4.spec
index 29e6d16..250aad5 100644
--- a/php-pecl-swoole4.spec
+++ b/php-pecl-swoole4.spec
@@ -30,7 +30,7 @@
Summary: PHP's asynchronous concurrent distributed networking framework
Name: %{?sub_prefix}php-pecl-%{pecl_name}4
-Version: 4.4.2
+Version: 4.4.3
Release: 1%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
# Extension is ASL 2.0
# Hiredis is BSD
@@ -318,7 +318,6 @@ cd ../ZTS
%doc %{pecl_docdir}/%{pecl_name}/include
%doc %{pecl_docdir}/%{pecl_name}/thirdparty
%doc %{pecl_docdir}/%{pecl_name}/travis
-%doc %{pecl_docdir}/%{pecl_name}/src
%{php_incldir}/ext/%{pecl_name}
%if %{with_zts}
@@ -327,6 +326,9 @@ cd ../ZTS
%changelog
+* Sat Aug 3 2019 Remi Collet <remi@remirepo.net> - 4.4.3-1
+- update to 4.4.3
+
* Fri Jul 26 2019 Remi Collet <remi@remirepo.net> - 4.4.2-1
- update to 4.4.2
- drop patch merged upstream