summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--0a1ab3d5b1cfde8b905192bec0535bc61b92871a.patch123
-rw-r--r--3686.patch23
-rw-r--r--3713.patch30
-rw-r--r--7d4eaed41ae94237ed9e4ae72ac166b6e7617047.patch25
-rw-r--r--PHPINFO4
-rw-r--r--REFLECTION48
-rw-r--r--bebc3a0890156b9067b19f9c56766d132647fd58.patch41
-rw-r--r--php-pecl-swoole4.spec20
8 files changed, 45 insertions, 269 deletions
diff --git a/0a1ab3d5b1cfde8b905192bec0535bc61b92871a.patch b/0a1ab3d5b1cfde8b905192bec0535bc61b92871a.patch
deleted file mode 100644
index 8954a4f..0000000
--- a/0a1ab3d5b1cfde8b905192bec0535bc61b92871a.patch
+++ /dev/null
@@ -1,123 +0,0 @@
-From 0a1ab3d5b1cfde8b905192bec0535bc61b92871a Mon Sep 17 00:00:00 2001
-From: twosee <twose@qq.com>
-Date: Mon, 21 Sep 2020 19:05:45 +0800
-Subject: [PATCH] Fix PHP8 build (ext/sockets compatibility) (#3684)
-
----
- php_swoole.h | 14 +++++++++++++-
- swoole_client.cc | 2 +-
- swoole_event.cc | 14 +++++++++++---
- swoole_server.cc | 2 +-
- swoole_server_port.cc | 2 +-
- 5 files changed, 27 insertions(+), 7 deletions(-)
-
-diff --git a/php_swoole.h b/php_swoole.h
-index 9137f21b8e..35be68aae7 100644
---- a/php_swoole.h
-+++ b/php_swoole.h
-@@ -487,7 +487,19 @@ static sw_inline void _sw_zend_bailout(const char *filename, uint32_t lineno)
- (ptr) = &(val); \
- } while (0)
-
--#define SW_ZEND_REGISTER_RESOURCE(return_value, result, le_result) ZVAL_RES(return_value,zend_register_resource(result, le_result))
-+#if PHP_VERSION_ID < 80000
-+#define SW_ZVAL_SOCKET(return_value, result) \
-+ ZVAL_RES(return_value,zend_register_resource((void *) (result), php_sockets_le_socket()))
-+#else
-+#define SW_ZVAL_SOCKET(return_value, result) \
-+ ZVAL_OBJ(return_value, &result->std)
-+#endif
-+
-+#if PHP_VERSION_ID < 80000
-+#define SW_Z_SOCKET_P(zsocket) (php_socket *) zend_fetch_resource_ex(zsocket, nullptr, php_sockets_le_socket())
-+#else
-+#define SW_Z_SOCKET_P(zsocket) Z_SOCKET_P(zsocket)
-+#endif
-
- #ifndef ZVAL_IS_BOOL
- static sw_inline zend_bool ZVAL_IS_BOOL(zval *v)
-diff --git a/swoole_client.cc b/swoole_client.cc
-index f2a23b8198..bc5de62d8d 100644
---- a/swoole_client.cc
-+++ b/swoole_client.cc
-@@ -1244,7 +1244,7 @@ static PHP_METHOD(swoole_client, getSocket) {
- if (!socket_object) {
- RETURN_FALSE;
- }
-- SW_ZEND_REGISTER_RESOURCE(return_value, (void *) socket_object, php_sockets_le_socket());
-+ SW_ZVAL_SOCKET(return_value, socket_object);
- zsocket = sw_zval_dup(return_value);
- Z_TRY_ADDREF_P(zsocket);
- php_swoole_client_set_zsocket(ZEND_THIS, zsocket);
-diff --git a/swoole_event.cc b/swoole_event.cc
-index 8dfcca37f2..8cc7fc2996 100644
---- a/swoole_event.cc
-+++ b/swoole_event.cc
-@@ -318,7 +318,7 @@ int php_swoole_convert_to_fd(zval *zsocket) {
- #ifdef SWOOLE_SOCKETS_SUPPORT
- else {
- php_socket *php_sock;
-- if ((php_sock = (php_socket *) zend_fetch_resource_ex(zsocket, nullptr, php_sockets_le_socket()))) {
-+ if ((php_sock = SW_Z_SOCKET_P(zsocket))) {
- fd = php_sock->bsd_socket;
- return fd;
- }
-@@ -372,7 +372,7 @@ int php_swoole_convert_to_fd_ex(zval *zsocket, int *async) {
- #ifdef SWOOLE_SOCKETS_SUPPORT
- else {
- php_socket *php_sock;
-- if ((php_sock = (php_socket *) zend_fetch_resource_ex(zsocket, nullptr, php_sockets_le_socket()))) {
-+ if ((php_sock = SW_Z_SOCKET_P(zsocket))) {
- fd = php_sock->bsd_socket;
- *async = 1;
- return fd;
-@@ -386,7 +386,9 @@ int php_swoole_convert_to_fd_ex(zval *zsocket, int *async) {
-
- #ifdef SWOOLE_SOCKETS_SUPPORT
- php_socket *php_swoole_convert_to_socket(int sock) {
-- php_socket *socket_object = (php_socket *) emalloc(sizeof *socket_object);
-+ php_socket *socket_object;
-+#if PHP_VERSION_ID < 80000
-+ socket_object = (php_socket *) emalloc(sizeof *socket_object);
- sw_memset_zero(socket_object, sizeof(php_socket));
- socket_object->bsd_socket = sock;
- socket_object->blocking = 1;
-@@ -410,6 +412,12 @@ php_socket *php_swoole_convert_to_socket(int sock) {
- } else {
- socket_object->blocking = !(t & O_NONBLOCK);
- }
-+#else
-+ zval zsocket;
-+ object_init_ex(&zsocket, socket_ce);
-+ socket_object = Z_SOCKET_P(&zsocket);
-+ socket_import_file_descriptor(sock, socket_object);
-+#endif
- return socket_object;
- }
- #endif
-diff --git a/swoole_server.cc b/swoole_server.cc
-index 5605a5de45..6e56733692 100644
---- a/swoole_server.cc
-+++ b/swoole_server.cc
-@@ -3529,7 +3529,7 @@ static PHP_METHOD(swoole_server, getSocket) {
- if (!socket_object) {
- RETURN_FALSE;
- }
-- SW_ZEND_REGISTER_RESOURCE(return_value, (void *) socket_object, php_sockets_le_socket());
-+ SW_ZVAL_SOCKET(return_value, socket_object);
- zval *zsocket = sw_zval_dup(return_value);
- Z_TRY_ADDREF_P(zsocket);
- }
-diff --git a/swoole_server_port.cc b/swoole_server_port.cc
-index 55093ea513..9be0b4e691 100644
---- a/swoole_server_port.cc
-+++ b/swoole_server_port.cc
-@@ -688,7 +688,7 @@ static PHP_METHOD(swoole_server_port, getSocket) {
- if (!socket_object) {
- RETURN_FALSE;
- }
-- SW_ZEND_REGISTER_RESOURCE(return_value, (void *) socket_object, php_sockets_le_socket());
-+ SW_ZVAL_SOCKET(return_value, socket_object);
- zval *zsocket = sw_zval_dup(return_value);
- Z_TRY_ADDREF_P(zsocket);
- }
diff --git a/3686.patch b/3686.patch
deleted file mode 100644
index 09226cc..0000000
--- a/3686.patch
+++ /dev/null
@@ -1,23 +0,0 @@
-From 3ea5088acb27a4f2f0164b5621c54fb7b8767d47 Mon Sep 17 00:00:00 2001
-From: Remi Collet <remi@remirepo.net>
-Date: Mon, 21 Sep 2020 14:43:55 +0200
-Subject: [PATCH] fix build error: invalid conversion from 'const char*' to
- 'char*'
-
----
- src/protocol/ssl.cc | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
-diff --git a/src/protocol/ssl.cc b/src/protocol/ssl.cc
-index c9069c1a8a..2f48e0ac72 100644
---- a/src/protocol/ssl.cc
-+++ b/src/protocol/ssl.cc
-@@ -512,7 +512,7 @@ static int swSSL_check_name(const char *name, ASN1_STRING *pattern) {
- char *s, *end;
- size_t slen, plen;
-
-- s = name;
-+ s = (char *)name;
- slen = strlen(name);
-
- uchar *p = ASN1_STRING_data(pattern);
diff --git a/3713.patch b/3713.patch
deleted file mode 100644
index 87961db..0000000
--- a/3713.patch
+++ /dev/null
@@ -1,30 +0,0 @@
-From c7c83174a0bdf01ce202afaccb1eff45717ca427 Mon Sep 17 00:00:00 2001
-From: Remi Collet <remi@remirepo.net>
-Date: Wed, 30 Sep 2020 11:35:59 +0200
-Subject: [PATCH] fix for 8.0.0RC1
-
----
- php_swoole.h | 8 ++++++++
- 1 file changed, 8 insertions(+)
-
-diff --git a/php_swoole.h b/php_swoole.h
-index 35be68aae7..be7d2385dd 100644
---- a/php_swoole.h
-+++ b/php_swoole.h
-@@ -1129,8 +1129,16 @@ static sw_inline char* php_swoole_url_encode(const char *value, size_t value_len
-
- static sw_inline char* php_swoole_http_build_query(zval *zdata, size_t *length, smart_str *formstr)
- {
-+#if PHP_VERSION_ID < 80000
- if (php_url_encode_hash_ex(HASH_OF(zdata), formstr, NULL, 0, NULL, 0, NULL, 0, NULL, NULL, (int) PHP_QUERY_RFC1738) == FAILURE)
- {
-+#else
-+ if (HASH_OF(zdata)) {
-+ php_url_encode_hash_ex(HASH_OF(zdata), formstr, NULL, 0, NULL, 0, NULL, 0, NULL, NULL, (int) PHP_QUERY_RFC1738);
-+ }
-+ else
-+ {
-+#endif
- if (formstr->s)
- {
- smart_str_free(formstr);
diff --git a/7d4eaed41ae94237ed9e4ae72ac166b6e7617047.patch b/7d4eaed41ae94237ed9e4ae72ac166b6e7617047.patch
deleted file mode 100644
index e05780b..0000000
--- a/7d4eaed41ae94237ed9e4ae72ac166b6e7617047.patch
+++ /dev/null
@@ -1,25 +0,0 @@
-From 7d4eaed41ae94237ed9e4ae72ac166b6e7617047 Mon Sep 17 00:00:00 2001
-From: Yurun <admin@yurunsoft.com>
-Date: Sun, 20 Sep 2020 14:43:03 +0800
-Subject: [PATCH] Fix #3681 (#3682)
-
----
- src/protocol/ssl.cc | 2 ++
- 1 file changed, 2 insertions(+)
-
-diff --git a/src/protocol/ssl.cc b/src/protocol/ssl.cc
-index 61a3e56c0e..c9069c1a8a 100644
---- a/src/protocol/ssl.cc
-+++ b/src/protocol/ssl.cc
-@@ -71,9 +71,11 @@ static int swSSL_verify_cookie(SSL *ssl, const uchar *cookie, uint cookie_len);
- static void MAYBE_UNUSED swSSL_lock_callback(int mode, int type, const char *file, int line);
-
- static const SSL_METHOD *swSSL_get_method(swSSL_option *option) {
-+#ifdef SW_SUPPORT_DTLS
- if (option->protocols & SW_SSL_DTLS) {
- return DTLS_method();
- }
-+#endif
- return SSLv23_method();
- }
-
diff --git a/PHPINFO b/PHPINFO
index f724a91..2ffef5e 100644
--- a/PHPINFO
+++ b/PHPINFO
@@ -3,8 +3,8 @@ swoole
Swoole => enabled
Author => Swoole Team <team@swoole.com>
-Version => 4.5.4
-Built => Sep 20 2020 00:00:00
+Version => 4.5.5
+Built => Oct 15 2020 00:00:00
coroutine => enabled
trace_log => enabled
epoll => enabled
diff --git a/REFLECTION b/REFLECTION
index 29d64a2..1035325 100644
--- a/REFLECTION
+++ b/REFLECTION
@@ -1,4 +1,4 @@
-Extension [ <persistent> extension #117 swoole version 4.5.4 ] {
+Extension [ <persistent> extension #117 swoole version 4.5.5 ] {
- INI {
Entry [ swoole.enable_coroutine <ALL> ]
@@ -21,12 +21,12 @@ Extension [ <persistent> extension #117 swoole version 4.5.4 ] {
}
}
- - Constants [344] {
- Constant [ string SWOOLE_VERSION ] { 4.5.4 }
- Constant [ int SWOOLE_VERSION_ID ] { 40504 }
+ - Constants [353] {
+ Constant [ string SWOOLE_VERSION ] { 4.5.5 }
+ Constant [ int SWOOLE_VERSION_ID ] { 40505 }
Constant [ int SWOOLE_MAJOR_VERSION ] { 4 }
Constant [ int SWOOLE_MINOR_VERSION ] { 5 }
- Constant [ int SWOOLE_RELEASE_VERSION ] { 4 }
+ Constant [ int SWOOLE_RELEASE_VERSION ] { 5 }
Constant [ string SWOOLE_EXTRA_VERSION ] { }
Constant [ bool SWOOLE_DEBUG ] { }
Constant [ bool SWOOLE_HAVE_COMPRESSION ] { 1 }
@@ -124,6 +124,7 @@ Extension [ <persistent> extension #117 swoole version 4.5.4 ] {
Constant [ int SWOOLE_ERROR_SSL_BAD_CLIENT ] { 1015 }
Constant [ int SWOOLE_ERROR_SSL_BAD_PROTOCOL ] { 1016 }
Constant [ int SWOOLE_ERROR_SSL_RESET ] { 1017 }
+ Constant [ int SWOOLE_ERROR_SSL_HANDSHAKE_FAILED ] { 1018 }
Constant [ int SWOOLE_ERROR_PACKAGE_LENGTH_TOO_LARGE ] { 1201 }
Constant [ int SWOOLE_ERROR_PACKAGE_LENGTH_NOT_FOUND ] { 1202 }
Constant [ int SWOOLE_ERROR_DATA_LENGTH_TOO_LARGE ] { 1203 }
@@ -133,6 +134,7 @@ Extension [ <persistent> extension #117 swoole version 4.5.4 ] {
Constant [ int SWOOLE_ERROR_HTTP2_STREAM_ID_TOO_BIG ] { 3001 }
Constant [ int SWOOLE_ERROR_HTTP2_STREAM_NO_HEADER ] { 3002 }
Constant [ int SWOOLE_ERROR_HTTP2_STREAM_NOT_FOUND ] { 3003 }
+ Constant [ int SWOOLE_ERROR_HTTP2_STREAM_IGNORE ] { 3004 }
Constant [ int SWOOLE_ERROR_AIO_BAD_REQUEST ] { 4001 }
Constant [ int SWOOLE_ERROR_AIO_CANCELED ] { 4002 }
Constant [ int SWOOLE_ERROR_AIO_TIMEOUT ] { 4003 }
@@ -142,8 +144,11 @@ Extension [ <persistent> extension #117 swoole version 4.5.4 ] {
Constant [ int SWOOLE_ERROR_SOCKS5_UNSUPPORT_METHOD ] { 7002 }
Constant [ int SWOOLE_ERROR_SOCKS5_AUTH_FAILED ] { 7003 }
Constant [ int SWOOLE_ERROR_SOCKS5_SERVER_ERROR ] { 7004 }
+ Constant [ int SWOOLE_ERROR_SOCKS5_HANDSHAKE_FAILED ] { 7005 }
Constant [ int SWOOLE_ERROR_HTTP_PROXY_HANDSHAKE_ERROR ] { 8001 }
Constant [ int SWOOLE_ERROR_HTTP_INVALID_PROTOCOL ] { 8002 }
+ Constant [ int SWOOLE_ERROR_HTTP_PROXY_HANDSHAKE_FAILED ] { 8003 }
+ Constant [ int SWOOLE_ERROR_HTTP_PROXY_BAD_RESPONSE ] { 8004 }
Constant [ int SWOOLE_ERROR_WEBSOCKET_BAD_CLIENT ] { 8501 }
Constant [ int SWOOLE_ERROR_WEBSOCKET_BAD_OPCODE ] { 8502 }
Constant [ int SWOOLE_ERROR_WEBSOCKET_UNCONNECTED ] { 8503 }
@@ -180,6 +185,7 @@ Extension [ <persistent> extension #117 swoole version 4.5.4 ] {
Constant [ int SWOOLE_TRACE_CONN ] { 16 }
Constant [ int SWOOLE_TRACE_EVENT ] { 32 }
Constant [ int SWOOLE_TRACE_WORKER ] { 64 }
+ Constant [ int SWOOLE_TRACE_MEMORY ] { 128 }
Constant [ int SWOOLE_TRACE_REACTOR ] { 256 }
Constant [ int SWOOLE_TRACE_PHP ] { 512 }
Constant [ int SWOOLE_TRACE_HTTP ] { 1024 }
@@ -187,6 +193,7 @@ Extension [ <persistent> extension #117 swoole version 4.5.4 ] {
Constant [ int SWOOLE_TRACE_EOF_PROTOCOL ] { 4096 }
Constant [ int SWOOLE_TRACE_LENGTH_PROTOCOL ] { 8192 }
Constant [ int SWOOLE_TRACE_CLOSE ] { 16384 }
+ Constant [ int SWOOLE_TRACE_WEBSOCEKT ] { 32768 }
Constant [ int SWOOLE_TRACE_REDIS_CLIENT ] { 65536 }
Constant [ int SWOOLE_TRACE_MYSQL_CLIENT ] { 131072 }
Constant [ int SWOOLE_TRACE_HTTP_CLIENT ] { 262144 }
@@ -199,6 +206,7 @@ Extension [ <persistent> extension #117 swoole version 4.5.4 ] {
Constant [ int SWOOLE_TRACE_COROUTINE ] { 33554432 }
Constant [ int SWOOLE_TRACE_CONTEXT ] { 67108864 }
Constant [ int SWOOLE_TRACE_CO_HTTP_SERVER ] { 134217728 }
+ Constant [ int SWOOLE_TRACE_TABLE ] { 268435456 }
Constant [ int SWOOLE_TRACE_ALL ] { 4294967295 }
Constant [ int SWOOLE_LOG_DEBUG ] { 0 }
Constant [ int SWOOLE_LOG_TRACE ] { 1 }
@@ -315,6 +323,7 @@ Extension [ <persistent> extension #117 swoole version 4.5.4 ] {
Constant [ int SWOOLE_TASK_NOREPLY ] { 128 }
Constant [ int SWOOLE_WORKER_BUSY ] { 1 }
Constant [ int SWOOLE_WORKER_IDLE ] { 2 }
+ Constant [ int SWOOLE_WORKER_EXIT ] { 3 }
Constant [ int SWOOLE_WEBSOCKET_STATUS_CONNECTION ] { 1 }
Constant [ int SWOOLE_WEBSOCKET_STATUS_HANDSHAKE ] { 2 }
Constant [ int SWOOLE_WEBSOCKET_STATUS_ACTIVE ] { 3 }
@@ -1377,7 +1386,7 @@ Extension [ <persistent> extension #117 swoole version 4.5.4 ] {
- Properties [0] {
}
- - Methods [22] {
+ - Methods [23] {
Method [ <internal:swoole, ctor> public method __construct ] {
- Parameters [2] {
@@ -1436,6 +1445,13 @@ Extension [ <persistent> extension #117 swoole version 4.5.4 ] {
}
}
+ Method [ <internal:swoole> public method delete ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $key ]
+ }
+ }
+
Method [ <internal:swoole> public method exists ] {
- Parameters [1] {
@@ -5491,7 +5507,7 @@ Extension [ <persistent> extension #117 swoole version 4.5.4 ] {
- Static methods [0] {
}
- - Properties [25] {
+ - Properties [26] {
Property [ <default> private $onStart ]
Property [ <default> private $onShutdown ]
Property [ <default> private $onWorkerStart ]
@@ -5517,6 +5533,7 @@ Extension [ <persistent> extension #117 swoole version 4.5.4 ] {
Property [ <default> public $worker_id ]
Property [ <default> public $taskworker ]
Property [ <default> public $worker_pid ]
+ Property [ <default> public $stats_timer ]
}
- Methods [47] {
@@ -6151,7 +6168,7 @@ Extension [ <persistent> extension #117 swoole version 4.5.4 ] {
Property [ <default> public $trailer ]
}
- - Methods [20] {
+ - Methods [21] {
Method [ <internal:swoole> public method initHeader ] {
- Parameters [0] {
@@ -6248,6 +6265,12 @@ Extension [ <persistent> extension #117 swoole version 4.5.4 ] {
}
}
+ Method [ <internal:swoole> public method goaway ] {
+
+ - Parameters [0] {
+ }
+ }
+
Method [ <internal:swoole> public method write ] {
- Parameters [1] {
@@ -6331,7 +6354,7 @@ Extension [ <persistent> extension #117 swoole version 4.5.4 ] {
- Static methods [0] {
}
- - Properties [12] {
+ - Properties [13] {
Property [ <default> public $setting ]
Property [ <default> public $connections ]
Property [ <default> public $host ]
@@ -6344,6 +6367,7 @@ Extension [ <persistent> extension #117 swoole version 4.5.4 ] {
Property [ <default> public $worker_id ]
Property [ <default> public $taskworker ]
Property [ <default> public $worker_pid ]
+ Property [ <default> public $stats_timer ]
}
- Methods [47] {
@@ -6800,7 +6824,7 @@ Extension [ <persistent> extension #117 swoole version 4.5.4 ] {
}
}
- - Properties [12] {
+ - Properties [13] {
Property [ <default> public $setting ]
Property [ <default> public $connections ]
Property [ <default> public $host ]
@@ -6813,6 +6837,7 @@ Extension [ <persistent> extension #117 swoole version 4.5.4 ] {
Property [ <default> public $worker_id ]
Property [ <default> public $taskworker ]
Property [ <default> public $worker_pid ]
+ Property [ <default> public $stats_timer ]
}
- Methods [50] {
@@ -7309,7 +7334,7 @@ Extension [ <persistent> extension #117 swoole version 4.5.4 ] {
}
}
- - Properties [12] {
+ - Properties [13] {
Property [ <default> public $setting ]
Property [ <default> public $connections ]
Property [ <default> public $host ]
@@ -7322,6 +7347,7 @@ Extension [ <persistent> extension #117 swoole version 4.5.4 ] {
Property [ <default> public $worker_id ]
Property [ <default> public $taskworker ]
Property [ <default> public $worker_pid ]
+ Property [ <default> public $stats_timer ]
}
- Methods [49] {
diff --git a/bebc3a0890156b9067b19f9c56766d132647fd58.patch b/bebc3a0890156b9067b19f9c56766d132647fd58.patch
deleted file mode 100644
index 307737b..0000000
--- a/bebc3a0890156b9067b19f9c56766d132647fd58.patch
+++ /dev/null
@@ -1,41 +0,0 @@
-From bebc3a0890156b9067b19f9c56766d132647fd58 Mon Sep 17 00:00:00 2001
-From: twosee <twose@qq.com>
-Date: Sat, 19 Sep 2020 07:15:07 +0800
-Subject: [PATCH] Fix PHP8 build (zend_compile_string change) (#3675)
-
----
- php_swoole_cxx.cc | 13 ++++++++++---
- 1 file changed, 10 insertions(+), 3 deletions(-)
-
-diff --git a/php_swoole_cxx.cc b/php_swoole_cxx.cc
-index 0360cf2779..adfa535132 100644
---- a/php_swoole_cxx.cc
-+++ b/php_swoole_cxx.cc
-@@ -12,7 +12,13 @@ SW_API zend_string **sw_zend_known_strings = nullptr;
-
- //----------------------------------Swoole known string------------------------------------
-
--static zend_op_array *swoole_compile_string(zval *source_string, ZEND_STR_CONST char *filename);
-+#if PHP_VERSION_ID < 80000
-+typedef zval zend_source_string_t;
-+#else
-+typedef zend_string zend_source_string_t;
-+#endif
-+
-+static zend_op_array *swoole_compile_string(zend_source_string_t *source_string, ZEND_STR_CONST char *filename);
-
- bool zend::include(std::string file) {
- zend_file_handle file_handle;
-@@ -51,9 +57,10 @@ bool zend::include(std::string file) {
- }
-
- // for compatibly with dis_eval
--static zend_op_array *(*old_compile_string)(zval *source_string, ZEND_STR_CONST char *filename);
-
--static zend_op_array *swoole_compile_string(zval *source_string, ZEND_STR_CONST char *filename) {
-+static zend_op_array *(*old_compile_string)(zend_source_string_t *source_string, ZEND_STR_CONST char *filename);
-+
-+static zend_op_array *swoole_compile_string(zend_source_string_t *source_string, ZEND_STR_CONST char *filename) {
- zend_op_array *opa = old_compile_string(source_string, filename);
- opa->type = ZEND_USER_FUNCTION;
- return opa;
diff --git a/php-pecl-swoole4.spec b/php-pecl-swoole4.spec
index 6afe5b5..9cf2dbe 100644
--- a/php-pecl-swoole4.spec
+++ b/php-pecl-swoole4.spec
@@ -27,26 +27,20 @@
%global with_brotli 0
%endif
-%global upstream_version 4.5.4
+%global upstream_version 4.5.5
#global upstream_prever RC2
Summary: PHP's asynchronous concurrent distributed networking framework
Name: %{?sub_prefix}php-pecl-%{pecl_name}4
Version: %{upstream_version}%{?upstream_prever:~%{upstream_prever}}
-Release: 3%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
+Release: 1%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
# Extension is ASL 2.0
# Hiredis is BSD
License: ASL 2.0 and BSD
URL: https://pecl.php.net/package/%{pecl_name}
Source0: https://pecl.php.net/get/%{pecl_name}-%{upstream_version}%{?upstream_prever}.tgz
-Patch0: https://github.com/swoole/swoole-src/commit/bebc3a0890156b9067b19f9c56766d132647fd58.patch
-Patch1: https://github.com/swoole/swoole-src/commit/7d4eaed41ae94237ed9e4ae72ac166b6e7617047.patch
-Patch2: https://github.com/swoole/swoole-src/commit/0a1ab3d5b1cfde8b905192bec0535bc61b92871a.patch
-Patch3: https://patch-diff.githubusercontent.com/raw/swoole/swoole-src/pull/3686.patch
-Patch4: https://patch-diff.githubusercontent.com/raw/swoole/swoole-src/pull/3713.patch
-
%if 0%{?rhel} == 6
BuildRequires: devtoolset-6-toolchain
%else
@@ -169,12 +163,6 @@ sed \
cd NTS
-%patch0 -p1 -b .up0
-%patch1 -p1 -b .up1
-%patch2 -p1 -b .up2
-%patch3 -p1 -b .pr3686
-%patch4 -p1 -b .pr3713
-
# Sanity check, really often broken
extver=$(sed -n '/#define SWOOLE_VERSION /{s/.* "//;s/".*$//;p}' include/swoole_version.h)
if test "x${extver}" != "x%{upstream_version}%{?upstream_prever}"; then
@@ -343,6 +331,10 @@ cd ../ZTS
%changelog
+* Thu Oct 15 2020 Remi Collet <remi@remirepo.net> - 4.5.5-1
+- update to 4.5.5
+- drop patches merged upstream
+
* Wed Sep 30 2020 Remi Collet <remi@remirepo.net> - 4.5.4-3
- rebuild for PHP 8.0.0RC1
- add patch from https://github.com/swoole/swoole-src/pull/3713