summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2020-11-09 14:57:20 +0100
committerRemi Collet <remi@remirepo.net>2020-11-09 14:57:20 +0100
commit317e716d133b75f410b6fdf8058d02f4239b11b8 (patch)
tree674b166672b0c712ed0a3ce1945c969f38078d40
parentcef0086f49f65fba7dfafb12239301103c81fb0a (diff)
update to 4.5.7
-rw-r--r--PHPINFO5
-rw-r--r--REFLECTION63
-rw-r--r--php-pecl-swoole4.spec5
3 files changed, 62 insertions, 11 deletions
diff --git a/PHPINFO b/PHPINFO
index 1e71816..0bdcba7 100644
--- a/PHPINFO
+++ b/PHPINFO
@@ -3,8 +3,8 @@ swoole
Swoole => enabled
Author => Swoole Team <team@swoole.com>
-Version => 4.5.6
-Built => Oct 30 2020 00:00:00
+Version => 4.5.7
+Built => Nov 9 2020 00:00:00
coroutine => enabled
trace_log => enabled
epoll => enabled
@@ -16,6 +16,7 @@ rwlock => enabled
sockets => enabled
openssl => OpenSSL 1.1.1g FIPS 21 Apr 2020
http2 => enabled
+json => enabled
pcre => enabled
zlib => 1.2.11
brotli => E16777225/D16777225
diff --git a/REFLECTION b/REFLECTION
index ab153b3..05107b5 100644
--- a/REFLECTION
+++ b/REFLECTION
@@ -1,4 +1,10 @@
-Extension [ <persistent> extension #117 swoole version 4.5.6 ] {
+Extension [ <persistent> extension #117 swoole version 4.5.7 ] {
+
+ - Dependencies {
+ Dependency [ json (Required) ]
+ Dependency [ mysqlnd (Required) ]
+ Dependency [ sockets (Required) ]
+ }
- INI {
Entry [ swoole.enable_coroutine <ALL> ]
@@ -21,12 +27,12 @@ Extension [ <persistent> extension #117 swoole version 4.5.6 ] {
}
}
- - Constants [354] {
- Constant [ string SWOOLE_VERSION ] { 4.5.6 }
- Constant [ int SWOOLE_VERSION_ID ] { 40506 }
+ - Constants [355] {
+ Constant [ string SWOOLE_VERSION ] { 4.5.7 }
+ Constant [ int SWOOLE_VERSION_ID ] { 40507 }
Constant [ int SWOOLE_MAJOR_VERSION ] { 4 }
Constant [ int SWOOLE_MINOR_VERSION ] { 5 }
- Constant [ int SWOOLE_RELEASE_VERSION ] { 6 }
+ Constant [ int SWOOLE_RELEASE_VERSION ] { 7 }
Constant [ string SWOOLE_EXTRA_VERSION ] { }
Constant [ bool SWOOLE_DEBUG ] { }
Constant [ bool SWOOLE_HAVE_COMPRESSION ] { 1 }
@@ -221,6 +227,7 @@ Extension [ <persistent> extension #117 swoole version 4.5.6 ] {
Constant [ int SWOOLE_IPC_NONE ] { 0 }
Constant [ int SWOOLE_IPC_UNIXSOCK ] { 1 }
Constant [ int SWOOLE_IPC_SOCKET ] { 3 }
+ Constant [ int SWOOLE_IOV_MAX ] { 1024 }
Constant [ int SWOOLE_FILELOCK ] { 2 }
Constant [ int SWOOLE_MUTEX ] { 3 }
Constant [ int SWOOLE_SEM ] { 4 }
@@ -1404,10 +1411,12 @@ Extension [ <persistent> extension #117 swoole version 4.5.6 ] {
- Static methods [0] {
}
- - Properties [0] {
+ - Properties [2] {
+ Property [ <default> public $size ]
+ Property [ <default> public $memorySize ]
}
- - Methods [23] {
+ - Methods [24] {
Method [ <internal:swoole, ctor> public method __construct ] {
- Parameters [2] {
@@ -1505,6 +1514,12 @@ Extension [ <persistent> extension #117 swoole version 4.5.6 ] {
}
}
+ Method [ <internal:swoole> public method getSize ] {
+
+ - Parameters [0] {
+ }
+ }
+
Method [ <internal:swoole> public method getMemorySize ] {
- Parameters [0] {
@@ -2869,7 +2884,7 @@ Extension [ <persistent> extension #117 swoole version 4.5.6 ] {
Property [ <default> public $errMsg ]
}
- - Methods [24] {
+ - Methods [28] {
Method [ <internal:swoole, ctor> public method __construct ] {
- Parameters [3] {
@@ -2946,6 +2961,38 @@ Extension [ <persistent> extension #117 swoole version 4.5.6 ] {
}
}
+ Method [ <internal:swoole> public method readVector ] {
+
+ - Parameters [2] {
+ Parameter #0 [ <required> $io_vector ]
+ Parameter #1 [ <optional> $timeout ]
+ }
+ }
+
+ Method [ <internal:swoole> public method readVectorAll ] {
+
+ - Parameters [2] {
+ Parameter #0 [ <required> $io_vector ]
+ Parameter #1 [ <optional> $timeout ]
+ }
+ }
+
+ Method [ <internal:swoole> public method writeVector ] {
+
+ - Parameters [2] {
+ Parameter #0 [ <required> $io_vector ]
+ Parameter #1 [ <optional> $timeout ]
+ }
+ }
+
+ Method [ <internal:swoole> public method writeVectorAll ] {
+
+ - Parameters [2] {
+ Parameter #0 [ <required> $io_vector ]
+ Parameter #1 [ <optional> $timeout ]
+ }
+ }
+
Method [ <internal:swoole> public method sendFile ] {
- Parameters [3] {
diff --git a/php-pecl-swoole4.spec b/php-pecl-swoole4.spec
index 921ff08..c251806 100644
--- a/php-pecl-swoole4.spec
+++ b/php-pecl-swoole4.spec
@@ -27,7 +27,7 @@
%global with_brotli 0
%endif
-%global upstream_version 4.5.6
+%global upstream_version 4.5.7
#global upstream_prever RC2
@@ -335,6 +335,9 @@ cd ../ZTS
%changelog
+* Mon Nov 9 2020 Remi Collet <remi@remirepo.net> - 4.5.7-1
+- update to 4.5.7
+
* Fri Oct 30 2020 Remi Collet <remi@remirepo.net> - 4.5.6-1
- update to 4.5.6
- raise dependency on openssl 1.0.2 (drop EL-6 support)