summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2018-09-19 07:48:27 +0200
committerRemi Collet <remi@remirepo.net>2018-09-19 07:48:27 +0200
commit337485d217e91ce42ac9a5b5ea67621f2d697aca (patch)
treeb30012d38a6545c057439ee1b9c96d485b28e4cf
parent383c1784b9685ff7a0a7f6cc53e62fae564e2fd8 (diff)
v4.2.1
-rw-r--r--PHPINFO2
-rw-r--r--REFLECTION311
-rw-r--r--php-pecl-swoole4.spec6
3 files changed, 84 insertions, 235 deletions
diff --git a/PHPINFO b/PHPINFO
index 056c5f4..e31d42e 100644
--- a/PHPINFO
+++ b/PHPINFO
@@ -2,7 +2,7 @@
swoole
swoole support => enabled
-Version => 4.1.2
+Version => 4.2.1
Author => Swoole Group[email: team@swoole.com]
coroutine => enabled
trace-log => enabled
diff --git a/REFLECTION b/REFLECTION
index cc45892..4abb5d0 100644
--- a/REFLECTION
+++ b/REFLECTION
@@ -1,4 +1,4 @@
-Extension [ <persistent> extension #148 swoole version 4.1.2 ] {
+Extension [ <persistent> extension #148 swoole version 4.2.1 ] {
- INI {
Entry [ swoole.enable_coroutine <ALL> ]
@@ -69,7 +69,7 @@ Extension [ <persistent> extension #148 swoole version 4.1.2 ] {
Constant [ integer SWOOLE_DTLSv1_CLIENT_METHOD ] { 17 }
Constant [ integer SWOOLE_EVENT_READ ] { 512 }
Constant [ integer SWOOLE_EVENT_WRITE ] { 1024 }
- Constant [ string SWOOLE_VERSION ] { 4.1.2 }
+ Constant [ string SWOOLE_VERSION ] { 4.2.1 }
Constant [ integer SWOOLE_ERROR_MALLOC_FAIL ] { 501 }
Constant [ integer SWOOLE_ERROR_SYSTEM_CALL_FAIL ] { 502 }
Constant [ integer SWOOLE_ERROR_PHP_FATAL_ERROR ] { 503 }
@@ -3641,7 +3641,7 @@ Extension [ <persistent> extension #148 swoole version 4.1.2 ] {
- Properties [0] {
}
- - Methods [6] {
+ - Methods [7] {
Method [ <internal:swoole, ctor> public method __construct ] {
- Parameters [3] {
@@ -3665,6 +3665,12 @@ Extension [ <persistent> extension #148 swoole version 4.1.2 ] {
}
}
+ Method [ <internal:swoole> public method getProcess ] {
+
+ - Parameters [0] {
+ }
+ }
+
Method [ <internal:swoole> public method listen ] {
- Parameters [3] {
@@ -3928,8 +3934,9 @@ Extension [ <persistent> extension #148 swoole version 4.1.2 ] {
Method [ <internal:swoole> static public method enableCoroutine ] {
- - Parameters [1] {
+ - Parameters [2] {
Parameter #0 [ <optional> $enable ]
+ Parameter #1 [ <optional> $flags ]
}
}
}
@@ -5182,7 +5189,23 @@ Extension [ <persistent> extension #148 swoole version 4.1.2 ] {
- Static properties [0] {
}
- - Static methods [0] {
+ - Static methods [2] {
+ Method [ <internal:swoole> static public method pack ] {
+
+ - Parameters [4] {
+ Parameter #0 [ <required> $data ]
+ Parameter #1 [ <optional> $opcode ]
+ Parameter #2 [ <optional> $finish ]
+ Parameter #3 [ <optional> $mask ]
+ }
+ }
+
+ Method [ <internal:swoole> static public method unpack ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $data ]
+ }
+ }
}
- Properties [4] {
@@ -5192,7 +5215,57 @@ Extension [ <persistent> extension #148 swoole version 4.1.2 ] {
Property [ <default> public $finish ]
}
- - Methods [0] {
+ - Methods [1] {
+ Method [ <internal:swoole> public method __toString ] {
+
+ - Parameters [0] {
+ }
+ }
+ }
+ }
+
+ Class [ <internal:swoole> class Swoole\WebSocket\CloseFrame extends Swoole\WebSocket\Frame ] {
+
+ - Constants [0] {
+ }
+
+ - Static properties [0] {
+ }
+
+ - Static methods [2] {
+ Method [ <internal:swoole, inherits Swoole\WebSocket\Frame> static public method pack ] {
+
+ - Parameters [4] {
+ Parameter #0 [ <required> $data ]
+ Parameter #1 [ <optional> $opcode ]
+ Parameter #2 [ <optional> $finish ]
+ Parameter #3 [ <optional> $mask ]
+ }
+ }
+
+ Method [ <internal:swoole, inherits Swoole\WebSocket\Frame> static public method unpack ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $data ]
+ }
+ }
+ }
+
+ - Properties [6] {
+ Property [ <default> public $fd ]
+ Property [ <default> public $data ]
+ Property [ <default> public $finish ]
+ Property [ <default> public $opcode ]
+ Property [ <default> public $code ]
+ Property [ <default> public $reason ]
+ }
+
+ - Methods [1] {
+ Method [ <internal:swoole, inherits Swoole\WebSocket\Frame> public method __toString ] {
+
+ - Parameters [0] {
+ }
+ }
}
}
@@ -5646,232 +5719,6 @@ Extension [ <persistent> extension #148 swoole version 4.1.2 ] {
}
}
- Class [ <internal:swoole> class Swoole\Http2\Client extends Swoole\Client ] {
-
- - Constants [7] {
- Constant [ public integer MSG_OOB ] { 1 }
- Constant [ public integer MSG_PEEK ] { 2 }
- Constant [ public integer MSG_DONTWAIT ] { 64 }
- Constant [ public integer MSG_WAITALL ] { 256 }
- Constant [ public integer SHUT_RDWR ] { 2 }
- Constant [ public integer SHUT_RD ] { 0 }
- Constant [ public integer SHUT_WR ] { 1 }
- }
-
- - Static properties [0] {
- }
-
- - Static methods [0] {
- }
-
- - Properties [16] {
- Property [ <default> public $errCode ]
- Property [ <default> public $sock ]
- Property [ <default> public $reuse ]
- Property [ <default> public $reuseCount ]
- Property [ <default> public $type ]
- Property [ <default> public $id ]
- Property [ <default> public $setting ]
- Property [ <default> public $onConnect ]
- Property [ <default> public $onError ]
- Property [ <default> public $onReceive ]
- Property [ <default> public $onClose ]
- Property [ <default> public $onBufferFull ]
- Property [ <default> public $onBufferEmpty ]
- Property [ <default> public $onSSLReady ]
- Property [ <default> public $requestHeaders ]
- Property [ <default> public $cookies ]
- }
-
- - Methods [34] {
- Method [ <internal:swoole, overwrites Swoole\Client, ctor> public method __construct ] {
- }
-
- Method [ <internal:swoole, overwrites Swoole\Client, prototype Swoole\Client, dtor> public method __destruct ] {
- }
-
- Method [ <internal:swoole> public method setHeaders ] {
- }
-
- Method [ <internal:swoole> public method setCookies ] {
- }
-
- Method [ <internal:swoole> public method get ] {
- }
-
- Method [ <internal:swoole> public method post ] {
- }
-
- Method [ <internal:swoole> public method onConnect ] {
- }
-
- Method [ <internal:swoole> public method onError ] {
- }
-
- Method [ <internal:swoole> public method onReceive ] {
- }
-
- Method [ <internal:swoole> public method onClose ] {
- }
-
- Method [ <internal:swoole> public method openStream ] {
- }
-
- Method [ <internal:swoole> public method push ] {
- }
-
- Method [ <internal:swoole> public method closeStream ] {
- }
-
- Method [ <internal:swoole, inherits Swoole\Client> public method set ] {
-
- - Parameters [1] {
- Parameter #0 [ <required> array $settings ]
- }
- }
-
- Method [ <internal:swoole, inherits Swoole\Client> public method connect ] {
-
- - Parameters [4] {
- Parameter #0 [ <required> $host ]
- Parameter #1 [ <optional> $port ]
- Parameter #2 [ <optional> $timeout ]
- Parameter #3 [ <optional> $sock_flag ]
- }
- }
-
- Method [ <internal:swoole, inherits Swoole\Client> public method recv ] {
-
- - Parameters [2] {
- Parameter #0 [ <optional> $size ]
- Parameter #1 [ <optional> $flag ]
- }
- }
-
- Method [ <internal:swoole, inherits Swoole\Client> public method send ] {
-
- - Parameters [2] {
- Parameter #0 [ <required> $data ]
- Parameter #1 [ <optional> $flag ]
- }
- }
-
- Method [ <internal:swoole, inherits Swoole\Client> public method pipe ] {
-
- - Parameters [1] {
- Parameter #0 [ <required> $dst_socket ]
- }
- }
-
- Method [ <internal:swoole, inherits Swoole\Client> public method sendfile ] {
-
- - Parameters [3] {
- Parameter #0 [ <required> $filename ]
- Parameter #1 [ <optional> $offset ]
- Parameter #2 [ <optional> $length ]
- }
- }
-
- Method [ <internal:swoole, inherits Swoole\Client> public method sendto ] {
-
- - Parameters [3] {
- Parameter #0 [ <required> $ip ]
- Parameter #1 [ <required> $port ]
- Parameter #2 [ <required> $data ]
- }
- }
-
- Method [ <internal:swoole, inherits Swoole\Client> public method sleep ] {
-
- - Parameters [0] {
- }
- }
-
- Method [ <internal:swoole, inherits Swoole\Client> public method wakeup ] {
-
- - Parameters [0] {
- }
- }
-
- Method [ <internal:swoole, inherits Swoole\Client> public method pause ] {
-
- - Parameters [0] {
- }
- }
-
- Method [ <internal:swoole, inherits Swoole\Client> public method resume ] {
-
- - Parameters [0] {
- }
- }
-
- Method [ <internal:swoole, inherits Swoole\Client> public method shutdown ] {
-
- - Parameters [1] {
- Parameter #0 [ <required> $how ]
- }
- }
-
- Method [ <internal:swoole, inherits Swoole\Client> public method enableSSL ] {
-
- - Parameters [1] {
- Parameter #0 [ <optional> $callback ]
- }
- }
-
- Method [ <internal:swoole, inherits Swoole\Client> public method getPeerCert ] {
-
- - Parameters [0] {
- }
- }
-
- Method [ <internal:swoole, inherits Swoole\Client> public method verifyPeerCert ] {
-
- - Parameters [0] {
- }
- }
-
- Method [ <internal:swoole, inherits Swoole\Client> public method isConnected ] {
-
- - Parameters [0] {
- }
- }
-
- Method [ <internal:swoole, inherits Swoole\Client> public method getsockname ] {
-
- - Parameters [0] {
- }
- }
-
- Method [ <internal:swoole, inherits Swoole\Client> public method getpeername ] {
-
- - Parameters [0] {
- }
- }
-
- Method [ <internal:swoole, inherits Swoole\Client> public method close ] {
-
- - Parameters [1] {
- Parameter #0 [ <optional> $force ]
- }
- }
-
- Method [ <internal:swoole, inherits Swoole\Client> public method on ] {
-
- - Parameters [2] {
- Parameter #0 [ <required> $event_name ]
- Parameter #1 [ <required> $callback ]
- }
- }
-
- Method [ <internal:swoole, inherits Swoole\Client> public method getSocket ] {
-
- - Parameters [0] {
- }
- }
- }
- }
-
Class [ <internal:swoole> class Swoole\Coroutine\Http2\Client ] {
- Constants [0] {
diff --git a/php-pecl-swoole4.spec b/php-pecl-swoole4.spec
index 012e9c3..ecf0375 100644
--- a/php-pecl-swoole4.spec
+++ b/php-pecl-swoole4.spec
@@ -36,7 +36,7 @@
Summary: PHP's asynchronous concurrent distributed networking framework
Name: %{?sub_prefix}php-pecl-%{pecl_name}4
-Version: 4.2.0
+Version: 4.2.1
Release: 1%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
License: BSD
URL: http://pecl.php.net/package/%{pecl_name}
@@ -331,7 +331,6 @@ cd ../ZTS
%files devel
%doc %{pecl_testdir}/%{pecl_name}
%doc %{pecl_docdir}/%{pecl_name}/examples
-%doc %{pecl_docdir}/%{pecl_name}/.github/ISSUE_TEMPLATE
%doc %{pecl_docdir}/%{pecl_name}/include/readme
%{php_incldir}/ext/%{pecl_name}
@@ -341,6 +340,9 @@ cd ../ZTS
%changelog
+* Wed Sep 19 2018 Remi Collet <remi@remirepo.net> - 4.2.1-1
+- update to 4.2.1
+
* Tue Sep 18 2018 Remi Collet <remi@remirepo.net> - 4.2.0-1
- update to 4.2.0
- open https://github.com/swoole/swoole-src/issues/1982