summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--REFLECTION18
-rw-r--r--php-pecl-swoole2.spec6
2 files changed, 17 insertions, 7 deletions
diff --git a/REFLECTION b/REFLECTION
index 2a8ef5b..aa35948 100644
--- a/REFLECTION
+++ b/REFLECTION
@@ -1,4 +1,4 @@
-Extension [ <persistent> extension #147 swoole version 2.1.2 ] {
+Extension [ <persistent> extension #147 swoole version 2.1.3 ] {
- INI {
Entry [ swoole.aio_thread_num <ALL> ]
@@ -66,7 +66,7 @@ Extension [ <persistent> extension #147 swoole version 2.1.2 ] {
Constant [ integer SWOOLE_DTLSv1_CLIENT_METHOD ] { 17 }
Constant [ integer SWOOLE_EVENT_READ ] { 512 }
Constant [ integer SWOOLE_EVENT_WRITE ] { 1024 }
- Constant [ string SWOOLE_VERSION ] { 2.1.2 }
+ Constant [ string SWOOLE_VERSION ] { 2.1.3 }
Constant [ integer SWOOLE_ERROR_MALLOC_FAIL ] { 501 }
Constant [ integer SWOOLE_ERROR_SYSTEM_CALL_FAIL ] { 502 }
Constant [ integer SWOOLE_ERROR_PHP_FATAL_ERROR ] { 503 }
@@ -3284,7 +3284,7 @@ Extension [ <persistent> extension #147 swoole version 2.1.2 ] {
- Properties [0] {
}
- - Methods [5] {
+ - Methods [6] {
Method [ <internal:swoole, ctor> public method __construct ] {
- Parameters [3] {
@@ -3310,9 +3310,17 @@ Extension [ <persistent> extension #147 swoole version 2.1.2 ] {
Method [ <internal:swoole> public method listen ] {
- - Parameters [2] {
+ - Parameters [3] {
Parameter #0 [ <required> $host ]
- Parameter #1 [ <required> $port ]
+ Parameter #1 [ <optional> $port ]
+ Parameter #2 [ <optional> $backlog ]
+ }
+ }
+
+ Method [ <internal:swoole> public method write ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $data ]
}
}
diff --git a/php-pecl-swoole2.spec b/php-pecl-swoole2.spec
index 6870538..6d3c802 100644
--- a/php-pecl-swoole2.spec
+++ b/php-pecl-swoole2.spec
@@ -25,7 +25,6 @@
%global ini_name 40-%{pecl_name}.ini
%endif
-# BUT see https://github.com/swoole/swoole-src/issues/1558
%if 0%{?fedora} >= 24 || 0%{?rhel} >= 8
%global with_pgsql 1
%else
@@ -42,7 +41,7 @@
Summary: PHP's asynchronous concurrent distributed networking framework
Name: %{?sub_prefix}php-pecl-%{pecl_name}2
-Version: 2.1.2
+Version: 2.1.3
Release: 1%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
License: BSD
URL: http://pecl.php.net/package/%{pecl_name}
@@ -316,6 +315,9 @@ cd ../ZTS
%changelog
+* Mon Apr 16 2018 Remi Collet <remi@remirepo.net> - 2.1.3-1
+- update to 2.1.3
+
* Tue Apr 10 2018 Remi Collet <remi@remirepo.net> - 2.1.2-1
- update to 2.1.2
- add PostgreSQL coroutine client on Fedora 24+