summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--REFLECTION446
-rw-r--r--php-pecl-swoole2.spec5
2 files changed, 417 insertions, 34 deletions
diff --git a/REFLECTION b/REFLECTION
index 18b2cf6..596f9b9 100644
--- a/REFLECTION
+++ b/REFLECTION
@@ -1,4 +1,4 @@
-Extension [ <persistent> extension #137 swoole version 2.0.8 ] {
+Extension [ <persistent> extension #138 swoole version 2.0.9 ] {
- INI {
Entry [ swoole.aio_thread_num <ALL> ]
@@ -63,7 +63,7 @@ Extension [ <persistent> extension #137 swoole version 2.0.8 ] {
Constant [ integer SWOOLE_DTLSv1_CLIENT_METHOD ] { 17 }
Constant [ integer SWOOLE_EVENT_READ ] { 512 }
Constant [ integer SWOOLE_EVENT_WRITE ] { 1024 }
- Constant [ string SWOOLE_VERSION ] { 2.0.8 }
+ Constant [ string SWOOLE_VERSION ] { 2.0.9 }
Constant [ integer SWOOLE_REDIS_MODE_MULTI ] { 0 }
Constant [ integer SWOOLE_REDIS_MODE_PIPELINE ] { 1 }
Constant [ integer SWOOLE_REDIS_TYPE_NOT_FOUND ] { 0 }
@@ -261,6 +261,11 @@ Extension [ <persistent> extension #137 swoole version 2.0.8 ] {
- Parameters [0] {
}
}
+ Function [ <internal:swoole> function swoole_get_local_mac ] {
+
+ - Parameters [0] {
+ }
+ }
Function [ <internal:swoole> function swoole_strerror ] {
- Parameters [1] {
@@ -274,7 +279,7 @@ Extension [ <persistent> extension #137 swoole version 2.0.8 ] {
}
}
- - Classes [34] {
+ - Classes [35] {
Class [ <internal:swoole> class Swoole\Server ] {
- Constants [0] {
@@ -286,10 +291,39 @@ Extension [ <persistent> extension #137 swoole version 2.0.8 ] {
- Static methods [0] {
}
- - Properties [0] {
+ - Properties [29] {
+ Property [ <default> public $onConnect ]
+ Property [ <default> public $onReceive ]
+ Property [ <default> public $onClose ]
+ Property [ <default> public $onPacket ]
+ Property [ <default> public $onBufferFull ]
+ Property [ <default> public $onBufferEmpty ]
+ Property [ <default> public $onStart ]
+ Property [ <default> public $onShutdown ]
+ Property [ <default> public $onWorkerStart ]
+ Property [ <default> public $onWorkerStop ]
+ Property [ <default> public $onWorkerExit ]
+ Property [ <default> public $onWorkerError ]
+ Property [ <default> public $onTask ]
+ Property [ <default> public $onFinish ]
+ Property [ <default> public $onManagerStart ]
+ Property [ <default> public $onManagerStop ]
+ Property [ <default> public $onPipeMessage ]
+ Property [ <default> public $setting ]
+ Property [ <default> public $connections ]
+ Property [ <default> public $host ]
+ Property [ <default> public $port ]
+ Property [ <default> public $type ]
+ Property [ <default> public $mode ]
+ Property [ <default> public $ports ]
+ Property [ <default> public $master_pid ]
+ Property [ <default> public $manager_pid ]
+ Property [ <default> public $worker_id ]
+ Property [ <default> public $taskworker ]
+ Property [ <default> public $worker_pid ]
}
- - Methods [39] {
+ - Methods [40] {
Method [ <internal:swoole, ctor> public method __construct ] {
- Parameters [4] {
@@ -452,6 +486,14 @@ Extension [ <persistent> extension #137 swoole version 2.0.8 ] {
}
}
+ Method [ <internal:swoole> public method taskCo ] {
+
+ - Parameters [2] {
+ Parameter #0 [ <required> array $tasks ]
+ Parameter #1 [ <optional> $timeout ]
+ }
+ }
+
Method [ <internal:swoole> public method finish ] {
- Parameters [1] {
@@ -938,7 +980,22 @@ Extension [ <persistent> extension #137 swoole version 2.0.8 ] {
- Static methods [0] {
}
- - Properties [0] {
+ - Properties [15] {
+ Property [ <default> public $onConnect ]
+ Property [ <default> public $onReceive ]
+ Property [ <default> public $onClose ]
+ Property [ <default> public $onPacket ]
+ Property [ <default> public $onBufferFull ]
+ Property [ <default> public $onBufferEmpty ]
+ Property [ <default> public $onRequest ]
+ Property [ <default> public $onHandShake ]
+ Property [ <default> public $onMessage ]
+ Property [ <default> public $onOpen ]
+ Property [ <default> public $host ]
+ Property [ <default> public $port ]
+ Property [ <default> public $type ]
+ Property [ <default> public $sock ]
+ Property [ <default> public $setting ]
}
- Methods [5] {
@@ -992,11 +1049,21 @@ Extension [ <persistent> extension #137 swoole version 2.0.8 ] {
- Static methods [0] {
}
- - Properties [4] {
+ - Properties [14] {
Property [ <default> public $errCode ]
Property [ <default> public $sock ]
Property [ <default> public $reuse ]
Property [ <default> public $reuseCount ]
+ Property [ <default> public $type ]
+ Property [ <default> public $id ]
+ Property [ <default> public $setting ]
+ Property [ <default> public $onConnect ]
+ Property [ <default> public $onError ]
+ Property [ <default> public $onReceive ]
+ Property [ <default> public $onClose ]
+ Property [ <default> public $onBufferFull ]
+ Property [ <default> public $onBufferEmpty ]
+ Property [ <default> public $onSSLReady ]
}
- Methods [22] {
@@ -1783,29 +1850,65 @@ Extension [ <persistent> extension #137 swoole version 2.0.8 ] {
Property [ <default> public $errno ]
}
- - Methods [8] {
+ - Methods [9] {
Method [ <internal:swoole, ctor> public method __construct ] {
+
+ - Parameters [0] {
+ }
}
Method [ <internal:swoole, dtor> public method __destruct ] {
+
+ - Parameters [0] {
+ }
}
Method [ <internal:swoole> public method connect ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> array $server_config ]
+ }
}
Method [ <internal:swoole> public method query ] {
+
+ - Parameters [2] {
+ Parameter #0 [ <required> $sql ]
+ Parameter #1 [ <optional> $timeout ]
+ }
}
Method [ <internal:swoole> public method recv ] {
+
+ - Parameters [0] {
+ }
+ }
+
+ Method [ <internal:swoole> public method escape ] {
+
+ - Parameters [2] {
+ Parameter #0 [ <required> $string ]
+ Parameter #1 [ <optional> $flags ]
+ }
}
Method [ <internal:swoole> public method setDefer ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <optional> $defer ]
+ }
}
Method [ <internal:swoole> public method getDefer ] {
+
+ - Parameters [0] {
+ }
}
Method [ <internal:swoole> public method close ] {
+
+ - Parameters [0] {
+ }
}
}
}
@@ -1942,7 +2045,7 @@ Extension [ <persistent> extension #137 swoole version 2.0.8 ] {
- Static properties [0] {
}
- - Static methods [7] {
+ - Static methods [8] {
Method [ <internal:swoole> static public method create ] {
}
@@ -1958,6 +2061,13 @@ Extension [ <persistent> extension #137 swoole version 2.0.8 ] {
Method [ <internal:swoole> static public method getuid ] {
}
+ Method [ <internal:swoole> static public method sleep ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $seconds ]
+ }
+ }
+
Method [ <internal:swoole> static public method call_user_func ] {
}
@@ -1983,9 +2093,26 @@ Extension [ <persistent> extension #137 swoole version 2.0.8 ] {
- Static methods [0] {
}
- - Properties [2] {
+ - Properties [19] {
+ Property [ <default> public $type ]
Property [ <default> public $errCode ]
Property [ <default> public $sock ]
+ Property [ <default> public $statusCode ]
+ Property [ <default> public $host ]
+ Property [ <default> public $port ]
+ Property [ <default> public $requestMethod ]
+ Property [ <default> public $requestHeaders ]
+ Property [ <default> public $requestBody ]
+ Property [ <default> public $uploadFiles ]
+ Property [ <default> public $set_cookie_headers ]
+ Property [ <default> public $downloadFile ]
+ Property [ <default> public $headers ]
+ Property [ <default> public $cookies ]
+ Property [ <default> public $body ]
+ Property [ <default> public $onConnect ]
+ Property [ <default> public $onError ]
+ Property [ <default> public $onMessage ]
+ Property [ <default> public $onClose ]
}
- Methods [17] {
@@ -2181,7 +2308,13 @@ Extension [ <persistent> extension #137 swoole version 2.0.8 ] {
}
}
- - Properties [0] {
+ - Properties [6] {
+ Property [ <default> public $pipe ]
+ Property [ <default> public $callback ]
+ Property [ <default> public $msgQueueId ]
+ Property [ <default> public $msgQueueKey ]
+ Property [ <default> public $pid ]
+ Property [ <default> public $id ]
}
- Methods [14] {
@@ -2284,7 +2417,7 @@ Extension [ <persistent> extension #137 swoole version 2.0.8 ] {
}
}
- Class [ <internal:swoole> <iterateable> class Swoole\Table implements Iterator, Traversable, Countable ] {
+ Class [ <internal:swoole> <iterateable> class Swoole\Table implements ArrayAccess, Iterator, Traversable, Countable ] {
- Constants [3] {
Constant [ integer TYPE_INT ] { 1 }
@@ -2301,11 +2434,12 @@ Extension [ <persistent> extension #137 swoole version 2.0.8 ] {
- Properties [0] {
}
- - Methods [16] {
+ - Methods [21] {
Method [ <internal:swoole, ctor> public method __construct ] {
- - Parameters [1] {
+ - Parameters [2] {
Parameter #0 [ <required> $table_size ]
+ Parameter #1 [ <optional> $conflict_proportion ]
}
}
@@ -2361,9 +2495,8 @@ Extension [ <persistent> extension #137 swoole version 2.0.8 ] {
Method [ <internal:swoole> public method exist ] {
- - Parameters [2] {
+ - Parameters [1] {
Parameter #0 [ <required> $key ]
- Parameter #1 [ <optional> $field ]
}
}
@@ -2385,6 +2518,41 @@ Extension [ <persistent> extension #137 swoole version 2.0.8 ] {
}
}
+ Method [ <internal:swoole> public method getMemorySize ] {
+
+ - Parameters [0] {
+ }
+ }
+
+ Method [ <internal:swoole, prototype ArrayAccess> public method offsetExists ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $offset ]
+ }
+ }
+
+ Method [ <internal:swoole, prototype ArrayAccess> public method offsetGet ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $offset ]
+ }
+ }
+
+ Method [ <internal:swoole, prototype ArrayAccess> public method offsetSet ] {
+
+ - Parameters [2] {
+ Parameter #0 [ <required> $offset ]
+ Parameter #1 [ <required> $value ]
+ }
+ }
+
+ Method [ <internal:swoole, prototype ArrayAccess> public method offsetUnset ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $offset ]
+ }
+ }
+
Method [ <internal:swoole, prototype Iterator> public method rewind ] {
- Parameters [0] {
@@ -2417,6 +2585,60 @@ Extension [ <persistent> extension #137 swoole version 2.0.8 ] {
}
}
+ Class [ <internal:swoole> class Swoole\Table\Row implements ArrayAccess ] {
+
+ - Constants [0] {
+ }
+
+ - Static properties [0] {
+ }
+
+ - Static methods [0] {
+ }
+
+ - Properties [2] {
+ Property [ <default> public $key ]
+ Property [ <default> public $value ]
+ }
+
+ - Methods [5] {
+ Method [ <internal:swoole, prototype ArrayAccess> public method offsetExists ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $offset ]
+ }
+ }
+
+ Method [ <internal:swoole, prototype ArrayAccess> public method offsetGet ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $offset ]
+ }
+ }
+
+ Method [ <internal:swoole, prototype ArrayAccess> public method offsetSet ] {
+
+ - Parameters [2] {
+ Parameter #0 [ <required> $offset ]
+ Parameter #1 [ <required> $value ]
+ }
+ }
+
+ Method [ <internal:swoole, prototype ArrayAccess> public method offsetUnset ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $offset ]
+ }
+ }
+
+ Method [ <internal:swoole, dtor> public method __destruct ] {
+
+ - Parameters [0] {
+ }
+ }
+ }
+ }
+
Class [ <internal:swoole> class Swoole\Lock ] {
- Constants [5] {
@@ -2574,11 +2796,41 @@ Extension [ <persistent> extension #137 swoole version 2.0.8 ] {
- Static methods [0] {
}
- - Properties [1] {
- Property [ <default> private $global ]
+ - Properties [31] {
+ Property [ <default> public $onConnect ]
+ Property [ <default> public $onReceive ]
+ Property [ <default> public $onClose ]
+ Property [ <default> public $onPacket ]
+ Property [ <default> public $onBufferFull ]
+ Property [ <default> public $onBufferEmpty ]
+ Property [ <default> public $onStart ]
+ Property [ <default> public $onShutdown ]
+ Property [ <default> public $onWorkerStart ]
+ Property [ <default> public $onWorkerStop ]
+ Property [ <default> public $onWorkerExit ]
+ Property [ <default> public $onWorkerError ]
+ Property [ <default> public $onTask ]
+ Property [ <default> public $onFinish ]
+ Property [ <default> public $onManagerStart ]
+ Property [ <default> public $onManagerStop ]
+ Property [ <default> public $onPipeMessage ]
+ Property [ <default> public $connections ]
+ Property [ <default> public $host ]
+ Property [ <default> public $port ]
+ Property [ <default> public $type ]
+ Property [ <default> public $mode ]
+ Property [ <default> public $ports ]
+ Property [ <default> public $master_pid ]
+ Property [ <default> public $manager_pid ]
+ Property [ <default> public $worker_id ]
+ Property [ <default> public $taskworker ]
+ Property [ <default> public $worker_pid ]
+ Property [ <default> public $onRequest ]
+ Property [ <default> public $onHandshake ]
+ Property [ <default> public $setting ]
}
- - Methods [39] {
+ - Methods [40] {
Method [ <internal:swoole, overwrites Swoole\Server, prototype Swoole\Server> public method on ] {
- Parameters [2] {
@@ -2741,6 +2993,14 @@ Extension [ <persistent> extension #137 swoole version 2.0.8 ] {
}
}
+ Method [ <internal:swoole, inherits Swoole\Server> public method taskCo ] {
+
+ - Parameters [2] {
+ Parameter #0 [ <required> array $tasks ]
+ Parameter #1 [ <optional> $timeout ]
+ }
+ }
+
Method [ <internal:swoole, inherits Swoole\Server> public method finish ] {
- Parameters [1] {
@@ -2892,7 +3152,11 @@ Extension [ <persistent> extension #137 swoole version 2.0.8 ] {
- Static methods [0] {
}
- - Properties [0] {
+ - Properties [4] {
+ Property [ <default> public $fd ]
+ Property [ <default> public $header ]
+ Property [ <default> public $cookie ]
+ Property [ <default> public $trailer ]
}
- Methods [11] {
@@ -3002,7 +3266,16 @@ Extension [ <persistent> extension #137 swoole version 2.0.8 ] {
- Static methods [0] {
}
- - Properties [0] {
+ - Properties [9] {
+ Property [ <default> public $fd ]
+ Property [ <default> public $header ]
+ Property [ <default> public $server ]
+ Property [ <default> public $request ]
+ Property [ <default> public $cookie ]
+ Property [ <default> public $get ]
+ Property [ <default> public $files ]
+ Property [ <default> public $post ]
+ Property [ <default> public $tmpfiles ]
}
- Methods [2] {
@@ -3134,10 +3407,41 @@ Extension [ <persistent> extension #137 swoole version 2.0.8 ] {
}
}
- - Properties [0] {
- }
-
- - Methods [40] {
+ - Properties [31] {
+ Property [ <default> public $onConnect ]
+ Property [ <default> public $onReceive ]
+ Property [ <default> public $onClose ]
+ Property [ <default> public $onPacket ]
+ Property [ <default> public $onBufferFull ]
+ Property [ <default> public $onBufferEmpty ]
+ Property [ <default> public $onStart ]
+ Property [ <default> public $onShutdown ]
+ Property [ <default> public $onWorkerStart ]
+ Property [ <default> public $onWorkerStop ]
+ Property [ <default> public $onWorkerExit ]
+ Property [ <default> public $onWorkerError ]
+ Property [ <default> public $onTask ]
+ Property [ <default> public $onFinish ]
+ Property [ <default> public $onManagerStart ]
+ Property [ <default> public $onManagerStop ]
+ Property [ <default> public $onPipeMessage ]
+ Property [ <default> public $connections ]
+ Property [ <default> public $host ]
+ Property [ <default> public $port ]
+ Property [ <default> public $type ]
+ Property [ <default> public $mode ]
+ Property [ <default> public $ports ]
+ Property [ <default> public $master_pid ]
+ Property [ <default> public $manager_pid ]
+ Property [ <default> public $worker_id ]
+ Property [ <default> public $taskworker ]
+ Property [ <default> public $worker_pid ]
+ Property [ <default> public $onRequest ]
+ Property [ <default> public $onHandshake ]
+ Property [ <default> public $setting ]
+ }
+
+ - Methods [41] {
Method [ <internal:swoole, overwrites Swoole\Http\Server, prototype Swoole\Server> public method on ] {
- Parameters [2] {
@@ -3310,6 +3614,14 @@ Extension [ <persistent> extension #137 swoole version 2.0.8 ] {
}
}
+ Method [ <internal:swoole, inherits Swoole\Server> public method taskCo ] {
+
+ - Parameters [2] {
+ Parameter #0 [ <required> array $tasks ]
+ Parameter #1 [ <optional> $timeout ]
+ }
+ }
+
Method [ <internal:swoole, inherits Swoole\Server> public method finish ] {
- Parameters [1] {
@@ -3485,11 +3797,18 @@ Extension [ <persistent> extension #137 swoole version 2.0.8 ] {
- Static methods [0] {
}
- - Properties [4] {
+ - Properties [11] {
+ Property [ <default> public $serverInfo ]
+ Property [ <default> public $sock ]
+ Property [ <default> public $connected ]
Property [ <default> public $errno ]
Property [ <default> public $connect_errno ]
+ Property [ <default> public $error ]
+ Property [ <default> public $connect_error ]
Property [ <default> public $insert_id ]
Property [ <default> public $affected_rows ]
+ Property [ <default> public $onConnect ]
+ Property [ <default> public $onClose ]
}
- Methods [11] {
@@ -3719,11 +4038,23 @@ Extension [ <persistent> extension #137 swoole version 2.0.8 ] {
- Static methods [0] {
}
- - Properties [4] {
+ - Properties [16] {
Property [ <default> public $errCode ]
Property [ <default> public $sock ]
Property [ <default> public $reuse ]
Property [ <default> public $reuseCount ]
+ Property [ <default> public $type ]
+ Property [ <default> public $id ]
+ Property [ <default> public $setting ]
+ Property [ <default> public $onConnect ]
+ Property [ <default> public $onError ]
+ Property [ <default> public $onReceive ]
+ Property [ <default> public $onClose ]
+ Property [ <default> public $onBufferFull ]
+ Property [ <default> public $onBufferEmpty ]
+ Property [ <default> public $onSSLReady ]
+ Property [ <default> public $requestHeaders ]
+ Property [ <default> public $cookies ]
}
- Methods [33] {
@@ -3919,7 +4250,10 @@ Extension [ <persistent> extension #137 swoole version 2.0.8 ] {
- Static methods [0] {
}
- - Properties [0] {
+ - Properties [3] {
+ Property [ <default> public $statusCode ]
+ Property [ <default> public $body ]
+ Property [ <default> public $streamId ]
}
- Methods [0] {
@@ -3975,7 +4309,16 @@ Extension [ <persistent> extension #137 swoole version 2.0.8 ] {
- Static methods [0] {
}
- - Properties [0] {
+ - Properties [9] {
+ Property [ <default> public $onConnect ]
+ Property [ <default> public $onClose ]
+ Property [ <default> public $onMessage ]
+ Property [ <default> public $setting ]
+ Property [ <default> public $host ]
+ Property [ <default> public $port ]
+ Property [ <default> public $sock ]
+ Property [ <default> public $errCode ]
+ Property [ <default> public $errMsg ]
}
- Methods [7] {
@@ -4056,10 +4399,39 @@ Extension [ <persistent> extension #137 swoole version 2.0.8 ] {
}
}
- - Properties [0] {
- }
-
- - Methods [40] {
+ - Properties [29] {
+ Property [ <default> public $onConnect ]
+ Property [ <default> public $onReceive ]
+ Property [ <default> public $onClose ]
+ Property [ <default> public $onPacket ]
+ Property [ <default> public $onBufferFull ]
+ Property [ <default> public $onBufferEmpty ]
+ Property [ <default> public $onStart ]
+ Property [ <default> public $onShutdown ]
+ Property [ <default> public $onWorkerStart ]
+ Property [ <default> public $onWorkerStop ]
+ Property [ <default> public $onWorkerExit ]
+ Property [ <default> public $onWorkerError ]
+ Property [ <default> public $onTask ]
+ Property [ <default> public $onFinish ]
+ Property [ <default> public $onManagerStart ]
+ Property [ <default> public $onManagerStop ]
+ Property [ <default> public $onPipeMessage ]
+ Property [ <default> public $setting ]
+ Property [ <default> public $connections ]
+ Property [ <default> public $host ]
+ Property [ <default> public $port ]
+ Property [ <default> public $type ]
+ Property [ <default> public $mode ]
+ Property [ <default> public $ports ]
+ Property [ <default> public $master_pid ]
+ Property [ <default> public $manager_pid ]
+ Property [ <default> public $worker_id ]
+ Property [ <default> public $taskworker ]
+ Property [ <default> public $worker_pid ]
+ }
+
+ - Methods [41] {
Method [ <internal:swoole, overwrites Swoole\Server, prototype Swoole\Server> public method start ] {
- Parameters [0] {
@@ -4232,6 +4604,14 @@ Extension [ <persistent> extension #137 swoole version 2.0.8 ] {
}
}
+ Method [ <internal:swoole, inherits Swoole\Server> public method taskCo ] {
+
+ - Parameters [2] {
+ Parameter #0 [ <required> array $tasks ]
+ Parameter #1 [ <optional> $timeout ]
+ }
+ }
+
Method [ <internal:swoole, inherits Swoole\Server> public method finish ] {
- Parameters [1] {
diff --git a/php-pecl-swoole2.spec b/php-pecl-swoole2.spec
index 472e1b7..fa2b6c9 100644
--- a/php-pecl-swoole2.spec
+++ b/php-pecl-swoole2.spec
@@ -30,7 +30,7 @@
Summary: PHP's asynchronous concurrent distributed networking framework
Name: %{?sub_prefix}php-pecl-%{pecl_name}2
-Version: 2.0.8
+Version: 2.0.9
Release: 1%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
License: BSD
Group: Development/Languages
@@ -308,6 +308,9 @@ cd ../ZTS
%changelog
+* Thu Aug 31 2017 Remi Collet <remi@remirepo.net> - 2.0.9-1
+- Update to 2.0.9
+
* Fri Aug 4 2017 Remi Collet <remi@remirepo.net> - 2.0.8-1
- Update to 2.0.8 (beta)
- add devel sub-package