summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--5945408fc74922a25a5d3c1500363ce474eb87dc.patch24
-rw-r--r--php-pecl-swoole2.spec6
2 files changed, 29 insertions, 1 deletions
diff --git a/5945408fc74922a25a5d3c1500363ce474eb87dc.patch b/5945408fc74922a25a5d3c1500363ce474eb87dc.patch
new file mode 100644
index 0000000..5721de6
--- /dev/null
+++ b/5945408fc74922a25a5d3c1500363ce474eb87dc.patch
@@ -0,0 +1,24 @@
+From 5945408fc74922a25a5d3c1500363ce474eb87dc Mon Sep 17 00:00:00 2001
+From: matyhtf <mikan.tenny@gmail.com>
+Date: Thu, 28 Dec 2017 18:25:05 +0800
+Subject: [PATCH] fix #1433
+
+---
+ swoole.c | 4 ----
+ 1 file changed, 4 deletions(-)
+
+diff --git a/swoole.c b/swoole.c
+index 2db93e145..c97ac829d 100644
+--- a/swoole.c
++++ b/swoole.c
+@@ -857,10 +857,6 @@ PHP_MINIT_FUNCTION(swoole)
+ zend_declare_property_bool(swoole_server_class_entry_ptr, ZEND_STRL("taskworker"), 0, ZEND_ACC_PUBLIC TSRMLS_CC);
+ zend_declare_property_long(swoole_server_class_entry_ptr, ZEND_STRL("worker_pid"), 0, ZEND_ACC_PUBLIC TSRMLS_CC);
+
+-#ifdef HAVE_PCRE
+- zend_declare_property_null(swoole_server_class_entry_ptr, ZEND_STRL("connections"), ZEND_ACC_PUBLIC TSRMLS_CC);
+-#endif
+-
+ SWOOLE_INIT_CLASS_ENTRY(swoole_timer_ce, "swoole_timer", "Swoole\\Timer", swoole_timer_methods);
+ swoole_timer_class_entry_ptr = zend_register_internal_class(&swoole_timer_ce TSRMLS_CC);
+ SWOOLE_CLASS_ALIAS(swoole_timer, "Swoole\\Timer");
diff --git a/php-pecl-swoole2.spec b/php-pecl-swoole2.spec
index 236afc6..3e747a0 100644
--- a/php-pecl-swoole2.spec
+++ b/php-pecl-swoole2.spec
@@ -37,6 +37,8 @@ Group: Development/Languages
URL: http://pecl.php.net/package/%{pecl_name}
Source0: http://pecl.php.net/get/%{pecl_name}-%{version}.tgz
+Patch0: https://github.com/swoole/swoole-src/commit/5945408fc74922a25a5d3c1500363ce474eb87dc.patch
+
BuildRequires: %{?scl_prefix}php-devel >= 5.5
BuildRequires: %{?scl_prefix}php-pear
BuildRequires: %{?scl_prefix}php-sockets
@@ -151,6 +153,7 @@ sed -e '/examples/s/role="src"/role="doc"/' \
cd NTS
+%patch0 -p1 -b .upstream
# Sanity check, really often broken
extver=$(sed -n '/#define PHP_SWOOLE_VERSION/{s/.* "//;s/".*$//;p}' php_swoole.h)
@@ -310,7 +313,8 @@ cd ../ZTS
%changelog
* Thu Dec 28 2017 Remi Collet <remi@remirepo.net> - 2.0.11-1
- Update to 2.0.11 (stable)
-- open https://github.com/swoole/swoole-src/issues/1433 - broken with PHP 5
+- add upstream patch to fix broken build with PHP 5.x
+ https://github.com/swoole/swoole-src/issues/1433
* Thu Dec 14 2017 Remi Collet <remi@remirepo.net> - 2.0.10-1
- Update to 2.0.10 (stable)