summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--REFLECTION163
-rw-r--r--php-pecl-swoole2.spec8
2 files changed, 121 insertions, 50 deletions
diff --git a/REFLECTION b/REFLECTION
index 7025bed..892ef30 100644
--- a/REFLECTION
+++ b/REFLECTION
@@ -1,4 +1,4 @@
-Extension [ <persistent> extension #143 swoole version 2.0.10 ] {
+Extension [ <persistent> extension #143 swoole version 2.0.11 ] {
- INI {
Entry [ swoole.aio_thread_num <ALL> ]
@@ -63,7 +63,7 @@ Extension [ <persistent> extension #143 swoole version 2.0.10 ] {
Constant [ integer SWOOLE_DTLSv1_CLIENT_METHOD ] { 17 }
Constant [ integer SWOOLE_EVENT_READ ] { 512 }
Constant [ integer SWOOLE_EVENT_WRITE ] { 1024 }
- Constant [ string SWOOLE_VERSION ] { 2.0.10 }
+ Constant [ string SWOOLE_VERSION ] { 2.0.11 }
Constant [ integer SWOOLE_REDIS_MODE_MULTI ] { 0 }
Constant [ integer SWOOLE_REDIS_MODE_PIPELINE ] { 1 }
Constant [ integer SWOOLE_REDIS_TYPE_NOT_FOUND ] { 0 }
@@ -318,7 +318,6 @@ Extension [ <persistent> extension #143 swoole version 2.0.10 ] {
Property [ <default> public $onManagerStop ]
Property [ <default> public $onPipeMessage ]
Property [ <default> public $setting ]
- Property [ <default> public $connections ]
Property [ <default> public $host ]
Property [ <default> public $port ]
Property [ <default> public $type ]
@@ -329,6 +328,7 @@ Extension [ <persistent> extension #143 swoole version 2.0.10 ] {
Property [ <default> public $worker_id ]
Property [ <default> public $taskworker ]
Property [ <default> public $worker_pid ]
+ Property [ <default> public $connections ]
}
- Methods [42] {
@@ -1009,7 +1009,7 @@ Extension [ <persistent> extension #143 swoole version 2.0.10 ] {
- Static methods [0] {
}
- - Properties [15] {
+ - Properties [16] {
Property [ <default> public $onConnect ]
Property [ <default> public $onReceive ]
Property [ <default> public $onClose ]
@@ -1025,6 +1025,7 @@ Extension [ <persistent> extension #143 swoole version 2.0.10 ] {
Property [ <default> public $type ]
Property [ <default> public $sock ]
Property [ <default> public $setting ]
+ Property [ <default> public $connections ]
}
- Methods [7] {
@@ -1072,10 +1073,10 @@ Extension [ <persistent> extension #143 swoole version 2.0.10 ] {
Class [ <internal:swoole> class Swoole\Client ] {
- Constants [4] {
- Constant [ integer MSG_OOB ] { 1 }
- Constant [ integer MSG_PEEK ] { 2 }
- Constant [ integer MSG_DONTWAIT ] { 64 }
- Constant [ integer MSG_WAITALL ] { 256 }
+ Constant [ public integer MSG_OOB ] { 1 }
+ Constant [ public integer MSG_PEEK ] { 2 }
+ Constant [ public integer MSG_DONTWAIT ] { 64 }
+ Constant [ public integer MSG_WAITALL ] { 256 }
}
- Static properties [0] {
@@ -1261,10 +1262,10 @@ Extension [ <persistent> extension #143 swoole version 2.0.10 ] {
Class [ <internal:swoole> class Swoole\Coroutine\Client ] {
- Constants [4] {
- Constant [ integer MSG_OOB ] { 1 }
- Constant [ integer MSG_PEEK ] { 2 }
- Constant [ integer MSG_DONTWAIT ] { 64 }
- Constant [ integer MSG_WAITALL ] { 256 }
+ Constant [ public integer MSG_OOB ] { 1 }
+ Constant [ public integer MSG_PEEK ] { 2 }
+ Constant [ public integer MSG_DONTWAIT ] { 64 }
+ Constant [ public integer MSG_WAITALL ] { 256 }
}
- Static properties [0] {
@@ -1903,7 +1904,7 @@ Extension [ <persistent> extension #143 swoole version 2.0.10 ] {
Property [ <default> public $errno ]
}
- - Methods [14] {
+ - Methods [16] {
Method [ <internal:swoole, ctor> public method __construct ] {
- Parameters [0] {
@@ -1963,6 +1964,20 @@ Extension [ <persistent> extension #143 swoole version 2.0.10 ] {
}
}
+ Method [ <internal:swoole> public method prepare ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $query ]
+ }
+ }
+
+ Method [ <internal:swoole> public method execute ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $query ]
+ }
+ }
+
Method [ <internal:swoole> public method setDefer ] {
- Parameters [1] {
@@ -2138,20 +2153,38 @@ Extension [ <persistent> extension #143 swoole version 2.0.10 ] {
- Static properties [0] {
}
- - Static methods [8] {
+ - Static methods [11] {
Method [ <internal:swoole> static public method create ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $func ]
+ }
}
Method [ <internal:swoole> static public method cli_wait ] {
+
+ - Parameters [0] {
+ }
}
Method [ <internal:swoole> static public method suspend ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $uid ]
+ }
}
Method [ <internal:swoole> static public method resume ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $uid ]
+ }
}
Method [ <internal:swoole> static public method getuid ] {
+
+ - Parameters [0] {
+ }
}
Method [ <internal:swoole> static public method sleep ] {
@@ -2161,10 +2194,44 @@ Extension [ <persistent> extension #143 swoole version 2.0.10 ] {
}
}
+ Method [ <internal:swoole> static public method fread ] {
+
+ - Parameters [2] {
+ Parameter #0 [ <required> $handle ]
+ Parameter #1 [ <optional> $length ]
+ }
+ }
+
+ Method [ <internal:swoole> static public method fwrite ] {
+
+ - Parameters [3] {
+ Parameter #0 [ <required> $handle ]
+ Parameter #1 [ <required> $string ]
+ Parameter #2 [ <optional> $length ]
+ }
+ }
+
+ Method [ <internal:swoole> static public method gethostbyname ] {
+
+ - Parameters [2] {
+ Parameter #0 [ <required> $domain_name ]
+ Parameter #1 [ <optional> $family ]
+ }
+ }
+
Method [ <internal:swoole> static public method call_user_func ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $func ]
+ }
}
Method [ <internal:swoole> static public method call_user_func_array ] {
+
+ - Parameters [2] {
+ Parameter #0 [ <required> $func ]
+ Parameter #1 [ <required> array $params ]
+ }
}
}
@@ -2348,7 +2415,7 @@ Extension [ <persistent> extension #143 swoole version 2.0.10 ] {
Class [ <internal:swoole> class Swoole\Process ] {
- Constants [1] {
- Constant [ integer IPC_NOWAIT ] { 256 }
+ Constant [ public integer IPC_NOWAIT ] { 256 }
}
- Static properties [0] {
@@ -2520,9 +2587,9 @@ Extension [ <persistent> extension #143 swoole version 2.0.10 ] {
Class [ <internal:swoole> <iterateable> class Swoole\Table implements ArrayAccess, Iterator, Traversable, Countable ] {
- Constants [3] {
- Constant [ integer TYPE_INT ] { 1 }
- Constant [ integer TYPE_STRING ] { 7 }
- Constant [ integer TYPE_FLOAT ] { 6 }
+ Constant [ public integer TYPE_INT ] { 1 }
+ Constant [ public integer TYPE_STRING ] { 7 }
+ Constant [ public integer TYPE_FLOAT ] { 6 }
}
- Static properties [0] {
@@ -2748,11 +2815,11 @@ Extension [ <persistent> extension #143 swoole version 2.0.10 ] {
Class [ <internal:swoole> class Swoole\Lock ] {
- Constants [5] {
- Constant [ integer FILELOCK ] { 2 }
- Constant [ integer MUTEX ] { 3 }
- Constant [ integer SEM ] { 4 }
- Constant [ integer RWLOCK ] { 1 }
- Constant [ integer SPINLOCK ] { 5 }
+ Constant [ public integer FILELOCK ] { 2 }
+ Constant [ public integer MUTEX ] { 3 }
+ Constant [ public integer SEM ] { 4 }
+ Constant [ public integer RWLOCK ] { 1 }
+ Constant [ public integer SPINLOCK ] { 5 }
}
- Static properties [0] {
@@ -2991,7 +3058,6 @@ Extension [ <persistent> extension #143 swoole version 2.0.10 ] {
Property [ <default> public $onManagerStart ]
Property [ <default> public $onManagerStop ]
Property [ <default> public $onPipeMessage ]
- Property [ <default> public $connections ]
Property [ <default> public $host ]
Property [ <default> public $port ]
Property [ <default> public $type ]
@@ -3002,6 +3068,7 @@ Extension [ <persistent> extension #143 swoole version 2.0.10 ] {
Property [ <default> public $worker_id ]
Property [ <default> public $taskworker ]
Property [ <default> public $worker_pid ]
+ Property [ <default> public $connections ]
Property [ <default> public $onRequest ]
Property [ <default> public $onHandshake ]
Property [ <default> public $setting ]
@@ -3626,7 +3693,6 @@ Extension [ <persistent> extension #143 swoole version 2.0.10 ] {
Property [ <default> public $onManagerStart ]
Property [ <default> public $onManagerStop ]
Property [ <default> public $onPipeMessage ]
- Property [ <default> public $connections ]
Property [ <default> public $host ]
Property [ <default> public $port ]
Property [ <default> public $type ]
@@ -3637,6 +3703,7 @@ Extension [ <persistent> extension #143 swoole version 2.0.10 ] {
Property [ <default> public $worker_id ]
Property [ <default> public $taskworker ]
Property [ <default> public $worker_pid ]
+ Property [ <default> public $connections ]
Property [ <default> public $onRequest ]
Property [ <default> public $onHandshake ]
Property [ <default> public $setting ]
@@ -3990,12 +4057,12 @@ Extension [ <persistent> extension #143 swoole version 2.0.10 ] {
Class [ <internal:swoole> class Swoole\MySQL ] {
- Constants [6] {
- Constant [ integer STATE_QUERY ] { 0 }
- Constant [ integer STATE_READ_START ] { 1 }
- Constant [ integer STATE_READ_FIELD ] { 2 }
- Constant [ integer STATE_READ_ROW ] { 3 }
- Constant [ integer STATE_READ_END ] { 4 }
- Constant [ integer STATE_CLOSED ] { 5 }
+ Constant [ public integer STATE_QUERY ] { 0 }
+ Constant [ public integer STATE_READ_START ] { 1 }
+ Constant [ public integer STATE_READ_FIELD ] { 2 }
+ Constant [ public integer STATE_READ_ROW ] { 3 }
+ Constant [ public integer STATE_READ_END ] { 5 }
+ Constant [ public integer STATE_CLOSED ] { 6 }
}
- Static properties [0] {
@@ -4233,10 +4300,10 @@ Extension [ <persistent> extension #143 swoole version 2.0.10 ] {
Class [ <internal:swoole> class Swoole\Http2\Client extends Swoole\Client ] {
- Constants [4] {
- Constant [ integer MSG_OOB ] { 1 }
- Constant [ integer MSG_PEEK ] { 2 }
- Constant [ integer MSG_DONTWAIT ] { 64 }
- Constant [ integer MSG_WAITALL ] { 256 }
+ Constant [ public integer MSG_OOB ] { 1 }
+ Constant [ public integer MSG_PEEK ] { 2 }
+ Constant [ public integer MSG_DONTWAIT ] { 64 }
+ Constant [ public integer MSG_WAITALL ] { 256 }
}
- Static properties [0] {
@@ -4503,11 +4570,11 @@ Extension [ <persistent> extension #143 swoole version 2.0.10 ] {
Class [ <internal:swoole> class Swoole\Redis ] {
- Constants [5] {
- Constant [ integer STATE_CONNECT ] { 0 }
- Constant [ integer STATE_READY ] { 1 }
- Constant [ integer STATE_WAIT_RESULT ] { 2 }
- Constant [ integer STATE_SUBSCRIBE ] { 3 }
- Constant [ integer STATE_CLOSED ] { 4 }
+ Constant [ public integer STATE_CONNECT ] { 0 }
+ Constant [ public integer STATE_READY ] { 1 }
+ Constant [ public integer STATE_WAIT_RESULT ] { 2 }
+ Constant [ public integer STATE_SUBSCRIBE ] { 3 }
+ Constant [ public integer STATE_CLOSED ] { 4 }
}
- Static properties [0] {
@@ -4584,13 +4651,13 @@ Extension [ <persistent> extension #143 swoole version 2.0.10 ] {
Class [ <internal:swoole> class Swoole\Redis\Server extends Swoole\Server ] {
- Constants [7] {
- Constant [ integer NIL ] { 1 }
- Constant [ integer ERROR ] { 0 }
- Constant [ integer STATUS ] { 2 }
- Constant [ integer INT ] { 3 }
- Constant [ integer STRING ] { 4 }
- Constant [ integer SET ] { 5 }
- Constant [ integer MAP ] { 6 }
+ Constant [ public integer NIL ] { 1 }
+ Constant [ public integer ERROR ] { 0 }
+ Constant [ public integer STATUS ] { 2 }
+ Constant [ public integer INT ] { 3 }
+ Constant [ public integer STRING ] { 4 }
+ Constant [ public integer SET ] { 5 }
+ Constant [ public integer MAP ] { 6 }
}
- Static properties [0] {
@@ -4625,7 +4692,6 @@ Extension [ <persistent> extension #143 swoole version 2.0.10 ] {
Property [ <default> public $onManagerStop ]
Property [ <default> public $onPipeMessage ]
Property [ <default> public $setting ]
- Property [ <default> public $connections ]
Property [ <default> public $host ]
Property [ <default> public $port ]
Property [ <default> public $type ]
@@ -4636,6 +4702,7 @@ Extension [ <persistent> extension #143 swoole version 2.0.10 ] {
Property [ <default> public $worker_id ]
Property [ <default> public $taskworker ]
Property [ <default> public $worker_pid ]
+ Property [ <default> public $connections ]
}
- Methods [43] {
diff --git a/php-pecl-swoole2.spec b/php-pecl-swoole2.spec
index 7b5f75b..236afc6 100644
--- a/php-pecl-swoole2.spec
+++ b/php-pecl-swoole2.spec
@@ -30,7 +30,7 @@
Summary: PHP's asynchronous concurrent distributed networking framework
Name: %{?sub_prefix}php-pecl-%{pecl_name}2
-Version: 2.0.10
+Version: 2.0.11
Release: 1%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
License: BSD
Group: Development/Languages
@@ -72,7 +72,7 @@ Conflicts: %{?scl_prefix}php-pecl-%{pecl_name} < 2
%if "%{?vendor}" == "Remi Collet" && 0%{!?scl:1} && 0%{?rhel}
# Other third party repo stuff
Obsoletes: php53-pecl-%{pecl_name}2 <= %{version}
-Obsoletes: php53u-pecl-%{pecl_name2} <= %{version}
+Obsoletes: php53u-pecl-%{pecl_name}2 <= %{version}
Obsoletes: php54-pecl-%{pecl_name}2 <= %{version}
Obsoletes: php54w-pecl-%{pecl_name}2 <= %{version}
Obsoletes: php55u-pecl-%{pecl_name}2 <= %{version}
@@ -308,6 +308,10 @@ cd ../ZTS
%changelog
+* Thu Dec 28 2017 Remi Collet <remi@remirepo.net> - 2.0.11-1
+- Update to 2.0.11 (stable)
+- open https://github.com/swoole/swoole-src/issues/1433 - broken with PHP 5
+
* Thu Dec 14 2017 Remi Collet <remi@remirepo.net> - 2.0.10-1
- Update to 2.0.10 (stable)