summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2015-01-07 16:55:39 +0100
committerRemi Collet <fedora@famillecollet.com>2015-01-07 16:55:39 +0100
commitb628a1daa88e70cfcad2ee7258ce147c7fdf1aef (patch)
tree5a27e727680ed05a30d8a2e7e9eb8816479b680a
parentb19d0e2a9f25548df511942e3885e4576eb5e454 (diff)
php-pecl-swoole: 1.7.9
-rw-r--r--REFLECTION123
-rw-r--r--php-pecl-swoole.spec7
2 files changed, 90 insertions, 40 deletions
diff --git a/REFLECTION b/REFLECTION
index a84af72..4f50ff6 100644
--- a/REFLECTION
+++ b/REFLECTION
@@ -1,11 +1,11 @@
-Extension [ <persistent> extension #147 swoole version 1.7.8 ] {
+Extension [ <persistent> extension #146 swoole version 1.7.9 ] {
- INI {
Entry [ swoole.aio_thread_num <ALL> ]
Current = '2'
}
Entry [ swoole.display_errors <ALL> ]
- Current = '2'
+ Current = 'On'
}
Entry [ swoole.message_queue_key <ALL> ]
Current = '0'
@@ -15,7 +15,7 @@ Extension [ <persistent> extension #147 swoole version 1.7.8 ] {
}
}
- - Constants [35] {
+ - Constants [41] {
Constant [ integer SWOOLE_BASE ] { 4 }
Constant [ integer SWOOLE_THREAD ] { 2 }
Constant [ integer SWOOLE_PROCESS ] { 3 }
@@ -47,10 +47,16 @@ Extension [ <persistent> extension #147 swoole version 1.7.8 ] {
Constant [ integer SWOOLE_SSL ] { 512 }
Constant [ integer SWOOLE_EVENT_READ ] { 512 }
Constant [ integer SWOOLE_EVENT_WRITE ] { 1024 }
- Constant [ string SWOOLE_VERSION ] { 1.7.8 }
+ Constant [ string SWOOLE_VERSION ] { 1.7.9 }
Constant [ integer SWOOLE_AIO_BASE ] { 0 }
Constant [ integer SWOOLE_AIO_GCC ] { 1 }
Constant [ integer SWOOLE_AIO_LINUX ] { 2 }
+ Constant [ integer WEBSOCKET_OPCODE_TEXT ] { 1 }
+ Constant [ integer WEBSOCKET_OPCODE_BINARY ] { 2 }
+ Constant [ integer HTTP_GLOBAL_GET ] { 1 }
+ Constant [ integer HTTP_GLOBAL_POST ] { 2 }
+ Constant [ integer HTTP_GLOBAL_COOKIE ] { 4 }
+ Constant [ integer HTTP_GLOBAL_ALL ] { 31 }
}
- Functions {
@@ -188,14 +194,6 @@ Extension [ <persistent> extension #147 swoole version 1.7.8 ] {
Parameter #1 [ <required> $from_id ]
}
}
- Function [ <internal:swoole> function swoole_bind_uid ] {
-
- - Parameters [3] {
- Parameter #0 [ <required> swoole_server $zobject ]
- Parameter #1 [ <required> $fd ]
- Parameter #2 [ <optional> $uid ]
- }
- }
Function [ <internal:swoole> function swoole_connection_info ] {
- Parameters [3] {
@@ -237,6 +235,13 @@ Extension [ <persistent> extension #147 swoole version 1.7.8 ] {
- Parameters [0] {
}
}
+ Function [ <internal:swoole> function swoole_event_write ] {
+
+ - Parameters [2] {
+ Parameter #0 [ <required> $fd ]
+ Parameter #1 [ <required> $data ]
+ }
+ }
Function [ <internal:swoole> function swoole_timer_add ] {
- Parameters [2] {
@@ -278,7 +283,7 @@ Extension [ <persistent> extension #147 swoole version 1.7.8 ] {
}
}
- - Classes [9] {
+ - Classes [10] {
Class [ <internal:swoole> class swoole_server ] {
- Constants [0] {
@@ -293,7 +298,7 @@ Extension [ <persistent> extension #147 swoole version 1.7.8 ] {
- Properties [0] {
}
- - Methods [24] {
+ - Methods [26] {
Method [ <internal:swoole, ctor> public method __construct ] {
- Parameters [4] {
@@ -433,14 +438,6 @@ Extension [ <persistent> extension #147 swoole version 1.7.8 ] {
}
}
- Method [ <internal:swoole> public method bind_uid ] {
-
- - Parameters [2] {
- Parameter #0 [ <required> $fd ]
- Parameter #1 [ <required> $uid ]
- }
- }
-
Method [ <internal:swoole> public method connection_info ] {
- Parameters [2] {
@@ -460,8 +457,22 @@ Extension [ <persistent> extension #147 swoole version 1.7.8 ] {
Method [ <internal:swoole> public method after ] {
}
+ Method [ <internal:swoole> public method sendmessage ] {
+ }
+
+ Method [ <internal:swoole> public method addprocess ] {
+ }
+
Method [ <internal:swoole> public method stats ] {
}
+
+ Method [ <internal:swoole> public method bind ] {
+
+ - Parameters [2] {
+ Parameter #0 [ <required> $fd ]
+ Parameter #1 [ <required> $uid ]
+ }
+ }
}
}
@@ -508,10 +519,13 @@ Extension [ <persistent> extension #147 swoole version 1.7.8 ] {
- Static properties [0] {
}
- - Static methods [3] {
+ - Static methods [4] {
Method [ <internal:swoole> static public method wait ] {
}
+ Method [ <internal:swoole> static public method signal ] {
+ }
+
Method [ <internal:swoole> static public method kill ] {
}
@@ -522,7 +536,7 @@ Extension [ <persistent> extension #147 swoole version 1.7.8 ] {
- Properties [0] {
}
- - Methods [9] {
+ - Methods [11] {
Method [ <internal:swoole, ctor> public method __construct ] {
}
@@ -535,6 +549,9 @@ Extension [ <persistent> extension #147 swoole version 1.7.8 ] {
Method [ <internal:swoole> public method write ] {
}
+ Method [ <internal:swoole> public method close ] {
+ }
+
Method [ <internal:swoole> public method read ] {
}
@@ -549,6 +566,9 @@ Extension [ <persistent> extension #147 swoole version 1.7.8 ] {
Method [ <internal:swoole> public method exec ] {
}
+
+ Method [ <internal:swoole> public method name ] {
+ }
}
}
@@ -764,10 +784,11 @@ Extension [ <persistent> extension #147 swoole version 1.7.8 ] {
- Static methods [0] {
}
- - Properties [0] {
+ - Properties [1] {
+ Property [ <default> private $global ]
}
- - Methods [24] {
+ - Methods [27] {
Method [ <internal:swoole, overwrites swoole_server, prototype swoole_server> public method on ] {
- Parameters [2] {
@@ -776,6 +797,9 @@ Extension [ <persistent> extension #147 swoole version 1.7.8 ] {
}
}
+ Method [ <internal:swoole> public method setGlobal ] {
+ }
+
Method [ <internal:swoole, overwrites swoole_server, prototype swoole_server> public method start ] {
}
@@ -904,14 +928,6 @@ Extension [ <persistent> extension #147 swoole version 1.7.8 ] {
}
}
- Method [ <internal:swoole, inherits swoole_server> public method bind_uid ] {
-
- - Parameters [2] {
- Parameter #0 [ <required> $fd ]
- Parameter #1 [ <required> $uid ]
- }
- }
-
Method [ <internal:swoole, inherits swoole_server> public method connection_info ] {
- Parameters [2] {
@@ -931,8 +947,22 @@ Extension [ <persistent> extension #147 swoole version 1.7.8 ] {
Method [ <internal:swoole, inherits swoole_server> public method after ] {
}
+ Method [ <internal:swoole, inherits swoole_server> public method sendmessage ] {
+ }
+
+ Method [ <internal:swoole, inherits swoole_server> public method addprocess ] {
+ }
+
Method [ <internal:swoole, inherits swoole_server> public method stats ] {
}
+
+ Method [ <internal:swoole, inherits swoole_server> public method bind ] {
+
+ - Parameters [2] {
+ Parameter #0 [ <required> $fd ]
+ Parameter #1 [ <required> $uid ]
+ }
+ }
}
}
@@ -950,7 +980,7 @@ Extension [ <persistent> extension #147 swoole version 1.7.8 ] {
- Properties [0] {
}
- - Methods [6] {
+ - Methods [5] {
Method [ <internal:swoole> public method cookie ] {
}
@@ -965,9 +995,6 @@ Extension [ <persistent> extension #147 swoole version 1.7.8 ] {
Method [ <internal:swoole> public method end ] {
}
-
- Method [ <internal:swoole> public method message ] {
- }
}
}
@@ -990,6 +1017,26 @@ Extension [ <persistent> extension #147 swoole version 1.7.8 ] {
}
}
}
+
+ Class [ <internal:swoole> class swoole_http_wsresponse ] {
+
+ - Constants [0] {
+ }
+
+ - Static properties [0] {
+ }
+
+ - Static methods [0] {
+ }
+
+ - Properties [0] {
+ }
+
+ - Methods [1] {
+ Method [ <internal:swoole> public method message ] {
+ }
+ }
+ }
}
}
diff --git a/php-pecl-swoole.spec b/php-pecl-swoole.spec
index 909b018..acae7e2 100644
--- a/php-pecl-swoole.spec
+++ b/php-pecl-swoole.spec
@@ -23,8 +23,8 @@
Summary: PHP's asynchronous concurrent distributed networking framework
Name: %{?scl_prefix}php-pecl-%{pecl_name}
-Version: 1.7.8
-Release: 1%{?dist}%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}.1
+Version: 1.7.9
+Release: 1%{?dist}%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}
License: BSD
Group: Development/Languages
URL: http://pecl.php.net/package/%{pecl_name}
@@ -231,6 +231,9 @@ rm -rf %{buildroot}
%changelog
+* Wed Jan 07 2015 Remi Collet <remi@fedoraproject.org> - 1.7.9-1
+- Update to 1.7.9
+
* Wed Dec 24 2014 Remi Collet <remi@fedoraproject.org> - 1.7.8-1.1
- Fedora 21 SCL mass rebuild