summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2016-03-02 07:08:24 +0100
committerRemi Collet <fedora@famillecollet.com>2016-03-02 07:08:24 +0100
commit9f9679a5ace6fa716fdb3f11b821bd7febfa200c (patch)
tree0fab2cadde93b8ed4bcee8c92ae2f699fdccf485
parent13f0408c5a77d83821c32fd447de719f19d57a02 (diff)
php-pecl-swoole: 1.8.2 (stable)
-rw-r--r--REFLECTION165
-rw-r--r--php-pecl-swoole.spec48
2 files changed, 196 insertions, 17 deletions
diff --git a/REFLECTION b/REFLECTION
index 26f6ee2..b439acf 100644
--- a/REFLECTION
+++ b/REFLECTION
@@ -1,4 +1,4 @@
-Extension [ <persistent> extension #166 swoole version 1.8.1 ] {
+Extension [ <persistent> extension #166 swoole version 1.8.2 ] {
- INI {
Entry [ swoole.aio_thread_num <ALL> ]
@@ -18,7 +18,7 @@ Extension [ <persistent> extension #166 swoole version 1.8.1 ] {
}
}
- - Constants [45] {
+ - Constants [64] {
Constant [ integer SWOOLE_BASE ] { 4 }
Constant [ integer SWOOLE_THREAD ] { 2 }
Constant [ integer SWOOLE_PROCESS ] { 3 }
@@ -43,9 +43,28 @@ Extension [ <persistent> extension #166 swoole version 1.8.1 ] {
Constant [ integer SWOOLE_SYNC ] { 2048 }
Constant [ integer SWOOLE_ASYNC ] { 1024 }
Constant [ integer SWOOLE_KEEP ] { 4096 }
+ Constant [ integer SWOOLE_SSL ] { 512 }
+ Constant [ integer SWOOLE_SSLv3_METHOD ] { 1 }
+ Constant [ integer SWOOLE_SSLv3_SERVER_METHOD ] { 2 }
+ Constant [ integer SWOOLE_SSLv3_CLIENT_METHOD ] { 3 }
+ Constant [ integer SWOOLE_SSLv23_METHOD ] { 0 }
+ Constant [ integer SWOOLE_SSLv23_SERVER_METHOD ] { 4 }
+ Constant [ integer SWOOLE_SSLv23_CLIENT_METHOD ] { 5 }
+ Constant [ integer SWOOLE_TLSv1_METHOD ] { 6 }
+ Constant [ integer SWOOLE_TLSv1_SERVER_METHOD ] { 7 }
+ Constant [ integer SWOOLE_TLSv1_CLIENT_METHOD ] { 8 }
+ Constant [ integer SWOOLE_TLSv1_1_METHOD ] { 9 }
+ Constant [ integer SWOOLE_TLSv1_1_SERVER_METHOD ] { 10 }
+ Constant [ integer SWOOLE_TLSv1_1_CLIENT_METHOD ] { 11 }
+ Constant [ integer SWOOLE_TLSv1_2_METHOD ] { 12 }
+ Constant [ integer SWOOLE_TLSv1_2_SERVER_METHOD ] { 13 }
+ Constant [ integer SWOOLE_TLSv1_2_CLIENT_METHOD ] { 14 }
+ Constant [ integer SWOOLE_DTLSv1_METHOD ] { 15 }
+ Constant [ integer SWOOLE_DTLSv1_SERVER_METHOD ] { 16 }
+ Constant [ integer SWOOLE_DTLSv1_CLIENT_METHOD ] { 17 }
Constant [ integer SWOOLE_EVENT_READ ] { 512 }
Constant [ integer SWOOLE_EVENT_WRITE ] { 1024 }
- Constant [ string SWOOLE_VERSION ] { 1.8.1 }
+ Constant [ string SWOOLE_VERSION ] { 1.8.2 }
Constant [ integer SWOOLE_AIO_BASE ] { 0 }
Constant [ integer SWOOLE_AIO_GCC ] { 1 }
Constant [ integer SWOOLE_AIO_LINUX ] { 2 }
@@ -223,7 +242,7 @@ Extension [ <persistent> extension #166 swoole version 1.8.1 ] {
}
}
- - Classes [15] {
+ - Classes [17] {
Class [ <internal:swoole> class swoole_server ] {
- Constants [0] {
@@ -238,7 +257,7 @@ Extension [ <persistent> extension #166 swoole version 1.8.1 ] {
- Properties [0] {
}
- - Methods [32] {
+ - Methods [33] {
Method [ <internal:swoole, ctor> public method __construct ] {
- Parameters [4] {
@@ -380,6 +399,12 @@ Extension [ <persistent> extension #166 swoole version 1.8.1 ] {
}
}
+ Method [ <internal:swoole> public method stop ] {
+
+ - Parameters [0] {
+ }
+ }
+
Method [ <internal:swoole> public method heartbeat ] {
- Parameters [1] {
@@ -667,6 +692,115 @@ Extension [ <persistent> extension #166 swoole version 1.8.1 ] {
}
}
+ Class [ <internal:swoole> class swoole_http_client ] {
+
+ - Constants [0] {
+ }
+
+ - Static properties [0] {
+ }
+
+ - Static methods [0] {
+ }
+
+ - Properties [2] {
+ Property [ <default> public $errCode ]
+ Property [ <default> public $sock ]
+ }
+
+ - Methods [13] {
+ Method [ <internal:swoole, ctor> public method __construct ] {
+ }
+
+ Method [ <internal:swoole, dtor> public method __destruct ] {
+ }
+
+ Method [ <internal:swoole> public method set ] {
+ }
+
+ Method [ <internal:swoole> public method setHeaders ] {
+ }
+
+ Method [ <internal:swoole> public method setData ] {
+ }
+
+ Method [ <internal:swoole> public method execute ] {
+ }
+
+ Method [ <internal:swoole> public method push ] {
+ }
+
+ Method [ <internal:swoole> public method get ] {
+ }
+
+ Method [ <internal:swoole> public method post ] {
+ }
+
+ Method [ <internal:swoole> public method upgrade ] {
+ }
+
+ Method [ <internal:swoole> public method isConnected ] {
+ }
+
+ Method [ <internal:swoole> public method close ] {
+ }
+
+ Method [ <internal:swoole> public method on ] {
+ }
+ }
+ }
+
+ Class [ <internal:swoole> class swoole_redis ] {
+
+ - Constants [0] {
+ }
+
+ - Static properties [0] {
+ }
+
+ - Static methods [0] {
+ }
+
+ - Properties [0] {
+ }
+
+ - Methods [6] {
+ Method [ <internal:swoole, ctor> public method __construct ] {
+ }
+
+ Method [ <internal:swoole, dtor> public method __destruct ] {
+ }
+
+ Method [ <internal:swoole> public method on ] {
+
+ - Parameters [2] {
+ Parameter #0 [ <required> $event_name ]
+ Parameter #1 [ <required> $callback ]
+ }
+ }
+
+ Method [ <internal:swoole> public method connect ] {
+
+ - Parameters [3] {
+ Parameter #0 [ <required> $host ]
+ Parameter #1 [ <required> $port ]
+ Parameter #2 [ <required> $callback ]
+ }
+ }
+
+ Method [ <internal:swoole> public method close ] {
+ }
+
+ Method [ <internal:swoole> public method __call ] {
+
+ - Parameters [2] {
+ Parameter #0 [ <required> $command ]
+ Parameter #1 [ <required> $params ]
+ }
+ }
+ }
+ }
+
Class [ <internal:swoole> class swoole_process ] {
- Constants [0] {
@@ -968,7 +1102,7 @@ Extension [ <persistent> extension #166 swoole version 1.8.1 ] {
Property [ <default> private $global ]
}
- - Methods [33] {
+ - Methods [34] {
Method [ <internal:swoole, overwrites swoole_server, prototype swoole_server> public method on ] {
- Parameters [2] {
@@ -1110,6 +1244,12 @@ Extension [ <persistent> extension #166 swoole version 1.8.1 ] {
}
}
+ Method [ <internal:swoole, inherits swoole_server> public method stop ] {
+
+ - Parameters [0] {
+ }
+ }
+
Method [ <internal:swoole, inherits swoole_server> public method heartbeat ] {
- Parameters [1] {
@@ -1277,13 +1417,16 @@ Extension [ <persistent> extension #166 swoole version 1.8.1 ] {
- Properties [0] {
}
- - Methods [8] {
+ - Methods [9] {
Method [ <internal:swoole, ctor> public method __construct ] {
}
Method [ <internal:swoole, dtor> public method __destruct ] {
}
+ Method [ <internal:swoole> public method __toString ] {
+ }
+
Method [ <internal:swoole> public method substr ] {
}
@@ -1334,7 +1477,7 @@ Extension [ <persistent> extension #166 swoole version 1.8.1 ] {
- Properties [0] {
}
- - Methods [34] {
+ - Methods [35] {
Method [ <internal:swoole, overwrites swoole_http_server, prototype swoole_server> public method on ] {
- Parameters [2] {
@@ -1486,6 +1629,12 @@ Extension [ <persistent> extension #166 swoole version 1.8.1 ] {
}
}
+ Method [ <internal:swoole, inherits swoole_server> public method stop ] {
+
+ - Parameters [0] {
+ }
+ }
+
Method [ <internal:swoole, inherits swoole_server> public method heartbeat ] {
- Parameters [1] {
diff --git a/php-pecl-swoole.spec b/php-pecl-swoole.spec
index f98c995..7f80b4e 100644
--- a/php-pecl-swoole.spec
+++ b/php-pecl-swoole.spec
@@ -15,9 +15,6 @@
%endif
%{?scl: %scl_package php-pecl-swoole}
-%{!?php_inidir: %global php_inidir %{_sysconfdir}/php.d}
-%{!?__pecl: %global __pecl %{_bindir}/pecl}
-%{!?__php: %global __php %{_bindir}/php}
%global with_zts 0%{!?_without_zts:%{?__ztsphp:1}}
%global pecl_name swoole
@@ -29,9 +26,16 @@
%global ini_name 40-%{pecl_name}.ini
%endif
+%if 0%{?fedora} >= 22 || 0%{?rhel} >= 6
+%global with_nghttpd2 1
+%else
+%global with_nghttpd2 0
+%endif
+%global with_hiredis 1
+
Summary: PHP's asynchronous concurrent distributed networking framework
Name: %{?sub_prefix}php-pecl-%{pecl_name}
-Version: 1.8.1
+Version: 1.8.2
Release: 1%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
License: BSD
Group: Development/Languages
@@ -44,6 +48,13 @@ BuildRequires: %{?scl_prefix}php-pear
BuildRequires: %{?scl_prefix}php-sockets
BuildRequires: %{?scl_prefix}php-mysqli
BuildRequires: pcre-devel
+BuildRequires: openssl-devel
+%if %{with_nghttpd2}
+BuildRequires: libnghttp2-devel
+%endif
+%if %{with_hiredis}
+BuildRequires: hiredis-devel
+%endif
Requires: %{?scl_prefix}php(zend-abi) = %{php_zend_api}
Requires: %{?scl_prefix}php(api) = %{php_core_api}
@@ -91,18 +102,23 @@ Obsoletes: php70w-pecl-%{pecl_name} <= %{version}
%description
-Asynchronous and concurrent and distributed networking framework for PHP.
+Event-driven asynchronous and concurrent networking engine with
+high performance for PHP.
- event-driven
-- full asynchronous non-blocking
+- asynchronous non-blocking
- multi-thread reactor
- multi-process worker
+- multi-protocol
- millisecond timer
-- async MySQL
+- async mysql client
+- built-in http/websocket/http2 server
+- async http/websocket client
+- async redis client
- async task
- async read/write file system
- async dns lookup
- support IPv4/IPv6/UnixSocket/TCP/UDP
-- SSL/TLS encrypted transmission
+- support SSL/TLS encrypted transmission</description>
Package built for PHP %(%{__php} -r 'echo PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')%{?scl: as Software Collection (%{scl} by %{?scl_vendor}%{!?scl_vendor:rh})}.
@@ -153,11 +169,18 @@ EOF
peclbuild() {
%configure \
--with-swoole \
- --enable-msgqueue \
+ --enable-openssl \
--enable-sockets \
%if "%{php_version}" > "5.4"
--enable-async-mysql \
%endif
+ --enable-async-httpclient \
+%if %{with_nghttpd2}
+ --enable-http2 \
+%endif
+%if %{with_hiredis}
+ --enable-async-redis \
+%endif
--with-php-config=$1
make %{?_smp_mflags}
@@ -199,6 +222,7 @@ do install -Dpm 644 NTS/$i %{buildroot}%{pecl_docdir}/%{pecl_name}/$i
done
+%if 0%{?fedora} < 24
# when pear installed alone, after us
%triggerin -- %{?scl_prefix}php-pear
if [ -x %{__pecl} ] ; then
@@ -215,6 +239,7 @@ fi
if [ $1 -eq 0 -a -x %{__pecl} ] ; then
%{pecl_uninstall} %{pecl_name} >/dev/null || :
fi
+%endif
%check
@@ -257,6 +282,11 @@ rm -rf %{buildroot}
%changelog
+* Wed Mar 02 2016 Remi Collet <remi@fedoraproject.org> - 1.8.2-1
+- Update to 1.8.2 (stable)
+- add --enable-openssl, --enable-async-httpclient
+ --enable-http2 and --enable-async-redis to build options
+
* Thu Feb 4 2016 Remi Collet <remi@fedoraproject.org> - 1.8.1-1
- Update to 1.8.1 (stable)