summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2014-10-10 17:00:15 +0200
committerRemi Collet <fedora@famillecollet.com>2014-10-10 17:00:15 +0200
commitf64590042812fca458ed8359667cb150697ba6cb (patch)
tree56d31904ef07ff5b397bc72ef54f4e0ad87e9f3c
php-pecl-stomp: 1.0.5 - New package
-rw-r--r--3_01.txt68
-rw-r--r--Makefile4
-rw-r--r--REFLECTION366
-rw-r--r--php-pecl-stomp.spec202
4 files changed, 640 insertions, 0 deletions
diff --git a/3_01.txt b/3_01.txt
new file mode 100644
index 0000000..6059c80
--- /dev/null
+++ b/3_01.txt
@@ -0,0 +1,68 @@
+--------------------------------------------------------------------
+ The PHP License, version 3.01
+Copyright (c) 1999 - 2014 The PHP Group. All rights reserved.
+--------------------------------------------------------------------
+
+Redistribution and use in source and binary forms, with or without
+modification, is permitted provided that the following conditions
+are met:
+
+ 1. Redistributions of source code must retain the above copyright
+ notice, this list of conditions and the following disclaimer.
+
+ 2. Redistributions in binary form must reproduce the above copyright
+ notice, this list of conditions and the following disclaimer in
+ the documentation and/or other materials provided with the
+ distribution.
+
+ 3. The name "PHP" must not be used to endorse or promote products
+ derived from this software without prior written permission. For
+ written permission, please contact group@php.net.
+
+ 4. Products derived from this software may not be called "PHP", nor
+ may "PHP" appear in their name, without prior written permission
+ from group@php.net. You may indicate that your software works in
+ conjunction with PHP by saying "Foo for PHP" instead of calling
+ it "PHP Foo" or "phpfoo"
+
+ 5. The PHP Group may publish revised and/or new versions of the
+ license from time to time. Each version will be given a
+ distinguishing version number.
+ Once covered code has been published under a particular version
+ of the license, you may always continue to use it under the terms
+ of that version. You may also choose to use such covered code
+ under the terms of any subsequent version of the license
+ published by the PHP Group. No one other than the PHP Group has
+ the right to modify the terms applicable to covered code created
+ under this License.
+
+ 6. Redistributions of any form whatsoever must retain the following
+ acknowledgment:
+ "This product includes PHP software, freely available from
+ <http://www.php.net/software/>".
+
+THIS SOFTWARE IS PROVIDED BY THE PHP DEVELOPMENT TEAM ``AS IS'' AND
+ANY EXPRESSED OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO,
+THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A
+PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE PHP
+DEVELOPMENT TEAM OR ITS CONTRIBUTORS BE LIABLE FOR ANY DIRECT,
+INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES
+(INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR
+SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION)
+HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT,
+STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE)
+ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED
+OF THE POSSIBILITY OF SUCH DAMAGE.
+
+--------------------------------------------------------------------
+
+This software consists of voluntary contributions made by many
+individuals on behalf of the PHP Group.
+
+The PHP Group can be contacted via Email at group@php.net.
+
+For more information on the PHP Group and the PHP project,
+please see <http://www.php.net>.
+
+PHP includes the Zend Engine, freely available at
+<http://www.zend.com>.
diff --git a/Makefile b/Makefile
new file mode 100644
index 0000000..13af741
--- /dev/null
+++ b/Makefile
@@ -0,0 +1,4 @@
+SRCDIR := $(shell pwd)
+NAME := $(shell basename $(SRCDIR))
+include ../../../common/Makefile
+
diff --git a/REFLECTION b/REFLECTION
new file mode 100644
index 0000000..f8e6c72
--- /dev/null
+++ b/REFLECTION
@@ -0,0 +1,366 @@
+Extension [ <persistent> extension #143 Stomp version 1.0.5 ] {
+
+ - INI {
+ Entry [ stomp.default_broker <ALL> ]
+ Current = 'tcp://localhost:61613'
+ }
+ Entry [ stomp.default_read_timeout_sec <ALL> ]
+ Current = '2'
+ }
+ Entry [ stomp.default_read_timeout_usec <ALL> ]
+ Current = '0'
+ }
+ Entry [ stomp.default_connection_timeout_sec <ALL> ]
+ Current = '2'
+ }
+ Entry [ stomp.default_connection_timeout_usec <ALL> ]
+ Current = '0'
+ }
+ }
+
+ - Functions {
+ Function [ <internal:Stomp> function stomp_version ] {
+
+ - Parameters [0] {
+ }
+ }
+ Function [ <internal:Stomp> function stomp_connect ] {
+
+ - Parameters [4] {
+ Parameter #0 [ <optional> $broker ]
+ Parameter #1 [ <optional> $username ]
+ Parameter #2 [ <optional> $password ]
+ Parameter #3 [ <optional> array or NULL $headers ]
+ }
+ }
+ Function [ <internal:Stomp> function stomp_connect_error ] {
+
+ - Parameters [0] {
+ }
+ }
+ Function [ <internal:Stomp> function stomp_get_session_id ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $link ]
+ }
+ }
+ Function [ <internal:Stomp> function stomp_close ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $link ]
+ }
+ }
+ Function [ <internal:Stomp> function stomp_send ] {
+
+ - Parameters [4] {
+ Parameter #0 [ <required> $link ]
+ Parameter #1 [ <required> $destination ]
+ Parameter #2 [ <required> $msg ]
+ Parameter #3 [ <optional> array or NULL $headers ]
+ }
+ }
+ Function [ <internal:Stomp> function stomp_subscribe ] {
+
+ - Parameters [3] {
+ Parameter #0 [ <required> $link ]
+ Parameter #1 [ <required> $destination ]
+ Parameter #2 [ <optional> array or NULL $headers ]
+ }
+ }
+ Function [ <internal:Stomp> function stomp_has_frame ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $link ]
+ }
+ }
+ Function [ <internal:Stomp> function stomp_read_frame ] {
+
+ - Parameters [2] {
+ Parameter #0 [ <required> $link ]
+ Parameter #1 [ <optional> $class_name ]
+ }
+ }
+ Function [ <internal:Stomp> function stomp_unsubscribe ] {
+
+ - Parameters [3] {
+ Parameter #0 [ <required> $link ]
+ Parameter #1 [ <required> $destination ]
+ Parameter #2 [ <optional> array or NULL $headers ]
+ }
+ }
+ Function [ <internal:Stomp> function stomp_begin ] {
+
+ - Parameters [3] {
+ Parameter #0 [ <required> $link ]
+ Parameter #1 [ <required> $transaction_id ]
+ Parameter #2 [ <optional> array or NULL $headers ]
+ }
+ }
+ Function [ <internal:Stomp> function stomp_commit ] {
+
+ - Parameters [3] {
+ Parameter #0 [ <required> $link ]
+ Parameter #1 [ <required> $transaction_id ]
+ Parameter #2 [ <optional> array or NULL $headers ]
+ }
+ }
+ Function [ <internal:Stomp> function stomp_abort ] {
+
+ - Parameters [3] {
+ Parameter #0 [ <required> $link ]
+ Parameter #1 [ <required> $transaction_id ]
+ Parameter #2 [ <optional> array or NULL $headers ]
+ }
+ }
+ Function [ <internal:Stomp> function stomp_ack ] {
+
+ - Parameters [3] {
+ Parameter #0 [ <required> $link ]
+ Parameter #1 [ <required> $msg ]
+ Parameter #2 [ <optional> array or NULL $headers ]
+ }
+ }
+ Function [ <internal:Stomp> function stomp_error ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $link ]
+ }
+ }
+ Function [ <internal:Stomp> function stomp_set_read_timeout ] {
+
+ - Parameters [3] {
+ Parameter #0 [ <required> $link ]
+ Parameter #1 [ <required> $seconds ]
+ Parameter #2 [ <optional> $microseconds ]
+ }
+ }
+ Function [ <internal:Stomp> function stomp_get_read_timeout ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $link ]
+ }
+ }
+ }
+
+ - Classes [3] {
+ Class [ <internal:Stomp> class Stomp ] {
+
+ - Constants [0] {
+ }
+
+ - Static properties [0] {
+ }
+
+ - Static methods [0] {
+ }
+
+ - Properties [0] {
+ }
+
+ - Methods [15] {
+ Method [ <internal:Stomp, ctor> public method __construct ] {
+
+ - Parameters [4] {
+ Parameter #0 [ <optional> $broker ]
+ Parameter #1 [ <optional> $username ]
+ Parameter #2 [ <optional> $password ]
+ Parameter #3 [ <optional> array or NULL $headers ]
+ }
+ }
+
+ Method [ <internal:Stomp> public method getSessionId ] {
+
+ - Parameters [0] {
+ }
+ }
+
+ Method [ <internal:Stomp, dtor> public method __destruct ] {
+
+ - Parameters [0] {
+ }
+ }
+
+ Method [ <internal:Stomp> public method send ] {
+
+ - Parameters [3] {
+ Parameter #0 [ <required> $destination ]
+ Parameter #1 [ <required> $msg ]
+ Parameter #2 [ <optional> array or NULL $headers ]
+ }
+ }
+
+ Method [ <internal:Stomp> public method subscribe ] {
+
+ - Parameters [2] {
+ Parameter #0 [ <required> $destination ]
+ Parameter #1 [ <optional> array or NULL $headers ]
+ }
+ }
+
+ Method [ <internal:Stomp> public method hasFrame ] {
+
+ - Parameters [0] {
+ }
+ }
+
+ Method [ <internal:Stomp> public method readFrame ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <optional> $class_name ]
+ }
+ }
+
+ Method [ <internal:Stomp> public method unsubscribe ] {
+
+ - Parameters [2] {
+ Parameter #0 [ <required> $destination ]
+ Parameter #1 [ <optional> array or NULL $headers ]
+ }
+ }
+
+ Method [ <internal:Stomp> public method begin ] {
+
+ - Parameters [2] {
+ Parameter #0 [ <required> $transaction_id ]
+ Parameter #1 [ <optional> array or NULL $headers ]
+ }
+ }
+
+ Method [ <internal:Stomp> public method commit ] {
+
+ - Parameters [2] {
+ Parameter #0 [ <required> $transaction_id ]
+ Parameter #1 [ <optional> array or NULL $headers ]
+ }
+ }
+
+ Method [ <internal:Stomp> public method abort ] {
+
+ - Parameters [2] {
+ Parameter #0 [ <required> $transaction_id ]
+ Parameter #1 [ <optional> array or NULL $headers ]
+ }
+ }
+
+ Method [ <internal:Stomp> public method ack ] {
+
+ - Parameters [2] {
+ Parameter #0 [ <required> $msg ]
+ Parameter #1 [ <optional> array or NULL $headers ]
+ }
+ }
+
+ Method [ <internal:Stomp> public method error ] {
+
+ - Parameters [0] {
+ }
+ }
+
+ Method [ <internal:Stomp> public method setReadTimeout ] {
+
+ - Parameters [2] {
+ Parameter #0 [ <required> $seconds ]
+ Parameter #1 [ <optional> $microseconds ]
+ }
+ }
+
+ Method [ <internal:Stomp> public method getReadTimeout ] {
+
+ - Parameters [0] {
+ }
+ }
+ }
+ }
+
+ Class [ <internal:Stomp> class StompFrame ] {
+
+ - Constants [0] {
+ }
+
+ - Static properties [0] {
+ }
+
+ - Static methods [0] {
+ }
+
+ - Properties [3] {
+ Property [ <default> public $command ]
+ Property [ <default> public $headers ]
+ Property [ <default> public $body ]
+ }
+
+ - Methods [1] {
+ Method [ <internal:Stomp, ctor> public method __construct ] {
+
+ - Parameters [3] {
+ Parameter #0 [ <optional> $command ]
+ Parameter #1 [ <optional> array or NULL $headers ]
+ Parameter #2 [ <optional> $body ]
+ }
+ }
+ }
+ }
+
+ Class [ <internal:Stomp> class StompException extends Exception ] {
+
+ - Constants [0] {
+ }
+
+ - Static properties [0] {
+ }
+
+ - Static methods [0] {
+ }
+
+ - Properties [5] {
+ Property [ <default> protected $message ]
+ Property [ <default> protected $code ]
+ Property [ <default> protected $file ]
+ Property [ <default> protected $line ]
+ Property [ <default> private $details ]
+ }
+
+ - Methods [10] {
+ Method [ <internal:Stomp> public method getDetails ] {
+
+ - Parameters [0] {
+ }
+ }
+
+ Method [ <internal:Core, inherits Exception, ctor> <visibility error> method __construct ] {
+
+ - Parameters [3] {
+ Parameter #0 [ <optional> $message ]
+ Parameter #1 [ <optional> $code ]
+ Parameter #2 [ <optional> $previous ]
+ }
+ }
+
+ Method [ <internal:Core, inherits Exception> final public method getMessage ] {
+ }
+
+ Method [ <internal:Core, inherits Exception> final public method getCode ] {
+ }
+
+ Method [ <internal:Core, inherits Exception> final public method getFile ] {
+ }
+
+ Method [ <internal:Core, inherits Exception> final public method getLine ] {
+ }
+
+ Method [ <internal:Core, inherits Exception> final public method getTrace ] {
+ }
+
+ Method [ <internal:Core, inherits Exception> final public method getPrevious ] {
+ }
+
+ Method [ <internal:Core, inherits Exception> final public method getTraceAsString ] {
+ }
+
+ Method [ <internal:Core, inherits Exception> public method __toString ] {
+ }
+ }
+ }
+ }
+}
+
diff --git a/php-pecl-stomp.spec b/php-pecl-stomp.spec
new file mode 100644
index 0000000..874c2af
--- /dev/null
+++ b/php-pecl-stomp.spec
@@ -0,0 +1,202 @@
+# spec file for php-pecl-stomp
+#
+# Copyright (c) 2014 Remi Collet
+# License: CC-BY-SA
+# http://creativecommons.org/licenses/by-sa/3.0/
+#
+# Please, preserve the changelog entries
+#
+%{?scl: %scl_package php-pecl-stomp}
+%{!?php_inidir: %global php_inidir %{_sysconfdir}/php.d}
+%{!?__pecl: %global __pecl %{_bindir}/pecl}
+%{!?__php: %global __php %{_bindir}/php}
+
+%global with_zts 0%{?__ztsphp:1}
+%global pecl_name stomp
+%if "%{php_version}" < "5.6"
+# After sockets
+%global ini_name %{pecl_name}.ini
+%else
+# After 20-sockets
+%global ini_name 40-%{pecl_name}.ini
+%endif
+
+Summary: Stomp client extension
+Name: %{?scl_prefix}php-pecl-%{pecl_name}
+Version: 1.0.5
+Release: 1%{?dist}%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}
+License: PHP
+Group: Development/Languages
+URL: http://pecl.php.net/package/%{pecl_name}
+Source0: http://pecl.php.net/get/%{pecl_name}-%{version}.tgz
+# URI from sources headers
+Source1: http://www.php.net/license/3_01.txt
+
+BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
+BuildRequires: %{?scl_prefix}php-devel
+BuildRequires: %{?scl_prefix}php-pear
+
+Requires(post): %{__pecl}
+Requires(postun): %{__pecl}
+Requires: %{?scl_prefix}php(zend-abi) = %{php_zend_api}
+Requires: %{?scl_prefix}php(api) = %{php_core_api}
+%{?_sclreq:Requires: %{?scl_prefix}runtime%{?_sclreq}%{?_isa}}
+
+Provides: %{?scl_prefix}php-%{pecl_name} = %{version}
+Provides: %{?scl_prefix}php-%{pecl_name}%{?_isa} = %{version}
+Provides: %{?scl_prefix}php-pecl(%{pecl_name}) = %{version}
+Provides: %{?scl_prefix}php-pecl(%{pecl_name})%{?_isa} = %{version}
+
+%if "%{?vendor}" == "Remi Collet" && 0%{!?scl:1}
+# Other third party repo stuff
+Obsoletes: php53-pecl-%{pecl_name} <= %{version}
+Obsoletes: php53u-pecl-%{pecl_name} <= %{version}
+Obsoletes: php54-pecl-%{pecl_name} <= %{version}
+Obsoletes: php54w-pecl-%{pecl_name} <= %{version}
+%if "%{php_version}" > "5.5"
+Obsoletes: php55u-pecl-%{pecl_name} <= %{version}
+Obsoletes: php55w-pecl-%{pecl_name} <= %{version}
+%endif
+%if "%{php_version}" > "5.6"
+Obsoletes: php56u-pecl-%{pecl_name} <= %{version}
+Obsoletes: php56w-pecl-%{pecl_name} <= %{version}
+%endif
+%endif
+
+%if 0%{?fedora} < 20 && 0%{?rhel} < 7
+# Filter shared private
+%{?filter_provides_in: %filter_provides_in %{_libdir}/.*\.so$}
+%{?filter_setup}
+%endif
+
+
+%description
+This extension allows php applications to communicate with any
+Stomp compliant Message Brokers through easy object oriented
+and procedural interfaces.
+
+Documentation: http://php.net/stomp
+Package built for PHP %(%{__php} -r 'echo PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')%{?scl: as Software Collection}.
+
+
+%prep
+%setup -q -c
+mv %{pecl_name}-%{version} NTS
+
+# Don't install/register tests
+sed -e 's/role="test"/role="src"/' -i package.xml
+
+%if %{with_zts}
+# Duplicate source tree for NTS / ZTS build
+cp -pr NTS ZTS
+%endif
+
+cp %{SOURCE1} NTS/LICENSE
+
+chmod -x ?TS/*.{c,h}
+
+# Create configuration file
+cat << 'EOF' | tee %{ini_name}
+; Enable %{summary} module
+extension=%{pecl_name}.so
+
+; See http://php.net/manual/en/stomp.configuration.php
+;stomp.default_broker = "tcp://localhost:61613"
+;stomp.default_read_timeout_sec = 2
+;stomp.default_read_timeout_usec = 0
+;stomp.default_connection_timeout_sec = 2
+;stomp.default_connection_timeout_usec = 0
+EOF
+
+
+%build
+peclbuild() {
+%configure \
+ --enable-stomp \
+ --with-php-config=$1
+
+make %{?_smp_mflags}
+}
+
+cd NTS
+%{_bindir}/phpize
+peclbuild %{_bindir}/php-config
+
+%if %{with_zts}
+cd ../ZTS
+%{_bindir}/zts-phpize
+peclbuild %{_bindir}/zts-php-config
+%endif
+
+
+%install
+rm -rf %{buildroot}
+
+make -C NTS install INSTALL_ROOT=%{buildroot}
+
+# install config file
+install -D -m 644 %{ini_name} %{buildroot}%{php_inidir}/%{ini_name}
+
+# Install XML package description
+install -D -m 644 package.xml %{buildroot}%{pecl_xmldir}/%{name}.xml
+
+%if %{with_zts}
+make -C ZTS install INSTALL_ROOT=%{buildroot}
+
+install -D -m 644 %{ini_name} %{buildroot}%{php_ztsinidir}/%{ini_name}
+%endif
+
+# Documentation
+for i in LICENSE $(grep 'role="doc"' package.xml | sed -e 's/^.*name="//;s/".*$//')
+do install -Dpm 644 NTS/$i %{buildroot}%{pecl_docdir}/%{pecl_name}/$i
+done
+
+
+%post
+%{pecl_install} %{pecl_xmldir}/%{name}.xml >/dev/null || :
+
+
+%postun
+if [ $1 -eq 0 ] ; then
+ %{pecl_uninstall} %{pecl_name} >/dev/null || :
+fi
+
+
+%check
+# Upstream test suite requires a Stomp server
+
+: Minimal load test for NTS extension
+%{__php} --no-php-ini \
+ --define extension=%{buildroot}%{php_extdir}/%{pecl_name}.so \
+ --modules | grep -i %{pecl_name}
+
+%if %{with_zts}
+: Minimal load test for ZTS extension
+%{__ztsphp} --no-php-ini \
+ --define extension=%{buildroot}%{php_ztsextdir}/%{pecl_name}.so \
+ --modules | grep -i %{pecl_name}
+%endif
+
+
+%clean
+rm -rf %{buildroot}
+
+
+%files
+%defattr(-,root,root,-)
+%{?_licensedir:%license NTS/LICENSE}
+%doc %{pecl_docdir}/%{pecl_name}
+%{pecl_xmldir}/%{name}.xml
+
+%config(noreplace) %{php_inidir}/%{ini_name}
+%{php_extdir}/%{pecl_name}.so
+
+%if %{with_zts}
+%config(noreplace) %{php_ztsinidir}/%{ini_name}
+%{php_ztsextdir}/%{pecl_name}.so
+%endif
+
+
+%changelog
+* Fri Oct 10 2014 Remi Collet <remi@fedoraproject.org> - 1.0.5-1
+- initial package, version 1.0.5 (stable) \ No newline at end of file