summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2016-05-26 17:34:27 +0200
committerRemi Collet <fedora@famillecollet.com>2016-05-26 17:34:27 +0200
commite127e9620a5b449b2df9610d65e3a01071fa7cc8 (patch)
tree5347d6267f44bb7a2626ab4b8930b0d2859a0219
parent7616609386b8c8485661562868120b7eaecebcf9 (diff)
php-pecl-stomp: 2.0.0 (php 7, beta)
-rw-r--r--REFLECTION-PHP7391
-rw-r--r--php-pecl-stomp-php7.spec31
2 files changed, 401 insertions, 21 deletions
diff --git a/REFLECTION-PHP7 b/REFLECTION-PHP7
new file mode 100644
index 0000000..e062a8a
--- /dev/null
+++ b/REFLECTION-PHP7
@@ -0,0 +1,391 @@
+Extension [ <persistent> extension #78 Stomp version 2.0.0 ] {
+
+ - INI {
+ Entry [ stomp.default_broker <ALL> ]
+ Current = 'tcp://localhost:61613'
+ }
+ Entry [ stomp.default_username <ALL> ]
+ Current = ''
+ }
+ Entry [ stomp.default_password <ALL> ]
+ Current = ''
+ }
+ Entry [ stomp.default_read_timeout_sec <ALL> ]
+ Current = '2'
+ }
+ Entry [ stomp.default_read_timeout_usec <ALL> ]
+ Current = '0'
+ }
+ Entry [ stomp.default_connection_timeout_sec <ALL> ]
+ Current = '2'
+ }
+ Entry [ stomp.default_connection_timeout_usec <ALL> ]
+ Current = '0'
+ }
+ }
+
+ - Functions {
+ Function [ <internal:Stomp> function stomp_version ] {
+
+ - Parameters [0] {
+ }
+ }
+ Function [ <internal:Stomp> function stomp_connect ] {
+
+ - Parameters [4] {
+ Parameter #0 [ <optional> $broker ]
+ Parameter #1 [ <optional> $username ]
+ Parameter #2 [ <optional> $password ]
+ Parameter #3 [ <optional> array or NULL $headers ]
+ }
+ }
+ Function [ <internal:Stomp> function stomp_connect_error ] {
+
+ - Parameters [0] {
+ }
+ }
+ Function [ <internal:Stomp> function stomp_get_session_id ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $link ]
+ }
+ }
+ Function [ <internal:Stomp> function stomp_close ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $link ]
+ }
+ }
+ Function [ <internal:Stomp> function stomp_send ] {
+
+ - Parameters [4] {
+ Parameter #0 [ <required> $link ]
+ Parameter #1 [ <required> $destination ]
+ Parameter #2 [ <required> $msg ]
+ Parameter #3 [ <optional> array or NULL $headers ]
+ }
+ }
+ Function [ <internal:Stomp> function stomp_subscribe ] {
+
+ - Parameters [3] {
+ Parameter #0 [ <required> $link ]
+ Parameter #1 [ <required> $destination ]
+ Parameter #2 [ <optional> array or NULL $headers ]
+ }
+ }
+ Function [ <internal:Stomp> function stomp_has_frame ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $link ]
+ }
+ }
+ Function [ <internal:Stomp> function stomp_read_frame ] {
+
+ - Parameters [2] {
+ Parameter #0 [ <required> $link ]
+ Parameter #1 [ <optional> $class_name ]
+ }
+ }
+ Function [ <internal:Stomp> function stomp_unsubscribe ] {
+
+ - Parameters [3] {
+ Parameter #0 [ <required> $link ]
+ Parameter #1 [ <required> $destination ]
+ Parameter #2 [ <optional> array or NULL $headers ]
+ }
+ }
+ Function [ <internal:Stomp> function stomp_begin ] {
+
+ - Parameters [3] {
+ Parameter #0 [ <required> $link ]
+ Parameter #1 [ <required> $transaction_id ]
+ Parameter #2 [ <optional> array or NULL $headers ]
+ }
+ }
+ Function [ <internal:Stomp> function stomp_commit ] {
+
+ - Parameters [3] {
+ Parameter #0 [ <required> $link ]
+ Parameter #1 [ <required> $transaction_id ]
+ Parameter #2 [ <optional> array or NULL $headers ]
+ }
+ }
+ Function [ <internal:Stomp> function stomp_abort ] {
+
+ - Parameters [3] {
+ Parameter #0 [ <required> $link ]
+ Parameter #1 [ <required> $transaction_id ]
+ Parameter #2 [ <optional> array or NULL $headers ]
+ }
+ }
+ Function [ <internal:Stomp> function stomp_ack ] {
+
+ - Parameters [3] {
+ Parameter #0 [ <required> $link ]
+ Parameter #1 [ <required> $msg ]
+ Parameter #2 [ <optional> array or NULL $headers ]
+ }
+ }
+ Function [ <internal:Stomp> function stomp_nack ] {
+
+ - Parameters [3] {
+ Parameter #0 [ <required> $link ]
+ Parameter #1 [ <required> $msg ]
+ Parameter #2 [ <optional> array or NULL $headers ]
+ }
+ }
+ Function [ <internal:Stomp> function stomp_error ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $link ]
+ }
+ }
+ Function [ <internal:Stomp> function stomp_set_read_timeout ] {
+
+ - Parameters [3] {
+ Parameter #0 [ <required> $link ]
+ Parameter #1 [ <required> $seconds ]
+ Parameter #2 [ <optional> $microseconds ]
+ }
+ }
+ Function [ <internal:Stomp> function stomp_get_read_timeout ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $link ]
+ }
+ }
+ }
+
+ - Classes [3] {
+ Class [ <internal:Stomp> class Stomp ] {
+
+ - Constants [0] {
+ }
+
+ - Static properties [0] {
+ }
+
+ - Static methods [0] {
+ }
+
+ - Properties [0] {
+ }
+
+ - Methods [16] {
+ Method [ <internal:Stomp, ctor> public method __construct ] {
+
+ - Parameters [4] {
+ Parameter #0 [ <optional> $broker ]
+ Parameter #1 [ <optional> $username ]
+ Parameter #2 [ <optional> $password ]
+ Parameter #3 [ <optional> array or NULL $headers ]
+ }
+ }
+
+ Method [ <internal:Stomp> public method getSessionId ] {
+
+ - Parameters [0] {
+ }
+ }
+
+ Method [ <internal:Stomp, dtor> public method __destruct ] {
+
+ - Parameters [0] {
+ }
+ }
+
+ Method [ <internal:Stomp> public method send ] {
+
+ - Parameters [3] {
+ Parameter #0 [ <required> $destination ]
+ Parameter #1 [ <required> $msg ]
+ Parameter #2 [ <optional> array or NULL $headers ]
+ }
+ }
+
+ Method [ <internal:Stomp> public method subscribe ] {
+
+ - Parameters [2] {
+ Parameter #0 [ <required> $destination ]
+ Parameter #1 [ <optional> array or NULL $headers ]
+ }
+ }
+
+ Method [ <internal:Stomp> public method hasFrame ] {
+
+ - Parameters [0] {
+ }
+ }
+
+ Method [ <internal:Stomp> public method readFrame ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <optional> $class_name ]
+ }
+ }
+
+ Method [ <internal:Stomp> public method unsubscribe ] {
+
+ - Parameters [2] {
+ Parameter #0 [ <required> $destination ]
+ Parameter #1 [ <optional> array or NULL $headers ]
+ }
+ }
+
+ Method [ <internal:Stomp> public method begin ] {
+
+ - Parameters [2] {
+ Parameter #0 [ <required> $transaction_id ]
+ Parameter #1 [ <optional> array or NULL $headers ]
+ }
+ }
+
+ Method [ <internal:Stomp> public method commit ] {
+
+ - Parameters [2] {
+ Parameter #0 [ <required> $transaction_id ]
+ Parameter #1 [ <optional> array or NULL $headers ]
+ }
+ }
+
+ Method [ <internal:Stomp> public method abort ] {
+
+ - Parameters [2] {
+ Parameter #0 [ <required> $transaction_id ]
+ Parameter #1 [ <optional> array or NULL $headers ]
+ }
+ }
+
+ Method [ <internal:Stomp> public method ack ] {
+
+ - Parameters [2] {
+ Parameter #0 [ <required> $msg ]
+ Parameter #1 [ <optional> array or NULL $headers ]
+ }
+ }
+
+ Method [ <internal:Stomp> public method nack ] {
+
+ - Parameters [2] {
+ Parameter #0 [ <required> $msg ]
+ Parameter #1 [ <optional> array or NULL $headers ]
+ }
+ }
+
+ Method [ <internal:Stomp> public method error ] {
+
+ - Parameters [0] {
+ }
+ }
+
+ Method [ <internal:Stomp> public method setReadTimeout ] {
+
+ - Parameters [2] {
+ Parameter #0 [ <required> $seconds ]
+ Parameter #1 [ <optional> $microseconds ]
+ }
+ }
+
+ Method [ <internal:Stomp> public method getReadTimeout ] {
+
+ - Parameters [0] {
+ }
+ }
+ }
+ }
+
+ Class [ <internal:Stomp> class StompFrame ] {
+
+ - Constants [0] {
+ }
+
+ - Static properties [0] {
+ }
+
+ - Static methods [0] {
+ }
+
+ - Properties [3] {
+ Property [ <default> public $command ]
+ Property [ <default> public $headers ]
+ Property [ <default> public $body ]
+ }
+
+ - Methods [1] {
+ Method [ <internal:Stomp, ctor> public method __construct ] {
+
+ - Parameters [3] {
+ Parameter #0 [ <optional> $command ]
+ Parameter #1 [ <optional> array or NULL $headers ]
+ Parameter #2 [ <optional> $body ]
+ }
+ }
+ }
+ }
+
+ Class [ <internal:Stomp> class StompException extends Exception implements Throwable ] {
+
+ - Constants [0] {
+ }
+
+ - Static properties [0] {
+ }
+
+ - Static methods [0] {
+ }
+
+ - Properties [5] {
+ Property [ <default> protected $message ]
+ Property [ <default> protected $code ]
+ Property [ <default> protected $file ]
+ Property [ <default> protected $line ]
+ Property [ <default> private $details ]
+ }
+
+ - Methods [11] {
+ Method [ <internal:Stomp> public method getDetails ] {
+
+ - Parameters [0] {
+ }
+ }
+
+ Method [ <internal:Core, inherits Exception, ctor> public method __construct ] {
+
+ - Parameters [3] {
+ Parameter #0 [ <optional> $message ]
+ Parameter #1 [ <optional> $code ]
+ Parameter #2 [ <optional> $previous ]
+ }
+ }
+
+ Method [ <internal:Core, inherits Exception> public method __wakeup ] {
+ }
+
+ Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getMessage ] {
+ }
+
+ Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getCode ] {
+ }
+
+ Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getFile ] {
+ }
+
+ Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getLine ] {
+ }
+
+ Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getTrace ] {
+ }
+
+ Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getPrevious ] {
+ }
+
+ Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getTraceAsString ] {
+ }
+
+ Method [ <internal:Core, inherits Exception, prototype Throwable> public method __toString ] {
+ }
+ }
+ }
+ }
+}
+
diff --git a/php-pecl-stomp-php7.spec b/php-pecl-stomp-php7.spec
index 1c4dac2..00c0668 100644
--- a/php-pecl-stomp-php7.spec
+++ b/php-pecl-stomp-php7.spec
@@ -11,25 +11,18 @@
%global with_zts 0%{!?_without_zts:%{?__ztsphp:1}}
%global pecl_name stomp
-%if "%{php_version}" < "5.6"
-# After sockets
-%global ini_name %{pecl_name}.ini
-%else
-# After 20-sockets
%global ini_name 40-%{pecl_name}.ini
-%endif
Summary: Stomp client extension
Name: %{?scl_prefix}php-pecl-%{pecl_name}
-Version: 1.0.9
-Release: 2%{?dist}%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}
+Version: 2.0.0
+Release: 1%{?dist}%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}
License: PHP
Group: Development/Languages
URL: http://pecl.php.net/package/%{pecl_name}
Source0: http://pecl.php.net/get/%{pecl_name}-%{version}.tgz
-BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
-BuildRequires: %{?scl_prefix}php-devel
+BuildRequires: %{?scl_prefix}php-devel > 7
BuildRequires: %{?scl_prefix}php-pear
BuildRequires: openssl-devel
@@ -41,8 +34,10 @@ Provides: %{?scl_prefix}php-%{pecl_name} = %{version}
Provides: %{?scl_prefix}php-%{pecl_name}%{?_isa} = %{version}
Provides: %{?scl_prefix}php-pecl(%{pecl_name}) = %{version}
Provides: %{?scl_prefix}php-pecl(%{pecl_name})%{?_isa} = %{version}
+%if "%{?scl_prefix}" != "%{?sub_prefix}"
Provides: %{?scl_prefix}php-pecl-%{pecl_name} = %{version}-%{release}
Provides: %{?scl_prefix}php-pecl-%{pecl_name}%{?_isa} = %{version}-%{release}
+%endif
%if "%{?vendor}" == "Remi Collet" && 0%{!?scl:1}
# Other third party repo stuff
@@ -50,14 +45,12 @@ Obsoletes: php53-pecl-%{pecl_name} <= %{version}
Obsoletes: php53u-pecl-%{pecl_name} <= %{version}
Obsoletes: php54-pecl-%{pecl_name} <= %{version}
Obsoletes: php54w-pecl-%{pecl_name} <= %{version}
-%if "%{php_version}" > "5.5"
Obsoletes: php55u-pecl-%{pecl_name} <= %{version}
Obsoletes: php55w-pecl-%{pecl_name} <= %{version}
-%endif
-%if "%{php_version}" > "5.6"
Obsoletes: php56u-pecl-%{pecl_name} <= %{version}
Obsoletes: php56w-pecl-%{pecl_name} <= %{version}
-%endif
+Obsoletes: php70u-pecl-%{pecl_name} <= %{version}
+Obsoletes: php70w-pecl-%{pecl_name} <= %{version}
%endif
%if 0%{?fedora} < 20 && 0%{?rhel} < 7
@@ -141,8 +134,6 @@ peclbuild %{_bindir}/zts-php-config
%install
-rm -rf %{buildroot}
-
make -C NTS install INSTALL_ROOT=%{buildroot}
# install config file
@@ -199,12 +190,7 @@ fi
%endif
-%clean
-rm -rf %{buildroot}
-
-
%files
-%defattr(-,root,root,-)
%{?_licensedir:%license NTS/LICENSE}
%doc %{pecl_docdir}/%{pecl_name}
%{pecl_xmldir}/%{name}.xml
@@ -219,6 +205,9 @@ rm -rf %{buildroot}
%changelog
+* Thu May 26 2016 Remi Collet <remi@fedoraproject.org> - 2.0.0-1
+- update to 2.0.0 (php 7, beta)
+
* Tue Mar 8 2016 Remi Collet <remi@fedoraproject.org> - 1.0.9-2
- adapt for F24