summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2017-05-04 08:36:57 +0200
committerRemi Collet <remi@remirepo.net>2017-05-04 08:36:57 +0200
commit9a9dc43b9b25b01c70df6284c0f2ce911749248e (patch)
tree7eb259234fb073858d573f23c5003572802821d2
parentf8b03da4abfd61ae0c35cecd8f6a73fb881ca65b (diff)
cleanup
-rw-r--r--REFLECTION-PHP7391
-rw-r--r--php-pecl-stomp-php7.spec248
-rw-r--r--stomp-upstream.patch56
3 files changed, 0 insertions, 695 deletions
diff --git a/REFLECTION-PHP7 b/REFLECTION-PHP7
deleted file mode 100644
index e062a8a..0000000
--- a/REFLECTION-PHP7
+++ /dev/null
@@ -1,391 +0,0 @@
-Extension [ <persistent> extension #78 Stomp version 2.0.0 ] {
-
- - INI {
- Entry [ stomp.default_broker <ALL> ]
- Current = 'tcp://localhost:61613'
- }
- Entry [ stomp.default_username <ALL> ]
- Current = ''
- }
- Entry [ stomp.default_password <ALL> ]
- Current = ''
- }
- Entry [ stomp.default_read_timeout_sec <ALL> ]
- Current = '2'
- }
- Entry [ stomp.default_read_timeout_usec <ALL> ]
- Current = '0'
- }
- Entry [ stomp.default_connection_timeout_sec <ALL> ]
- Current = '2'
- }
- Entry [ stomp.default_connection_timeout_usec <ALL> ]
- Current = '0'
- }
- }
-
- - Functions {
- Function [ <internal:Stomp> function stomp_version ] {
-
- - Parameters [0] {
- }
- }
- Function [ <internal:Stomp> function stomp_connect ] {
-
- - Parameters [4] {
- Parameter #0 [ <optional> $broker ]
- Parameter #1 [ <optional> $username ]
- Parameter #2 [ <optional> $password ]
- Parameter #3 [ <optional> array or NULL $headers ]
- }
- }
- Function [ <internal:Stomp> function stomp_connect_error ] {
-
- - Parameters [0] {
- }
- }
- Function [ <internal:Stomp> function stomp_get_session_id ] {
-
- - Parameters [1] {
- Parameter #0 [ <required> $link ]
- }
- }
- Function [ <internal:Stomp> function stomp_close ] {
-
- - Parameters [1] {
- Parameter #0 [ <required> $link ]
- }
- }
- Function [ <internal:Stomp> function stomp_send ] {
-
- - Parameters [4] {
- Parameter #0 [ <required> $link ]
- Parameter #1 [ <required> $destination ]
- Parameter #2 [ <required> $msg ]
- Parameter #3 [ <optional> array or NULL $headers ]
- }
- }
- Function [ <internal:Stomp> function stomp_subscribe ] {
-
- - Parameters [3] {
- Parameter #0 [ <required> $link ]
- Parameter #1 [ <required> $destination ]
- Parameter #2 [ <optional> array or NULL $headers ]
- }
- }
- Function [ <internal:Stomp> function stomp_has_frame ] {
-
- - Parameters [1] {
- Parameter #0 [ <required> $link ]
- }
- }
- Function [ <internal:Stomp> function stomp_read_frame ] {
-
- - Parameters [2] {
- Parameter #0 [ <required> $link ]
- Parameter #1 [ <optional> $class_name ]
- }
- }
- Function [ <internal:Stomp> function stomp_unsubscribe ] {
-
- - Parameters [3] {
- Parameter #0 [ <required> $link ]
- Parameter #1 [ <required> $destination ]
- Parameter #2 [ <optional> array or NULL $headers ]
- }
- }
- Function [ <internal:Stomp> function stomp_begin ] {
-
- - Parameters [3] {
- Parameter #0 [ <required> $link ]
- Parameter #1 [ <required> $transaction_id ]
- Parameter #2 [ <optional> array or NULL $headers ]
- }
- }
- Function [ <internal:Stomp> function stomp_commit ] {
-
- - Parameters [3] {
- Parameter #0 [ <required> $link ]
- Parameter #1 [ <required> $transaction_id ]
- Parameter #2 [ <optional> array or NULL $headers ]
- }
- }
- Function [ <internal:Stomp> function stomp_abort ] {
-
- - Parameters [3] {
- Parameter #0 [ <required> $link ]
- Parameter #1 [ <required> $transaction_id ]
- Parameter #2 [ <optional> array or NULL $headers ]
- }
- }
- Function [ <internal:Stomp> function stomp_ack ] {
-
- - Parameters [3] {
- Parameter #0 [ <required> $link ]
- Parameter #1 [ <required> $msg ]
- Parameter #2 [ <optional> array or NULL $headers ]
- }
- }
- Function [ <internal:Stomp> function stomp_nack ] {
-
- - Parameters [3] {
- Parameter #0 [ <required> $link ]
- Parameter #1 [ <required> $msg ]
- Parameter #2 [ <optional> array or NULL $headers ]
- }
- }
- Function [ <internal:Stomp> function stomp_error ] {
-
- - Parameters [1] {
- Parameter #0 [ <required> $link ]
- }
- }
- Function [ <internal:Stomp> function stomp_set_read_timeout ] {
-
- - Parameters [3] {
- Parameter #0 [ <required> $link ]
- Parameter #1 [ <required> $seconds ]
- Parameter #2 [ <optional> $microseconds ]
- }
- }
- Function [ <internal:Stomp> function stomp_get_read_timeout ] {
-
- - Parameters [1] {
- Parameter #0 [ <required> $link ]
- }
- }
- }
-
- - Classes [3] {
- Class [ <internal:Stomp> class Stomp ] {
-
- - Constants [0] {
- }
-
- - Static properties [0] {
- }
-
- - Static methods [0] {
- }
-
- - Properties [0] {
- }
-
- - Methods [16] {
- Method [ <internal:Stomp, ctor> public method __construct ] {
-
- - Parameters [4] {
- Parameter #0 [ <optional> $broker ]
- Parameter #1 [ <optional> $username ]
- Parameter #2 [ <optional> $password ]
- Parameter #3 [ <optional> array or NULL $headers ]
- }
- }
-
- Method [ <internal:Stomp> public method getSessionId ] {
-
- - Parameters [0] {
- }
- }
-
- Method [ <internal:Stomp, dtor> public method __destruct ] {
-
- - Parameters [0] {
- }
- }
-
- Method [ <internal:Stomp> public method send ] {
-
- - Parameters [3] {
- Parameter #0 [ <required> $destination ]
- Parameter #1 [ <required> $msg ]
- Parameter #2 [ <optional> array or NULL $headers ]
- }
- }
-
- Method [ <internal:Stomp> public method subscribe ] {
-
- - Parameters [2] {
- Parameter #0 [ <required> $destination ]
- Parameter #1 [ <optional> array or NULL $headers ]
- }
- }
-
- Method [ <internal:Stomp> public method hasFrame ] {
-
- - Parameters [0] {
- }
- }
-
- Method [ <internal:Stomp> public method readFrame ] {
-
- - Parameters [1] {
- Parameter #0 [ <optional> $class_name ]
- }
- }
-
- Method [ <internal:Stomp> public method unsubscribe ] {
-
- - Parameters [2] {
- Parameter #0 [ <required> $destination ]
- Parameter #1 [ <optional> array or NULL $headers ]
- }
- }
-
- Method [ <internal:Stomp> public method begin ] {
-
- - Parameters [2] {
- Parameter #0 [ <required> $transaction_id ]
- Parameter #1 [ <optional> array or NULL $headers ]
- }
- }
-
- Method [ <internal:Stomp> public method commit ] {
-
- - Parameters [2] {
- Parameter #0 [ <required> $transaction_id ]
- Parameter #1 [ <optional> array or NULL $headers ]
- }
- }
-
- Method [ <internal:Stomp> public method abort ] {
-
- - Parameters [2] {
- Parameter #0 [ <required> $transaction_id ]
- Parameter #1 [ <optional> array or NULL $headers ]
- }
- }
-
- Method [ <internal:Stomp> public method ack ] {
-
- - Parameters [2] {
- Parameter #0 [ <required> $msg ]
- Parameter #1 [ <optional> array or NULL $headers ]
- }
- }
-
- Method [ <internal:Stomp> public method nack ] {
-
- - Parameters [2] {
- Parameter #0 [ <required> $msg ]
- Parameter #1 [ <optional> array or NULL $headers ]
- }
- }
-
- Method [ <internal:Stomp> public method error ] {
-
- - Parameters [0] {
- }
- }
-
- Method [ <internal:Stomp> public method setReadTimeout ] {
-
- - Parameters [2] {
- Parameter #0 [ <required> $seconds ]
- Parameter #1 [ <optional> $microseconds ]
- }
- }
-
- Method [ <internal:Stomp> public method getReadTimeout ] {
-
- - Parameters [0] {
- }
- }
- }
- }
-
- Class [ <internal:Stomp> class StompFrame ] {
-
- - Constants [0] {
- }
-
- - Static properties [0] {
- }
-
- - Static methods [0] {
- }
-
- - Properties [3] {
- Property [ <default> public $command ]
- Property [ <default> public $headers ]
- Property [ <default> public $body ]
- }
-
- - Methods [1] {
- Method [ <internal:Stomp, ctor> public method __construct ] {
-
- - Parameters [3] {
- Parameter #0 [ <optional> $command ]
- Parameter #1 [ <optional> array or NULL $headers ]
- Parameter #2 [ <optional> $body ]
- }
- }
- }
- }
-
- Class [ <internal:Stomp> class StompException extends Exception implements Throwable ] {
-
- - Constants [0] {
- }
-
- - Static properties [0] {
- }
-
- - Static methods [0] {
- }
-
- - Properties [5] {
- Property [ <default> protected $message ]
- Property [ <default> protected $code ]
- Property [ <default> protected $file ]
- Property [ <default> protected $line ]
- Property [ <default> private $details ]
- }
-
- - Methods [11] {
- Method [ <internal:Stomp> public method getDetails ] {
-
- - Parameters [0] {
- }
- }
-
- Method [ <internal:Core, inherits Exception, ctor> public method __construct ] {
-
- - Parameters [3] {
- Parameter #0 [ <optional> $message ]
- Parameter #1 [ <optional> $code ]
- Parameter #2 [ <optional> $previous ]
- }
- }
-
- Method [ <internal:Core, inherits Exception> public method __wakeup ] {
- }
-
- Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getMessage ] {
- }
-
- Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getCode ] {
- }
-
- Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getFile ] {
- }
-
- Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getLine ] {
- }
-
- Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getTrace ] {
- }
-
- Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getPrevious ] {
- }
-
- Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getTraceAsString ] {
- }
-
- Method [ <internal:Core, inherits Exception, prototype Throwable> public method __toString ] {
- }
- }
- }
- }
-}
-
diff --git a/php-pecl-stomp-php7.spec b/php-pecl-stomp-php7.spec
deleted file mode 100644
index b06de50..0000000
--- a/php-pecl-stomp-php7.spec
+++ /dev/null
@@ -1,248 +0,0 @@
-# remimrepo/fedora spec file for php-pecl-stomp
-#
-# Copyright (c) 2014-2017 Remi Collet
-# License: CC-BY-SA
-# http://creativecommons.org/licenses/by-sa/4.0/
-#
-# Please, preserve the changelog entries
-#
-%{?scl: %scl_package php-pecl-stomp}
-%{!?scl: %global _root_prefix %{_prefix}}
-
-%global with_zts 0%{!?_without_zts:%{?__ztsphp:1}}
-%global pecl_name stomp
-%global ini_name 40-%{pecl_name}.ini
-
-Summary: Stomp client extension
-Name: %{?scl_prefix}php-pecl-%{pecl_name}
-Version: 2.0.0
-Release: 4%{?dist}%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}
-License: PHP
-Group: Development/Languages
-URL: http://pecl.php.net/package/%{pecl_name}
-Source0: http://pecl.php.net/get/%{pecl_name}-%{version}.tgz
-
-Patch0: %{pecl_name}-upstream.patch
-
-BuildRequires: %{?scl_prefix}php-devel > 7
-BuildRequires: %{?scl_prefix}php-pear
-BuildRequires: openssl-devel
-
-Requires: %{?scl_prefix}php(zend-abi) = %{php_zend_api}
-Requires: %{?scl_prefix}php(api) = %{php_core_api}
-%{?_sclreq:Requires: %{?scl_prefix}runtime%{?_sclreq}%{?_isa}}
-
-Provides: %{?scl_prefix}php-%{pecl_name} = %{version}
-Provides: %{?scl_prefix}php-%{pecl_name}%{?_isa} = %{version}
-Provides: %{?scl_prefix}php-pecl(%{pecl_name}) = %{version}
-Provides: %{?scl_prefix}php-pecl(%{pecl_name})%{?_isa} = %{version}
-%if "%{?scl_prefix}" != "%{?sub_prefix}"
-Provides: %{?scl_prefix}php-pecl-%{pecl_name} = %{version}-%{release}
-Provides: %{?scl_prefix}php-pecl-%{pecl_name}%{?_isa} = %{version}-%{release}
-%endif
-
-%if "%{?vendor}" == "Remi Collet" && 0%{!?scl:1} && 0%{?rhel}
-# Other third party repo stuff
-Obsoletes: php53-pecl-%{pecl_name} <= %{version}
-Obsoletes: php53u-pecl-%{pecl_name} <= %{version}
-Obsoletes: php54-pecl-%{pecl_name} <= %{version}
-Obsoletes: php54w-pecl-%{pecl_name} <= %{version}
-Obsoletes: php55u-pecl-%{pecl_name} <= %{version}
-Obsoletes: php55w-pecl-%{pecl_name} <= %{version}
-Obsoletes: php56u-pecl-%{pecl_name} <= %{version}
-Obsoletes: php56w-pecl-%{pecl_name} <= %{version}
-Obsoletes: php70u-pecl-%{pecl_name} <= %{version}
-Obsoletes: php70w-pecl-%{pecl_name} <= %{version}
-%if "%{php_version}" > "7.1"
-Obsoletes: php71u-pecl-%{pecl_name} <= %{version}
-Obsoletes: php71w-pecl-%{pecl_name} <= %{version}
-%endif
-%endif
-
-%if 0%{?fedora} < 20 && 0%{?rhel} < 7
-# Filter shared private
-%{?filter_provides_in: %filter_provides_in %{_libdir}/.*\.so$}
-%{?filter_setup}
-%endif
-
-
-%description
-This extension allows php applications to communicate with any
-Stomp compliant Message Brokers through easy object oriented
-and procedural interfaces.
-
-Documentation: http://php.net/stomp
-
-Package built for PHP %(%{__php} -r 'echo PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')%{?scl: as Software Collection (%{scl} by %{?scl_vendor}%{!?scl_vendor:rh})}.
-
-
-%prep
-%setup -q -c
-mv %{pecl_name}-%{version} NTS
-
-# Don't install/register tests
-sed -e 's/role="test"/role="src"/' \
- %{?_licensedir:-e '/LICENSE/s/role="doc"/role="src"/' } \
- -i package.xml
-
-cd NTS
-%patch0 -p1 -b .upstream
-
-# Sanity check, really often broken
-extver=$(sed -n '/#define PHP_STOMP_VERSION/{s/.* "//;s/".*$//;p}' php_stomp.h)
-if test "x${extver}" != "x%{version}%{?versuf}"; then
- : Error: Upstream extension version is ${extver}, expecting %{version}%{?versuf}.
- exit 1
-fi
-cd ..
-
-
-%if %{with_zts}
-# Duplicate source tree for NTS / ZTS build
-cp -pr NTS ZTS
-%endif
-
-# Create configuration file
-cat << 'EOF' | tee %{ini_name}
-; Enable %{summary} module
-extension=%{pecl_name}.so
-
-; See http://php.net/manual/en/stomp.configuration.php
-;stomp.default_broker = "tcp://localhost:61613"
-;stomp.default_username = ''
-;stomp.default_password = ''
-;stomp.default_read_timeout_sec = 2
-;stomp.default_read_timeout_usec = 0
-;stomp.default_connection_timeout_sec = 2
-;stomp.default_connection_timeout_usec = 0
-EOF
-
-
-%build
-peclbuild() {
-%configure \
- --enable-stomp \
- --with-openssl-dir=%{_root_prefix} \
- --with-libdir=%{_lib} \
- --with-php-config=$1
-
-make %{?_smp_mflags}
-}
-
-cd NTS
-%{_bindir}/phpize
-peclbuild %{_bindir}/php-config
-
-%if %{with_zts}
-cd ../ZTS
-%{_bindir}/zts-phpize
-peclbuild %{_bindir}/zts-php-config
-%endif
-
-
-%install
-make -C NTS install INSTALL_ROOT=%{buildroot}
-
-# install config file
-install -D -m 644 %{ini_name} %{buildroot}%{php_inidir}/%{ini_name}
-
-# Install XML package description
-install -D -m 644 package.xml %{buildroot}%{pecl_xmldir}/%{name}.xml
-
-%if %{with_zts}
-make -C ZTS install INSTALL_ROOT=%{buildroot}
-
-install -D -m 644 %{ini_name} %{buildroot}%{php_ztsinidir}/%{ini_name}
-%endif
-
-# Documentation
-for i in $(grep 'role="doc"' package.xml | sed -e 's/^.*name="//;s/".*$//')
-do install -Dpm 644 NTS/$i %{buildroot}%{pecl_docdir}/%{pecl_name}/$i
-done
-
-
-%if 0%{?fedora} < 24
-# when pear installed alone, after us
-%triggerin -- %{?scl_prefix}php-pear
-if [ -x %{__pecl} ] ; then
- %{pecl_install} %{pecl_xmldir}/%{name}.xml >/dev/null || :
-fi
-
-# posttrans as pear can be installed after us
-%posttrans
-if [ -x %{__pecl} ] ; then
- %{pecl_install} %{pecl_xmldir}/%{name}.xml >/dev/null || :
-fi
-
-%postun
-if [ $1 -eq 0 -a -x %{__pecl} ] ; then
- %{pecl_uninstall} %{pecl_name} >/dev/null || :
-fi
-%endif
-
-
-%check
-# Upstream test suite requires a Stomp server
-
-: Minimal load test for NTS extension
-%{__php} --no-php-ini \
- --define extension=%{buildroot}%{php_extdir}/%{pecl_name}.so \
- --modules | grep -i %{pecl_name}
-
-%if %{with_zts}
-: Minimal load test for ZTS extension
-%{__ztsphp} --no-php-ini \
- --define extension=%{buildroot}%{php_ztsextdir}/%{pecl_name}.so \
- --modules | grep -i %{pecl_name}
-%endif
-
-
-%files
-%{?_licensedir:%license NTS/LICENSE}
-%doc %{pecl_docdir}/%{pecl_name}
-%{pecl_xmldir}/%{name}.xml
-
-%config(noreplace) %{php_inidir}/%{ini_name}
-%{php_extdir}/%{pecl_name}.so
-
-%if %{with_zts}
-%config(noreplace) %{php_ztsinidir}/%{ini_name}
-%{php_ztsextdir}/%{pecl_name}.so
-%endif
-
-
-%changelog
-* Thu Dec 1 2016 Remi Collet <remi@fedoraproject.org> - 2.0.0-4
-- rebuild with PHP 7.1.0 GA
-
-* Wed Sep 14 2016 Remi Collet <remi@fedoraproject.org> - 2.0.0-3
-- rebuild for PHP 7.1 new API version
-
-* Fri Jun 10 2016 Remi Collet <remi@fedoraproject.org> - 2.0.0-2
-- add upstream patch for PHP 7.1
-
-* Thu May 26 2016 Remi Collet <remi@fedoraproject.org> - 2.0.0-1
-- update to 2.0.0 (php 7, beta)
-
-* Tue Mar 8 2016 Remi Collet <remi@fedoraproject.org> - 1.0.9-2
-- adapt for F24
-
-* Tue Jan 05 2016 Remi Collet <remi@fedoraproject.org> - 1.0.9-1
-- Update to 1.0.9 (stable)
-
-* Tue May 19 2015 Remi Collet <remi@fedoraproject.org> - 1.0.8-1
-- Update to 1.0.8 (stable, no change)
-
-* Sat May 16 2015 Remi Collet <remi@fedoraproject.org> - 1.0.7-1
-- Update to 1.0.7 (stable)
-- drop runtime dependency on pear, new scriptlets
-
-* Wed Dec 24 2014 Remi Collet <remi@fedoraproject.org> - 1.0.6-2.1
-- Fedora 21 SCL mass rebuild
-
-* Mon Dec 08 2014 Remi Collet <remi@fedoraproject.org> - 1.0.6-2
-- Update to 1.0.6 (stable)
-- enable openssl support
-
-* Fri Oct 10 2014 Remi Collet <remi@fedoraproject.org> - 1.0.5-1
-- initial package, version 1.0.5 (stable)
diff --git a/stomp-upstream.patch b/stomp-upstream.patch
deleted file mode 100644
index d53e166..0000000
--- a/stomp-upstream.patch
+++ /dev/null
@@ -1,56 +0,0 @@
-From 2a6ef9570e309b6d2d58f03ed80e305d7b2ea4cb Mon Sep 17 00:00:00 2001
-From: Pierrick Charron <pierrick@webstart.fr>
-Date: Thu, 9 Jun 2016 13:27:54 -0400
-Subject: [PATCH] Remove useless zend_fcall_info.function_table
-
----
- php_stomp.c | 2 ++
- 1 file changed, 2 insertions(+)
-
-diff --git a/php_stomp.c b/php_stomp.c
-index 96a08db..869e7ed 100644
---- a/php_stomp.c
-+++ b/php_stomp.c
-@@ -963,8 +963,10 @@ PHP_FUNCTION(stomp_read_frame)
- }
-
- fci.size = sizeof(fci);
-+#if (PHP_MAJOR_VERSION == 7 && PHP_MINOR_VERSION == 0)
- fci.function_table = &ce->function_table;
- fci.symbol_table = NULL;
-+#endif
-
- /* PARAMS */
- fci.param_count = 3;
---
-2.1.4
-
-From bd384b27c1ed0b188dd7fd21961d1f31628939cd Mon Sep 17 00:00:00 2001
-From: Pierrick Charron <pierrick@webstart.fr>
-Date: Thu, 9 Jun 2016 13:32:55 -0400
-Subject: [PATCH] get rid of EG(scope). zend_get_executed_scope() should be
- used instead
-
----
- php_stomp.c | 4 ++++
- 1 file changed, 4 insertions(+)
-
-diff --git a/php_stomp.c b/php_stomp.c
-index 869e7ed..dcde51f 100644
---- a/php_stomp.c
-+++ b/php_stomp.c
-@@ -982,7 +982,11 @@ PHP_FUNCTION(stomp_read_frame)
-
- fcc.initialized = 1;
- fcc.function_handler = ce->constructor;
-+#if (PHP_MAJOR_VERSION == 7 && PHP_MINOR_VERSION == 0)
- fcc.calling_scope = EG(scope);
-+#else
-+ fcc.calling_scope = zend_get_executed_scope();
-+#endif
- fcc.object = Z_OBJ_P(return_value);
-
- if (zend_call_function(&fci, &fcc ) == FAILURE) {
---
-2.1.4
-