summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2015-05-16 07:37:18 +0200
committerRemi Collet <fedora@famillecollet.com>2015-05-16 07:37:18 +0200
commit5a06dcbda3b06ef4b4654d2b082fef1a04b90de0 (patch)
tree1dc58d37e1a7eb3cd4ddde79bb00d086b8c4f1be
parent1ba4f4e040cb67ee234d9c92225725369a8cd523 (diff)
php-pecl-stomp: 1.0.7 (stable)
-rw-r--r--3_01.txt68
-rw-r--r--REFLECTION2
-rw-r--r--php-pecl-stomp.spec52
3 files changed, 40 insertions, 82 deletions
diff --git a/3_01.txt b/3_01.txt
deleted file mode 100644
index 6059c80..0000000
--- a/3_01.txt
+++ /dev/null
@@ -1,68 +0,0 @@
---------------------------------------------------------------------
- The PHP License, version 3.01
-Copyright (c) 1999 - 2014 The PHP Group. All rights reserved.
---------------------------------------------------------------------
-
-Redistribution and use in source and binary forms, with or without
-modification, is permitted provided that the following conditions
-are met:
-
- 1. Redistributions of source code must retain the above copyright
- notice, this list of conditions and the following disclaimer.
-
- 2. Redistributions in binary form must reproduce the above copyright
- notice, this list of conditions and the following disclaimer in
- the documentation and/or other materials provided with the
- distribution.
-
- 3. The name "PHP" must not be used to endorse or promote products
- derived from this software without prior written permission. For
- written permission, please contact group@php.net.
-
- 4. Products derived from this software may not be called "PHP", nor
- may "PHP" appear in their name, without prior written permission
- from group@php.net. You may indicate that your software works in
- conjunction with PHP by saying "Foo for PHP" instead of calling
- it "PHP Foo" or "phpfoo"
-
- 5. The PHP Group may publish revised and/or new versions of the
- license from time to time. Each version will be given a
- distinguishing version number.
- Once covered code has been published under a particular version
- of the license, you may always continue to use it under the terms
- of that version. You may also choose to use such covered code
- under the terms of any subsequent version of the license
- published by the PHP Group. No one other than the PHP Group has
- the right to modify the terms applicable to covered code created
- under this License.
-
- 6. Redistributions of any form whatsoever must retain the following
- acknowledgment:
- "This product includes PHP software, freely available from
- <http://www.php.net/software/>".
-
-THIS SOFTWARE IS PROVIDED BY THE PHP DEVELOPMENT TEAM ``AS IS'' AND
-ANY EXPRESSED OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO,
-THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A
-PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE PHP
-DEVELOPMENT TEAM OR ITS CONTRIBUTORS BE LIABLE FOR ANY DIRECT,
-INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES
-(INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR
-SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION)
-HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT,
-STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE)
-ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED
-OF THE POSSIBILITY OF SUCH DAMAGE.
-
---------------------------------------------------------------------
-
-This software consists of voluntary contributions made by many
-individuals on behalf of the PHP Group.
-
-The PHP Group can be contacted via Email at group@php.net.
-
-For more information on the PHP Group and the PHP project,
-please see <http://www.php.net>.
-
-PHP includes the Zend Engine, freely available at
-<http://www.zend.com>.
diff --git a/REFLECTION b/REFLECTION
index ec44644..1703511 100644
--- a/REFLECTION
+++ b/REFLECTION
@@ -1,4 +1,4 @@
-Extension [ <persistent> extension #145 Stomp version 1.0.6 ] {
+Extension [ <persistent> extension #152 Stomp version 1.0.7 ] {
- INI {
Entry [ stomp.default_broker <ALL> ]
diff --git a/php-pecl-stomp.spec b/php-pecl-stomp.spec
index 4283f53..44448a7 100644
--- a/php-pecl-stomp.spec
+++ b/php-pecl-stomp.spec
@@ -1,4 +1,4 @@
-# spec file for php-pecl-stomp
+# remimrepo/fedora spec file for php-pecl-stomp
#
# Copyright (c) 2014-2015 Remi Collet
# License: CC-BY-SA
@@ -24,22 +24,18 @@
Summary: Stomp client extension
Name: %{?scl_prefix}php-pecl-%{pecl_name}
-Version: 1.0.6
-Release: 2%{?dist}%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}.1
+Version: 1.0.7
+Release: 1%{?dist}%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}
License: PHP
Group: Development/Languages
URL: http://pecl.php.net/package/%{pecl_name}
Source0: http://pecl.php.net/get/%{pecl_name}-%{version}.tgz
-# URI from sources headers
-Source1: http://www.php.net/license/3_01.txt
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
BuildRequires: %{?scl_prefix}php-devel
BuildRequires: %{?scl_prefix}php-pear
BuildRequires: openssl-devel
-Requires(post): %{__pecl}
-Requires(postun): %{__pecl}
Requires: %{?scl_prefix}php(zend-abi) = %{php_zend_api}
Requires: %{?scl_prefix}php(api) = %{php_core_api}
%{?_sclreq:Requires: %{?scl_prefix}runtime%{?_sclreq}%{?_isa}}
@@ -89,13 +85,28 @@ mv %{pecl_name}-%{version} NTS
# Don't install/register tests
sed -e 's/role="test"/role="src"/' -i package.xml
+cd NTS
+
+sed -e '/PHP_STOMP_VERSION_STATUS/s/-dev//' -i php_stomp.h
+
+# Sanity check, really often broken
+extmajor=$(sed -n '/#define PHP_STOMP_MAJOR_VERSION/{s/.* "//;s/".*$//;p}' php_stomp.h)
+extminor=$(sed -n '/#define PHP_STOMP_MINOR_VERSION/{s/.* "//;s/".*$//;p}' php_stomp.h)
+extpatch=$(sed -n '/#define PHP_STOMP_PATCH_VERSION/{s/.* "//;s/".*$//;p}' php_stomp.h)
+extstate=$(sed -n '/#define PHP_STOMP_VERSION_STATUS/{s/.* "//;s/".*$//;p}' php_stomp.h)
+extver=${extmajor}.${extminor}.${extpatch}${extstate}
+if test "x${extver}" != "x%{version}%{?versuf}"; then
+ : Error: Upstream extension version is ${extver}, expecting %{version}%{?versuf}.
+ exit 1
+fi
+cd ..
+
+
%if %{with_zts}
# Duplicate source tree for NTS / ZTS build
cp -pr NTS ZTS
%endif
-cp %{SOURCE1} NTS/LICENSE
-
chmod -x ?TS/*.{c,h}
# Create configuration file
@@ -154,17 +165,28 @@ install -D -m 644 %{ini_name} %{buildroot}%{php_ztsinidir}/%{ini_name}
%endif
# Documentation
-for i in LICENSE $(grep 'role="doc"' package.xml | sed -e 's/^.*name="//;s/".*$//')
+for i in $(grep 'role="doc"' package.xml | sed -e 's/^.*name="//;s/".*$//')
do install -Dpm 644 NTS/$i %{buildroot}%{pecl_docdir}/%{pecl_name}/$i
done
-%post
-%{pecl_install} %{pecl_xmldir}/%{name}.xml >/dev/null || :
+# Don't install/register tests
+sed -e 's/role="test"/role="src"/' -i package.xml
+
+# when pear installed alone, after us
+%triggerin -- %{?scl_prefix}php-pear
+if [ -x %{__pecl} ] ; then
+ %{pecl_install} %{pecl_xmldir}/%{name}.xml >/dev/null || :
+fi
+# posttrans as pear can be installed after us
+%posttrans
+if [ -x %{__pecl} ] ; then
+ %{pecl_install} %{pecl_xmldir}/%{name}.xml >/dev/null || :
+fi
%postun
-if [ $1 -eq 0 ] ; then
+if [ $1 -eq 0 -a -x %{__pecl} ] ; then
%{pecl_uninstall} %{pecl_name} >/dev/null || :
fi
@@ -205,6 +227,10 @@ rm -rf %{buildroot}
%changelog
+* Sat May 16 2015 Remi Collet <remi@fedoraproject.org> - 1.0.7-1
+- Update to 1.0.7 (stable)
+- drop runtime dependency on pear, new scriptlets
+
* Wed Dec 24 2014 Remi Collet <remi@fedoraproject.org> - 1.0.6-2.1
- Fedora 21 SCL mass rebuild