summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2014-12-08 06:28:13 +0100
committerRemi Collet <fedora@famillecollet.com>2014-12-08 06:28:13 +0100
commit155ad65b7a9182a57067c661d4bd6e100e9aeee0 (patch)
tree5f3c6fbdf1956a1c7e076374a489ecc2c32e2c96
parentf64590042812fca458ed8359667cb150697ba6cb (diff)
php-pecl-stomp: 1.0.6 (stable)
-rw-r--r--REFLECTION26
-rw-r--r--php-pecl-stomp.spec8
2 files changed, 31 insertions, 3 deletions
diff --git a/REFLECTION b/REFLECTION
index f8e6c72..ec44644 100644
--- a/REFLECTION
+++ b/REFLECTION
@@ -1,9 +1,15 @@
-Extension [ <persistent> extension #143 Stomp version 1.0.5 ] {
+Extension [ <persistent> extension #145 Stomp version 1.0.6 ] {
- INI {
Entry [ stomp.default_broker <ALL> ]
Current = 'tcp://localhost:61613'
}
+ Entry [ stomp.default_username <ALL> ]
+ Current = ''
+ }
+ Entry [ stomp.default_password <ALL> ]
+ Current = ''
+ }
Entry [ stomp.default_read_timeout_sec <ALL> ]
Current = '2'
}
@@ -120,6 +126,14 @@ Extension [ <persistent> extension #143 Stomp version 1.0.5 ] {
Parameter #2 [ <optional> array or NULL $headers ]
}
}
+ Function [ <internal:Stomp> function stomp_nack ] {
+
+ - Parameters [3] {
+ Parameter #0 [ <required> $link ]
+ Parameter #1 [ <required> $msg ]
+ Parameter #2 [ <optional> array or NULL $headers ]
+ }
+ }
Function [ <internal:Stomp> function stomp_error ] {
- Parameters [1] {
@@ -157,7 +171,7 @@ Extension [ <persistent> extension #143 Stomp version 1.0.5 ] {
- Properties [0] {
}
- - Methods [15] {
+ - Methods [16] {
Method [ <internal:Stomp, ctor> public method __construct ] {
- Parameters [4] {
@@ -250,6 +264,14 @@ Extension [ <persistent> extension #143 Stomp version 1.0.5 ] {
}
}
+ Method [ <internal:Stomp> public method nack ] {
+
+ - Parameters [2] {
+ Parameter #0 [ <required> $msg ]
+ Parameter #1 [ <optional> array or NULL $headers ]
+ }
+ }
+
Method [ <internal:Stomp> public method error ] {
- Parameters [0] {
diff --git a/php-pecl-stomp.spec b/php-pecl-stomp.spec
index 874c2af..f943c8b 100644
--- a/php-pecl-stomp.spec
+++ b/php-pecl-stomp.spec
@@ -23,7 +23,7 @@
Summary: Stomp client extension
Name: %{?scl_prefix}php-pecl-%{pecl_name}
-Version: 1.0.5
+Version: 1.0.6
Release: 1%{?dist}%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}
License: PHP
Group: Development/Languages
@@ -76,6 +76,7 @@ Stomp compliant Message Brokers through easy object oriented
and procedural interfaces.
Documentation: http://php.net/stomp
+
Package built for PHP %(%{__php} -r 'echo PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')%{?scl: as Software Collection}.
@@ -102,6 +103,8 @@ extension=%{pecl_name}.so
; See http://php.net/manual/en/stomp.configuration.php
;stomp.default_broker = "tcp://localhost:61613"
+;stomp.default_username = ''
+;stomp.default_password = ''
;stomp.default_read_timeout_sec = 2
;stomp.default_read_timeout_usec = 0
;stomp.default_connection_timeout_sec = 2
@@ -198,5 +201,8 @@ rm -rf %{buildroot}
%changelog
+* Mon Dec 08 2014 Remi Collet <remi@fedoraproject.org> - 1.0.6-1
+- Update to 1.0.6 (stable)
+
* Fri Oct 10 2014 Remi Collet <remi@fedoraproject.org> - 1.0.5-1
- initial package, version 1.0.5 (stable) \ No newline at end of file