summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2012-06-10 07:06:04 +0200
committerRemi Collet <fedora@famillecollet.com>2012-06-10 07:06:04 +0200
commit24266a6c2f7d165089633dd4fd997325dcddc0bd (patch)
treee84a526dd35488df2b4054b69dbf0f22d573b73b
repo reorg
-rw-r--r--Makefile4
-rw-r--r--php-pecl-ssh2-0.10-README86
-rw-r--r--php-pecl-ssh2.spec175
3 files changed, 265 insertions, 0 deletions
diff --git a/Makefile b/Makefile
new file mode 100644
index 0000000..1e65467
--- /dev/null
+++ b/Makefile
@@ -0,0 +1,4 @@
+SRCDIR := $(shell pwd)
+NAME := $(shell basename $(SRCDIR))
+include ../common/Makefile
+
diff --git a/php-pecl-ssh2-0.10-README b/php-pecl-ssh2-0.10-README
new file mode 100644
index 0000000..3f59aad
--- /dev/null
+++ b/php-pecl-ssh2-0.10-README
@@ -0,0 +1,86 @@
+----------------------------------------
+See this link for more documentation:
+http://php.net/ssh2
+----------------------------------------
+
+CLIII. Secure Shell2 Functions
+Introduction
+
+Bindings to the libssh2 library which provide access to resources (shell, remote exec, tunneling, file transfer) on a remote machine using a secure cryptographic transport.
+
+Predefined Constants
+
+The constants below are defined by this extension, and will only be available when the extension has either been compiled into PHP or dynamically loaded at runtime.
+
+SSH2_FINGERPRINT_MD5 (integer)
+
+ Flag to ssh2_fingerprint() requesting hostkey fingerprint as an MD5 hash.
+SSH2_FINGERPRINT_SHA1 (integer)
+
+ Flag to ssh2_fingerprint() requesting hostkey fingerprint as an SHA1 hash.
+SSH2_FINGERPRINT_HEX (integer)
+
+ Flag to ssh2_fingerprint() requesting hostkey fingerprint as a string of hexits.
+SSH2_FINGERPRINT_RAW (integer)
+
+ Flag to ssh2_fingerprint() requesting hostkey fingerprint as a raw string of 8-bit characters.
+SSH2_TERM_UNIT_CHARS (integer)
+
+ Flag to ssh2_shell() specifying that width and height are provided as character sizes.
+SSH2_TERM_UNIT_PIXELS (integer)
+
+ Flag to ssh2_shell() specifying that width and height are provided in pixel units.
+SSH2_DEFAULT_TERM_WIDTH (integer)
+
+ Default terminal width requested by ssh2_shell().
+SSH2_DEFAULT_TERM_HEIGHT (integer)
+
+ Default terminal height requested by ssh2_shell().
+SSH2_DEFAULT_TERM_UNIT (integer)
+
+ Default terminal units requested by ssh2_shell().
+SSH2_STREAM_STDIO (integer)
+
+ Flag to ssh2_fetch_stream() requesting STDIO subchannel.
+SSH2_STREAM_STDERR (integer)
+
+ Flag to ssh2_fetch_stream() requesting STDERR subchannel.
+SSH2_DEFAULT_TERMINAL (string)
+
+ Default terminal type (e.g. vt102, ansi, xterm, vanilla) requested by ssh2_shell().
+
+
+Table of Contents:
+
+ssh2_auth_hostbased_file -- Authenticate using a public hostkey
+ssh2_auth_none -- Authenticate as "none"
+ssh2_auth_password -- Authenticate over SSH using a plain password
+ssh2_auth_pubkey_file -- Authenticate using a public key
+ssh2_connect -- Connect to an SSH server
+ssh2_exec -- Execute a command on a remote server
+ssh2_fetch_stream -- Fetch an extended data stream
+ssh2_fingerprint -- Retreive fingerprint of remote server
+ssh2_methods_negotiated -- Return list of negotiated methods
+ssh2_publickey_add -- Add an authorized publickey
+ssh2_publickey_init -- Initialize Publickey subsystem
+ssh2_publickey_list -- List currently authorized publickeys
+ssh2_publickey_remove -- Remove an authorized publickey
+ssh2_scp_recv -- Request a file via SCP
+ssh2_scp_send -- Send a file via SCP
+ssh2_sftp_lstat -- Stat a symbolic link
+ssh2_sftp_mkdir -- Create a directory
+ssh2_sftp_readlink -- Return the target of a symbolic link
+ssh2_sftp_realpath -- Resolve the realpath of a provided path string
+ssh2_sftp_rename -- Rename a remote file
+ssh2_sftp_rmdir -- Remove a directory
+ssh2_sftp_stat -- Stat a file on a remote filesystem
+ssh2_sftp_symlink -- Create a symlink
+ssh2_sftp_unlink -- Delete a file
+ssh2_sftp -- Initialize SFTP subsystem
+ssh2_shell -- Request an interactive shell
+ssh2_tunnel -- Open a tunnel through a remote server
+
+----------------------------------------
+See this link for more documentation:
+http://php.net/ssh2
+----------------------------------------
diff --git a/php-pecl-ssh2.spec b/php-pecl-ssh2.spec
new file mode 100644
index 0000000..8ddca97
--- /dev/null
+++ b/php-pecl-ssh2.spec
@@ -0,0 +1,175 @@
+%{!?__pecl: %{expand: %%global __pecl %{_bindir}/pecl}}
+
+%global pecl_name ssh2
+
+Name: php-pecl-ssh2
+Version: 0.11.3
+Release: 2%{?dist}
+Summary: Bindings for the libssh2 library
+
+# http://pecl.php.net/bugs/bug.php?id=24364
+License: PHP
+Group: Development/Languages
+URL: http://pecl.php.net/package/ssh2
+Source0: http://pecl.php.net/get/ssh2-%{version}.tgz
+Source2: php-pecl-ssh2-0.10-README
+
+BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
+BuildRequires: libssh2-devel php-devel php-pear
+
+Requires(post): %{__pecl}
+Requires(postun): %{__pecl}
+Provides: php-pecl(ssh2) = %{version}
+Requires: php(zend-abi) = %{php_zend_api}
+Requires: php(api) = %{php_core_api}
+
+
+# RPM 4.8
+%{?filter_provides_in: %filter_provides_in %{_libdir}/.*\.so$}
+%{?filter_setup}
+# RPM 4.9
+%global __provides_exclude_from %{?__provides_exclude_from:%__provides_exclude_from|}%{_libdir}/.*\\.so$
+
+
+%description
+Bindings to the libssh2 library which provide access to resources
+(shell, remote exec, tunneling, file transfer) on a remote machine using
+a secure cryptographic transport.
+
+Documentation : http://php.net/ssh2
+
+
+%prep
+%setup -c -q
+
+# http://pecl.php.net/bugs/bug.php?id=24390
+sed -i -e '/PHP_SSH2_VERSION/s/0.11.3-dev/0.11.3/' %{pecl_name}-%{version}/php_ssh2.h
+
+extver=$(sed -n '/#define PHP_SSH2_VERSION/{s/.* "//;s/".*$//;p}' %{pecl_name}-%{version}/php_ssh2.h)
+if test "x${extver}" != "x%{version}"; then
+ : Error: Upstream PDO ABI version is now ${extver}, expecting %{version}.
+ : Update the pdover macro and rebuild.
+ exit 1
+fi
+
+cp %{SOURCE2} README
+
+cat > ssh2.ini << 'EOF'
+; Enable ssh2 extension module
+extension=ssh2.so
+EOF
+
+cp -pr %{pecl_name}-%{version} %{pecl_name}-%{version}-zts
+
+
+%build
+cd %{pecl_name}-%{version}
+%{_bindir}/phpize
+%configure --with-php-config=%{_bindir}/php-config
+make %{?_smp_mflags}
+
+cd ../%{pecl_name}-%{version}-zts
+%{_bindir}/zts-phpize
+%configure --with-php-config=%{_bindir}/zts-php-config
+make %{?_smp_mflags}
+
+
+%install
+rm -rf %{buildroot}
+
+make -C %{pecl_name}-%{version} \
+ install INSTALL_ROOT=%{buildroot}
+
+make -C %{pecl_name}-%{version}-zts \
+ install INSTALL_ROOT=%{buildroot}
+
+# Install XML package description
+install -Dpm 644 package.xml %{buildroot}%{pecl_xmldir}/%{name}.xml
+
+# install config file
+install -Dpm644 ssh2.ini %{buildroot}%{php_inidir}/ssh2.ini
+install -Dpm644 ssh2.ini %{buildroot}%{php_ztsinidir}/ssh2.ini
+
+
+%check
+# Minimal load test for NTS extension
+%{__php} --no-php-ini \
+ --define extension_dir=%{pecl_name}-%{version}/modules \
+ --define extension=%{pecl_name}.so \
+ --modules | grep %{pecl_name}
+
+# Minimal load test for ZTS extension
+%{__ztsphp} --no-php-ini \
+ --define extension_dir=%{pecl_name}-%{version}-zts/modules \
+ --define extension=%{pecl_name}.so \
+ --modules | grep %{pecl_name}
+
+
+%post
+%{pecl_install} %{pecl_xmldir}/%{name}.xml >/dev/null || :
+
+
+%postun
+if [ $1 -eq 0 ] ; then
+ %{pecl_uninstall} %{pecl_name} >/dev/null || :
+fi
+
+
+%clean
+rm -rf %{buildroot}
+
+
+%files
+%defattr(-,root,root,-)
+%doc README
+%config(noreplace) %{php_inidir}/ssh2.ini
+%config(noreplace) %{php_ztsinidir}/ssh2.ini
+%{php_extdir}/ssh2.so
+%{php_ztsextdir}/ssh2.so
+%{pecl_xmldir}/%{name}.xml
+
+
+%changelog
+* Sun Nov 13 2011 Remi Collet <remi@fedoraproject.org> - 0.11.3-2
+- build against php 5.4
+
+* Sat Oct 04 2011 Remi Collet <RPMS@FamilleCollet.com> - 0.11.3-1
+- update to 0.11.3
+- zts extension
+
+* Tue Aug 16 2011 Remi Collet <RPMS@FamilleCollet.com> - 0.11.2-1.1
+- EL-5 rebuild for libssh2
+- add filter
+
+* Sat Apr 16 2011 Remi Collet <RPMS@FamilleCollet.com> - 0.11.2-1
+- update to 0.11.2
+- add minimal %%check
+
+* Wed Feb 09 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.11.0-7
+- Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
+
+* Thu Jan 14 2010 Chris Weyl <cweyl@alumni.drew.edu> 0.11.0-6
+- bump for libssh2 rebuild
+
+
+* Mon Sep 21 2009 Chris Weyl <cweyl@alumni.drew.edu> - 0.11.0-5
+- rebuild for libssh2 1.2
+
+* Sun Jul 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.11.0-4
+- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
+
+* Sun Jul 12 2009 Remi Collet <Fedora@FamilleCollet.com> - 0.11.0-3
+- add ssh2-php53.patch
+- rebuild for new PHP 5.3.0 ABI (20090626)
+
+* Thu Feb 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.11.0-2
+- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
+
+* Sat Dec 20 2008 Itamar Reis Peixoto <itamar@ispbrasil.com.br> 0.11.0-1
+- convert package.xml to V2 format, update to 0.11.0 #BZ 476405
+
+* Sat Nov 15 2008 Itamar Reis Peixoto <itamar@ispbrasil.com.br> 0.10-2
+- Install pecl xml, license and readme files
+
+* Wed Jul 16 2008 Itamar Reis Peixoto <itamar@ispbrasil.com.br> 0.10-1
+- Initial release