summaryrefslogtreecommitdiffstats
path: root/php-pecl-skywalking.spec
diff options
context:
space:
mode:
Diffstat (limited to 'php-pecl-skywalking.spec')
-rw-r--r--php-pecl-skywalking.spec25
1 files changed, 15 insertions, 10 deletions
diff --git a/php-pecl-skywalking.spec b/php-pecl-skywalking.spec
index 7d263da..03e2a66 100644
--- a/php-pecl-skywalking.spec
+++ b/php-pecl-skywalking.spec
@@ -16,19 +16,17 @@
%global with_zts 0
%global ini_name 40-%{pecl_name}.ini
# TODO need investigation
-%global with_tests 0%{?_with_tests:1}
+%bcond_with tests
Summary: The PHP instrument agent for Apache SkyWalking
Name: %{?sub_prefix}php-pecl-%{pecl_name}
-Version: 4.0.0
-Release: 2%{?dist}%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}
+Version: 4.1.0
+Release: 1%{?dist}%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}
Source0: https://pecl.php.net/get/%{pecl_name}-%{version}.tgz
License: ASL 2.0
URL: https://pecl.php.net/package/%{pecl_name}
-Patch0: https://patch-diff.githubusercontent.com/raw/SkyAPM/SkyAPM-php-sdk/pull/274.patch
-Patch1: https://patch-diff.githubusercontent.com/raw/SkyAPM/SkyAPM-php-sdk/pull/275.patch
-Patch2: https://patch-diff.githubusercontent.com/raw/SkyAPM/SkyAPM-php-sdk/pull/276.patch
+Patch0: https://patch-diff.githubusercontent.com/raw/SkyAPM/SkyAPM-php-sdk/pull/294.patch
BuildRequires: %{?dtsprefix}gcc
BuildRequires: %{?scl_prefix}php-devel > 7.0
@@ -96,9 +94,7 @@ sed -e 's/role="test"/role="src"/' \
-i package.xml
pushd NTS
-%patch0 -p1 -b .pr274
-%patch1 -p1 -b .pr275
-%patch2 -p1 -b .pr276
+%patch0 -p1 -b .pr294
: Check version
extver=$(sed -n '/#define PHP_SKYWALKING_VERSION /{s/.* "//;s/".*$//;p}' php_skywalking.h)
@@ -128,6 +124,8 @@ extension=%{pecl_name}.so
;skywalking.grpc_tls_pem_root_certs = ''
;skywalking.grpc_tls_pem_private_key = ''
;skywalking.grpc_tls_pem_cert_chain = ''
+;skywalking.log_enable = 0
+;skywalking.log_path = '/tmp/skywalking-php.log';
EOF
@@ -211,7 +209,7 @@ OPT="-n -d extension=curl.so -d extension=json.so"
--modules | grep %{pecl_name}
%endif
-%if %{with_tests}
+%if %{with tests}
: Upstream test suite for NTS extension
cd NTS
TEST_PHP_ARGS="$OPT -d extension=%{buildroot}%{php_extdir}/%{pecl_name}.so" \
@@ -245,8 +243,15 @@ TEST_PHP_EXECUTABLE=%{__ztsphp} \
%{php_ztsextdir}/%{pecl_name}.so
%endif
+# TODO : missing grpc in EPEL
%changelog
+* Fri Nov 13 2020 Remi Collet <remi@remirepo.net> - 4.1.0-1
+- update to 4.1.0
+- drop patches merged upstream
+- add patch to fix build with PHP 8 from
+ https://github.com/SkyAPM/SkyAPM-php-sdk/pull/294
+
* Thu Oct 15 2020 Remi Collet <remi@remirepo.net> - 4.0.0-2
- add patch to properly check available command from
https://github.com/SkyAPM/SkyAPM-php-sdk/pull/275