summaryrefslogtreecommitdiffstats
path: root/php-pecl-skywalking.spec
diff options
context:
space:
mode:
Diffstat (limited to 'php-pecl-skywalking.spec')
-rw-r--r--php-pecl-skywalking.spec43
1 files changed, 30 insertions, 13 deletions
diff --git a/php-pecl-skywalking.spec b/php-pecl-skywalking.spec
index 862d83e..adc39f8 100644
--- a/php-pecl-skywalking.spec
+++ b/php-pecl-skywalking.spec
@@ -11,27 +11,35 @@
%scl_package php-pecl-skywalking
%endif
-%global pecl_name skywalking
-%global with_zts 0%{!?_without_zts:%{?__ztsphp:1}}
-%global ini_name 40-%{pecl_name}.ini
+%global pecl_name skywalking
+# not supported by upstream
+%global with_zts 0
+%global ini_name 40-%{pecl_name}.ini
# TODO need investigation
%global with_tests 0%{?_with_tests:1}
Summary: The PHP instrument agent for Apache SkyWalking
Name: %{?sub_prefix}php-pecl-%{pecl_name}
-Version: 3.3.2
+Version: 4.0.0
Release: 1%{?dist}%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}
Source0: https://pecl.php.net/get/%{pecl_name}-%{version}.tgz
License: ASL 2.0
URL: https://pecl.php.net/package/%{pecl_name}
+Patch0: https://patch-diff.githubusercontent.com/raw/SkyAPM/SkyAPM-php-sdk/pull/274.patch
+
BuildRequires: %{?dtsprefix}gcc
-BuildRequires: %{?scl_prefix}php-devel > 7.1
+BuildRequires: %{?scl_prefix}php-devel > 7.0
BuildRequires: %{?scl_prefix}php-pear
BuildRequires: %{?scl_prefix}php-curl
BuildRequires: %{?scl_prefix}php-json
BuildRequires: %{?scl_prefix}php-pcre
BuildRequires: libcurl-devel
+BuildRequires: protobuf-devel
+BuildRequires: protobuf-compiler
+# Missing in EPEL https://bugzilla.redhat.com/1757147
+BuildRequires: grpc-devel
+BuildRequires: grpc-plugins
Requires: %{?scl_prefix}php(zend-abi) = %{php_zend_api}
Requires: %{?scl_prefix}php(api) = %{php_core_api}
@@ -49,19 +57,16 @@ Provides: %{?scl_prefix}php-pecl-%{pecl_name} = %{version}-%{rele
Provides: %{?scl_prefix}php-pecl-%{pecl_name}%{?_isa} = %{version}-%{release}
%endif
-%if "%{?vendor}" == "Remi Collet" && 0%{!?scl:1} && 0%{?rhel}
+%if "%{?packager}" == "Remi Collet" && 0%{!?scl:1} && 0%{?rhel}
# Other third party repo stuff
-%if "%{php_version}" > "7.2"
-Obsoletes: php72u-pecl-%{pecl_name} <= %{version}
-Obsoletes: php72w-pecl-%{pecl_name} <= %{version}
-%endif
%if "%{php_version}" > "7.3"
Obsoletes: php73-pecl-%{pecl_name} <= %{version}
-Obsoletes: php73w-pecl-%{pecl_name} <= %{version}
%endif
%if "%{php_version}" > "7.4"
Obsoletes: php74-pecl-%{pecl_name} <= %{version}
-Obsoletes: php74w-pecl-%{pecl_name} <= %{version}
+%endif
+%if "%{php_version}" > "8.0"
+Obsoletes: php80-pecl-%{pecl_name} <= %{version}
%endif
%endif
@@ -89,6 +94,8 @@ sed -e 's/role="test"/role="src"/' \
-i package.xml
pushd NTS
+%patch0 -p1 -b .pr
+
: Check version
extver=$(sed -n '/#define PHP_SKYWALKING_VERSION /{s/.* "//;s/".*$//;p}' php_skywalking.h)
if test "x${extver}" != "x%{version}%{?prever}"; then
@@ -111,7 +118,12 @@ extension=%{pecl_name}.so
;skywalking.enable = Off
;skywalking.version = 8
;skywalking.app_code = 'hello_skywalking'
-;skywalking.sock_path = '/tmp/sky-agent.sock'
+;skywalking.authentication = ''
+;skywalking.grpc = '127.0.0.1:11800'
+;skywalking.grpc_tls_enable = 0
+;skywalking.grpc_tls_pem_root_certs = ''
+;skywalking.grpc_tls_pem_private_key = ''
+;skywalking.grpc_tls_pem_cert_chain = ''
EOF
@@ -231,6 +243,11 @@ TEST_PHP_EXECUTABLE=%{__ztsphp} \
%changelog
+* Thu Oct 15 2020 Remi Collet <remi@remirepo.net> - 4.0.0-1
+- update to 4.0.0
+- add patch to properly use cxx for link from
+ https://github.com/SkyAPM/SkyAPM-php-sdk/pull/274
+
* Fri Jun 5 2020 Remi Collet <remi@remirepo.net> - 3.3.2-1
- update to 3.3.2