summaryrefslogtreecommitdiffstats
path: root/php-pecl-selinux.spec
diff options
context:
space:
mode:
Diffstat (limited to 'php-pecl-selinux.spec')
-rw-r--r--php-pecl-selinux.spec56
1 files changed, 31 insertions, 25 deletions
diff --git a/php-pecl-selinux.spec b/php-pecl-selinux.spec
index 9422d66..e0e7565 100644
--- a/php-pecl-selinux.spec
+++ b/php-pecl-selinux.spec
@@ -1,7 +1,7 @@
# remirepo spec file for php-pecl-selinux
# adapted for SCL
#
-# Copyright (c) 2011-2020 Remi Collet
+# Copyright (c) 2011-2023 Remi Collet
#
# Fedora spec file for php-pecl-selinux
#
@@ -17,13 +17,12 @@
%undefine _strict_symbol_defs_build
%if 0%{?scl:1}
-%global sub_prefix %{scl_prefix}
%scl_package php-pecl-selinux
%endif
%global pecl_name selinux
%global with_zts 0%{!?_without_zts:%{?__ztsphp:1}}
-%global with_tests %{?_without_tests:0}%{!?_without_tests:1}
+%global with_tests 0%{!?_without_tests:1}
%if "%{php_version}" < "5.6"
%global ini_name %{pecl_name}.ini
%else
@@ -31,47 +30,39 @@
%endif
Summary: SELinux binding for PHP scripting language
-Name: %{?sub_prefix}php-pecl-selinux
-Version: 0.5.0
-Release: 4%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
-License: PHP
+Name: %{?scl_prefix}php-pecl-selinux
+Version: 0.6.0
+Release: 3%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
+License: PHP-3.01
URL: https://pecl.php.net/package/%{pecl_name}
Source0: https://pecl.php.net/get/%{pecl_name}-%{version}.tgz
+BuildRequires: make
BuildRequires: %{?dtsprefix}gcc
-BuildRequires: %{?scl_prefix}php-devel > 7
+BuildRequires: %{?scl_prefix}php-devel >= 7.0
BuildRequires: %{?scl_prefix}php-pear
BuildRequires: libselinux-devel >= 2.0.80
Requires: %{?scl_prefix}php(zend-abi) = %{php_zend_api}
Requires: %{?scl_prefix}php(api) = %{php_core_api}
Requires: libselinux >= 2.0.80
-%{?_sclreq:Requires: %{?scl_prefix}runtime%{?_sclreq}%{?_isa}}
Provides: %{?scl_prefix}php-%{pecl_name} = %{version}
Provides: %{?scl_prefix}php-%{pecl_name}%{?_isa} = %{version}
Provides: %{?scl_prefix}php-pecl(%{pecl_name}) = %{version}
Provides: %{?scl_prefix}php-pecl(%{pecl_name})%{?_isa} = %{version}
-Provides: %{?scl_prefix}php-pecl-%{pecl_name} = %{version}-%{release}
-Provides: %{?scl_prefix}php-pecl-%{pecl_name}%{?_isa} = %{version}-%{release}
%if "%{?packager}" == "Remi Collet" && 0%{!?scl:1} && 0%{?rhel}
# Other third party repo stuff
-%if "%{php_version}" > "7.3"
-Obsoletes: php73-pecl-%{pecl_name} <= %{version}
-%endif
%if "%{php_version}" > "7.4"
Obsoletes: php74-pecl-%{pecl_name} <= %{version}
%endif
%if "%{php_version}" > "8.0"
Obsoletes: php80-pecl-%{pecl_name} <= %{version}
%endif
+%if "%{php_version}" > "8.1"
+Obsoletes: php81-pecl-%{pecl_name} <= %{version}
%endif
-
-%if 0%{?fedora} < 20 && 0%{?rhel} < 7
-# Filter private shared object
-%{?filter_provides_in: %filter_provides_in %{_libdir}/.*\.so$}
-%{?filter_setup}
%endif
@@ -121,14 +112,16 @@ cp -pr NTS ZTS
cd NTS
%{_bindir}/phpize
%configure \
- --with-php-config=%{_bindir}/php-config
+ --with-php-config=%{_bindir}/php-config \
+ --enable-selinux
make %{?_smp_mflags}
%if %{with_zts}
cd ../ZTS
%{_bindir}/zts-phpize
%configure \
- --with-php-config=%{_bindir}/zts-php-config
+ --with-php-config=%{_bindir}/zts-php-config \
+ --enable-selinux
make %{?_smp_mflags}
%endif
@@ -159,24 +152,22 @@ done
%check
-cd NTS
: Minimal load test for NTS extension
%{__php} --no-php-ini \
--define extension=%{buildroot}%{php_extdir}/%{pecl_name}.so \
--modules | grep '^%{pecl_name}$'
%if %{with_tests}
+cd NTS
: Upstream test suite for NTS extension
TEST_PHP_EXECUTABLE=%{__php} \
TEST_PHP_ARGS="-n -d extension=$PWD/modules/%{pecl_name}.so" \
-NO_INTERACTION=1 \
REPORT_EXIT_STATUS=0 \
-%{__php} -n run-tests.php --show-diff
+%{__php} -n run-tests.php -q --show-diff
: Ignore result as unreliable in mock
%endif
%if %{with_zts}
-cd ../ZTS
: Minimal load test for ZTS extension
%{__ztsphp} --no-php-ini \
--define extension=%{buildroot}%{php_ztsextdir}/%{pecl_name}.so \
@@ -220,6 +211,21 @@ fi
%changelog
+* Wed Aug 30 2023 Remi Collet <remi@remirepo.net> - 0.6.0-3
+- rebuild for PHP 8.3.0RC1
+
+* Thu Sep 1 2022 Remi Collet <remi@remirepo.net> - 0.6.0-2
+- rebuild for PHP 8.2.0RC1
+
+* Thu Dec 23 2021 Remi Collet <remi@remirepo.net> - 0.6.0-1
+- update to 0.6.0
+
+* Wed Dec 22 2021 Remi Collet <remi@remirepo.net> - 0.5.0-7
+- cleanup spec file
+
+* Wed Sep 01 2021 Remi Collet <remi@remirepo.net> - 0.5.0-5
+- rebuild for 8.1.0RC1
+
* Wed Sep 30 2020 Remi Collet <remi@remirepo.net> - 0.5.0-4
- rebuild for PHP 8.0.0RC1