summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--REFLECTION19
-rw-r--r--php-pecl-selinux.spec24
2 files changed, 29 insertions, 14 deletions
diff --git a/REFLECTION b/REFLECTION
index 04616b6..f5d621d 100644
--- a/REFLECTION
+++ b/REFLECTION
@@ -1,4 +1,4 @@
-Extension [ <persistent> extension #126 selinux version <no_version> ] {
+Extension [ <persistent> extension #144 selinux version 0.4.1 ] {
- Functions {
Function [ <internal:selinux> function selinux_is_enabled ] {
@@ -153,10 +153,11 @@ Extension [ <persistent> extension #126 selinux version <no_version> ] {
}
Function [ <internal:selinux> function selinux_compute_create ] {
- - Parameters [3] {
+ - Parameters [4] {
Parameter #0 [ <required> $scontext ]
Parameter #1 [ <required> $tcontext ]
Parameter #2 [ <required> $tclass ]
+ Parameter #3 [ <optional> $name ]
}
}
Function [ <internal:selinux> function selinux_compute_relabel ] {
@@ -260,6 +261,20 @@ Extension [ <persistent> extension #126 selinux version <no_version> ] {
Parameter #2 [ <optional> $specfile ]
}
}
+ Function [ <internal:selinux> function selinux_x_label_lookup ] {
+
+ - Parameters [2] {
+ Parameter #0 [ <required> $x_key ]
+ Parameter #1 [ <required> $x_type ]
+ }
+ }
+ Function [ <internal:selinux> function selinux_db_label_lookup ] {
+
+ - Parameters [2] {
+ Parameter #0 [ <required> $db_key ]
+ Parameter #1 [ <required> $db_type ]
+ }
+ }
Function [ <internal:selinux> function selinux_getenforcemode ] {
- Parameters [0] {
diff --git a/php-pecl-selinux.spec b/php-pecl-selinux.spec
index 04f74df..35ed733 100644
--- a/php-pecl-selinux.spec
+++ b/php-pecl-selinux.spec
@@ -1,6 +1,9 @@
-# spec file for php-pecl-selinux
+# remirepo spec file for php-pecl-selinux
#
# Copyright (c) 2011-2015 Remi Collet
+#
+# Fedora spec file for php-pecl-selinux
+#
# Copyright (c) 2009-2010 KaiGai Kohei
#
# License: MIT
@@ -24,14 +27,12 @@
Summary: SELinux binding for PHP scripting language
Name: %{?scl_prefix}php-pecl-selinux
-Version: 0.3.1
-Release: 17%{?dist}%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}
+Version: 0.4.1
+Release: 1%{?dist}%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}
License: PHP
Group: Development/Languages
URL: http://pecl.php.net/package/%{pecl_name}
-#Source0: http://pecl.php.net/get/%{pecl_name}-%{version}.tgz
-# SVN snapshot
-Source0: http://pecl.php.net/get/%{pecl_name}-0.4.1dev.tgz
+Source0: http://pecl.php.net/get/%{pecl_name}-%{version}.tgz
BuildRoot: %(mktemp -ud %{_tmppath}/%{name}-%{version}-%{release}-XXXXXX)
BuildRequires: %{?scl_prefix}php-devel >= 5.2.0
@@ -88,17 +89,13 @@ Package built for PHP %(%{__php} -r 'echo PHP_MAJOR_VERSION.".".PHP_MINOR_VERSIO
%prep
%setup -c -q
-mv %{pecl_name}-0.4.1dev NTS
+mv %{pecl_name}-%{version} NTS
# Don't install/register tests
-# Keep version as 0.3.1 for now
sed -e 's/role="test"/role="src"/' \
- -e 's/0.4.1dev/0.3.1/' \
-i package.xml
pushd NTS
-sed -e 's/"0.4.1dev"/"0.3.1"/' -i php_selinux.h
-
extver=$(sed -n '/#define PHP_SELINUX_VERSION/{s/.* "//;s/".*$//;p}' php_selinux.h)
if test "x${extver}" != "x%{version}"; then
: Error: Upstream extension version is ${extver}, expecting %{version}.
@@ -152,7 +149,7 @@ make -C ZTS install INSTALL_ROOT=%{buildroot}
install -D -m 644 %{ini_name} %{buildroot}%{php_ztsinidir}/%{ini_name}
%endif
-# Test & Documentation
+# Documentation
cd NTS
for i in $(grep 'role="doc"' ../package.xml | sed -e 's/^.*name="//;s/".*$//')
do install -Dpm 644 $i %{buildroot}%{pecl_docdir}/%{pecl_name}/$i
@@ -224,6 +221,9 @@ fi
%changelog
+* Sun May 24 2015 Remi Collet <remi@fedoraproject.org> - 0.4.1-1
+- version 0.4.1 (beta)
+
* Sun Apr 5 2015 Remi Collet <remi@fedoraproject.org> - 0.3.1-17
- add upstream fix for PHP 7
- drop runtime dependency on pear, new scriptlets