summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2018-11-26 07:15:15 +0100
committerRemi Collet <remi@remirepo.net>2018-11-26 07:15:15 +0100
commitc70f77700976b2d97855ceed220aeacbf81b61e5 (patch)
treedcb203ba3839e7cd5ae77f378c62606f1abd1363
parent25709bafecbf82e7e06c878597b4a902e842937b (diff)
v1.9.0
-rw-r--r--PHPINFO2
-rw-r--r--REFLECTION27
-rw-r--r--php-pecl-seaslog.spec5
3 files changed, 28 insertions, 6 deletions
diff --git a/PHPINFO b/PHPINFO
index 5e5f262..038b8b7 100644
--- a/PHPINFO
+++ b/PHPINFO
@@ -2,7 +2,7 @@
SeasLog
SeasLog support => Enabled
-SeasLog Version => 1.8.6
+SeasLog Version => 1.9.0
SeasLog Author => Chitao.Gao [ neeke@php.net ]
SeasLog Supports => https://github.com/SeasX/SeasLog
diff --git a/REFLECTION b/REFLECTION
index 3b4e13f..863e13f 100644
--- a/REFLECTION
+++ b/REFLECTION
@@ -1,4 +1,4 @@
-Extension [ <persistent> extension #198 SeasLog version 1.8.6 ] {
+Extension [ <persistent> extension #197 SeasLog version 1.9.0 ] {
- Dependencies {
}
@@ -78,8 +78,8 @@ Extension [ <persistent> extension #198 SeasLog version 1.8.6 ] {
}
}
- - Constants [18] {
- Constant [ string SEASLOG_VERSION ] { 1.8.6 }
+ - Constants [22] {
+ Constant [ string SEASLOG_VERSION ] { 1.9.0 }
Constant [ string SEASLOG_AUTHOR ] { Chitao.Gao [ neeke@php.net ] }
Constant [ string SEASLOG_ALL ] { ALL }
Constant [ string SEASLOG_DEBUG ] { DEBUG }
@@ -97,6 +97,10 @@ Extension [ <persistent> extension #198 SeasLog version 1.8.6 ] {
Constant [ integer SEASLOG_APPENDER_UDP ] { 3 }
Constant [ integer SEASLOG_CLOSE_LOGGER_STREAM_MOD_ALL ] { 1 }
Constant [ integer SEASLOG_CLOSE_LOGGER_STREAM_MOD_ASSIGN ] { 2 }
+ Constant [ integer SEASLOG_REQUEST_VARIABLE_DOMAIN_PORT ] { 1 }
+ Constant [ integer SEASLOG_REQUEST_VARIABLE_REQUEST_URI ] { 2 }
+ Constant [ integer SEASLOG_REQUEST_VARIABLE_REQUEST_METHOD ] { 3 }
+ Constant [ integer SEASLOG_REQUEST_VARIABLE_CLIENT_IP ] { 4 }
}
- Functions {
@@ -115,7 +119,7 @@ Extension [ <persistent> extension #198 SeasLog version 1.8.6 ] {
- Static properties [0] {
}
- - Static methods [23] {
+ - Static methods [25] {
Method [ <internal:SeasLog> static public method setBasePath ] {
- Parameters [1] {
@@ -164,6 +168,21 @@ Extension [ <persistent> extension #198 SeasLog version 1.8.6 ] {
Method [ <internal:SeasLog> static public method getDatetimeFormat ] {
}
+ Method [ <internal:SeasLog> static public method setRequestVariable ] {
+
+ - Parameters [2] {
+ Parameter #0 [ <required> $key ]
+ Parameter #1 [ <optional> $value ]
+ }
+ }
+
+ Method [ <internal:SeasLog> static public method getRequestVariable ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $key ]
+ }
+ }
+
Method [ <internal:SeasLog> static public method analyzerCount ] {
- Parameters [3] {
diff --git a/php-pecl-seaslog.spec b/php-pecl-seaslog.spec
index 7e4857e..0f9f0a5 100644
--- a/php-pecl-seaslog.spec
+++ b/php-pecl-seaslog.spec
@@ -25,7 +25,7 @@
Summary: An effective, fast, stable log extension for PHP
Name: %{?sub_prefix}php-pecl-%{pecl_name}
-Version: 1.8.6
+Version: 1.9.0
Release: 1%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
License: PHP
URL: http://pecl.php.net/package/%{proj_name}
@@ -249,6 +249,9 @@ fi
%changelog
+* Mon Nov 26 2018 Remi Collet <remi@remirepo.net> - 1.9.0-1
+- update to 1.9.0
+
* Sat Sep 8 2018 Remi Collet <remi@remirepo.net> - 1.8.6-1
- update to 1.8.6